Maverick with AMD System. - Hackintosh Mavericks - Hackintosh Zone Jump to content
oilzds

Maverick with AMD System.

Recommended Posts

Hello everyone!

I recently tried to install Maverick in dual boot with windows 7 and i've encountered a few problems(why am i not surprised? :D ).

Here my specs

CPU: Amd fx 8320
GPU: Sapphire R9 280x Vapor x

Motherboard: Asus M5A97 EVO R2.0

Ram: Kingston 8GB 1600mhz

..and other stuff that i think they don't matter.

I know, it might not be the best compatible system but it's what i have.

So this is what i've done: set a 200Gb Partition for Maverick, prepared a bootable drive with the maverick image then boot from USB, type amdfx -v (according to a videoguide i saw where the guy had my same processor and similar motherboard, he had the "normal" one istead of the EVO version) in the black screen/white keys where you have to select which drive to boot, erase the partition as Mac os Extended Journaled click install and then which kext or plugin i should select to make a correct installation with my pc specs?

After the installation is finished what i have to do?
In one of my previous try i was unable to boot proprely if i didn't type "-x GraphicsEnabler=No". And the system started in safemode. After it booted i've waited to get it set up. And then reboot.
Here comes again the problems. If i let it boot without doing anything i get stuck when appear the apple logo with the loading circle but if i let it boot typing "-v GraphicsEnabler=No "Kernel Cache"=amdfx" it boot (allmost)proprely with 1920x1080 resolution and not in safemode.

But there are two problems at this point(as much as i can tell) an annoyng constant noise coming out from my headset and speakers(probably caused by missing Audio driver), and flickering graphics expecially when using Safari and evrething(graphically speaking) it's not as smooth as it should be.

I'm planning to do a new try from zero so can you guide me in the process telling me which plugins i should select before the installation process, how to boot proprely after the installation,which kext/driver i should install according to my system specs?

 

I'm not a great expert as may you can tell from how i've explained myself because i don't know every terminology and other stuff so please, be easy and patient on me, i can do it but with some help (:
Thank to everyone who will help me i'm sorry if i said something wrong and for my english, i'm from Italy. Bye

  • Like 1

Share this post


Link to post
Share on other sites

this is my PC scpecifications:

M/B Asus M4A78

CPU AMD Athlon II X4 630

RAM Patriot 2gb DDR2 800MHz

VGA GF 9800GT 1GB

(SOUND:  ALC887 )

 

I installed Mac OS X 10.9 Mavericks ( niresh ) and in post-installation level when I should configure language, user data and something like that I encountered to freezes, I search some keywords and I got some answers. I used just        "Kernel Cache"=amd        and it worked for me but after OS X was loaded

I am experiencing problems like yours and specially the worst is annoying constant noise and I can barely hear a voice even with high sound volume.

graphic isn't smooth. I see some color and shape distortion in the right edge of many drop-down menus like safari. in launchpad all icons were in  red and pink color ( I just see this one time and after second restart it wasn't there )

oh and one thing I want to do a new installation like oilzds and I want to select proper kexts ( or I provide/download them )

any help will be appreciated.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Shahram!

For the graphics problem i don't know what to do, but for the Audio kext with Multibeast, maybe it will work for you too but your motherboard is different so i don't know which ones you need exactly.

At this moment i can boot the system proprely(allmost, there are still the graphics problems) but only typing -v GraphicsEnabler=No "KernelCache"=amdfx before booting the drive where osx is installed, there is a way to avoid doing that every time?

  • Like 1

Share this post


Link to post
Share on other sites

hi oilzds.

your sound chipset model is ALC892 and it is different from mine.

I have deleted niresh mavericks for now and I want to do a informed installing this time. I had seroius problems in dual-boot with windows 7 and at the end I blow up mac os x :D I tried many programs but there was any useful result.

did you try just  "Kernel Cache"=amd ?

  • Like 1

Share this post


Link to post
Share on other sites

No, i haven't tryed typing "Kernel Cache"=amd and now i can't boot in osx in any way, i probably touched something wrong i have to install everything again. At least windows 7 works with no problems.
I don't have any news with the graphic problem  but i'm wondering if there is any way to boot osx without typing anything all the times.
Another thing...When i boot maverick typing -v GraphicsEnabler=No "KernelCache"=amdfx on the top left corner of the screen appear something like "Amd kernel not found" or something like that, there's a way to solve that or is it normal?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $48.99 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • So I tried to install Mac OS X Sierra on my computer with the following specs :   - Intel Core i5 650 3.20GHZ - 12GB RAM DDR3 - 2 HDD (.1TB , 250GB ) - Nvidia Geforce 210 1GB VRAM DDR3   Everything was cool at first the installation went smoothly with no problems, after setting up everything I noticed that the graphics card has been detected by the systems but there is no acceleration and the resolution is 1024x768, I couldn’t change it   I tried a lot of kext drivers from multiple websites but no success, last kext crashes my os, I start getting black screen after the login page, and the computer restart it self immediately, so I decided to mess with the clover options to find if I can enable the graphics card from there, and WALLAA, the magic happened, I went to clover options then > Graphics Injector Menu > I checked : InjectNvidia option, and I checked : Use NVIDIA WEB Drivers   Note : I already installed Nvidia web drivers previously so you do that too before trying this method   After the restart it took longer then the usual to boot up, but once it got to the login page I noticed that the acceleration is working perfectly and the graphics has no bugs like before.   So until now everything is working fine and I’m enjoying my experience with Mac Sierra  
    • HI, I have the same issue. I have integrated Intel HD4000 and nVidia 620m. I tried with IGPEnabler, GraphicsEnabler and nv_disabled bootflags but none of them helped, it just got me additional kernel panic "AppleUSBHostPort: :disconnect: persistant enumeration failures". I also don't have option to turn off any of my graphic cards in BIOS.  Is there any solution to this issue?
    • ya no documentation ..and iam so confused to ..can some one make tutorial
    • Desktop Specs 
      Mob-: MSI X99a Godlike Gaming (MS-7883) (supports Legacy+UEFI)
      CPU- Intel 5820k (Haswell E)
      Graphics- MSI 980ti
      Ram- Avexir ddr4 8x4gb also, i have attempted using: OsxAptioFix2Drv-free2000.efi At the moment i typically get stalled with: Only single RAM bank (128 bytes) and some times I am getting: Couldn't allocate runtime area.
      Any advice would be greatly appreciated as im scratching my head wondering what the problem is - currently going to reformat the usb and start a new.
    • getting error (iobluetoothhcicontroller) (searchfortransporteventtimeouthandler) (missing bluetooth controler) apple loading bar stuck in middle if i boot normally. So i tried these  boot flags npci=0x2000 -v npci=0x3000 -v  -x-v PCIRootUID=1 -v PCIRootUID=0 -v still same error ?? Stuck in loading bar any solution?? thanks Acer Aspire 5733 (pew71) 

      Core i5 m560 @ 2.67 Ghz
      Intel HD Graphics
      Atheros AR5B125 Wifi
      Broadcom Net Link
      Realtek HD Audio
  • Download Statistics

    • Files
      848
    • Comments
      2,135
    • Reviews
      2,568

    Latest File
    By Vale1831

    1    0

×