AMD FX - Hackintosh Mountain Lion - Hackintosh Zone Jump to content

Recommended Posts

Hello guys! this is my first post in this site!
My english isn't very nice, i'm learning this language. But i'll try :D
 
Well!! I was trying to install OS X Mountain Lion 10.8.2 on my pc!.
 
My CPU Configuration is below:
 
Processor: Amd Fx 8150  (8-core black edition)
Motherboard: Gygabite 970A-D3P AM3+ Socket
Ram: 8Gb DDR (1600 bus speed)
Graphics: ATI-Radeon 5570 HD (1gb)
 
I tried to boot Niresh and when i write the flag:
"KernelCache"=amd -v
"KernelCache"=amd
"KernelCache"=-amd
"KernelCache"=amd
"KernelCache"=amd arch=i386 -v
amd arch=i386
-nossse3bit amd
npci=0x3000 Busratio=15(/20/9) cpus=4
UseKernelCache=amd arch=i386 colors=32 maxmem=4096
 
and other flags. I don't remember...!
Ok, after that! Always, my computers give me a black screen and it's restarting all the time.
 
This pic is the only one with apple simbol (gray screen, always run in black screen and reboot)
 
Can anyone please help me that how may fix this? :)

post-81-0-82373000-1386127600_thumb.jpg

Share this post


Link to post
Share on other sites

OS X is Really Hard Installing on AMD So

please wait for my 10.8.5 it will be released soon may be with in a week

Share this post


Link to post
Share on other sites

What you probably want to do is to install another kernel for your processor. I have 10.8.2 running on my FX-8150 with this kernel: http://www.insanelymac.com/forum/files/file/13-amd-fx-kernel/ there is plenty of guides on how to install it but short and sweet: Open up installer, have his kernel on an USB flash drive (the installer USB), open up terminal and transfer your fx_kernel file to your root on the install Macintosh HDD, then boot up with fx_kernel GraphicsEnabler=Yes <- Also use this for the installation.

 

Quick edit: Niresh, you should really include this kernel on your 10.8.5 distro. 

 

P.S. Sorry for the sloppy answer, will edit and clean up later, in class atm.

Share this post


Link to post
Share on other sites

niresh, i think u should include various amd kernel with nameamd1 -vamd2 -vamd3 -v...bz when i use ur 10.8.2 niresh isoi always add it by myself....so that it can boot easily in amd pc...and i think u should include MacPE,System info and Chameleon(fdisk activate) in ur isoI have success port MacPE and Chameleon into iaktos.....but i failed to add in ur-made iso...i also dont know why, but i hope u can add this feature in new come iso 

Share this post


Link to post
Share on other sites

What you probably want to do is to install another kernel for your processor. I have 10.8.2 running on my FX-8150 with this kernel: http://www.insanelymac.com/forum/files/file/13-amd-fx-kernel/ there is plenty of guides on how to install it but short and sweet: Open up installer, have his kernel on an USB flash drive (the installer USB), open up terminal and transfer your fx_kernel file to your root on the install Macintosh HDD, then boot up with fx_kernel GraphicsEnabler=Yes <- Also use this for the installation.

 

Quick edit: Niresh, you should really include this kernel on your 10.8.5 distro. 

 

P.S. Sorry for the sloppy answer, will edit and clean up later, in class atm.

 

Excuse me, but how can i add this kernel in USB FLASH ? on win 7?

 

I used transmac to create the usb flash drive, after that i tried to add some file.xxx to usb-flash-drive, and always i have a reading error. I only try this without terminal, but i can do this with ms-dos (system simbol).? (Copy & paste the kernel to usb-flash-drive) 

Share this post


Link to post
Share on other sites

Thanks for all!!!

 

I have now Mavericks's distro and i has some problems and i'm fixing and investigate some problems with my graphic card!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $48.99 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • So I tried to install Mac OS X Sierra on my computer with the following specs :   - Intel Core i5 650 3.20GHZ - 12GB RAM DDR3 - 2 HDD (.1TB , 250GB ) - Nvidia Geforce 210 1GB VRAM DDR3   Everything was cool at first the installation went smoothly with no problems, after setting up everything I noticed that the graphics card has been detected by the systems but there is no acceleration and the resolution is 1024x768, I couldn’t change it   I tried a lot of kext drivers from multiple websites but no success, last kext crashes my os, I start getting black screen after the login page, and the computer restart it self immediately, so I decided to mess with the clover options to find if I can enable the graphics card from there, and WALLAA, the magic happened, I went to clover options then > Graphics Injector Menu > I checked : InjectNvidia option, and I checked : Use NVIDIA WEB Drivers   Note : I already installed Nvidia web drivers previously so you do that too before trying this method   After the restart it took longer then the usual to boot up, but once it got to the login page I noticed that the acceleration is working perfectly and the graphics has no bugs like before.   So until now everything is working fine and I’m enjoying my experience with Mac Sierra  
    • HI, I have the same issue. I have integrated Intel HD4000 and nVidia 620m. I tried with IGPEnabler, GraphicsEnabler and nv_disabled bootflags but none of them helped, it just got me additional kernel panic "AppleUSBHostPort: :disconnect: persistant enumeration failures". I also don't have option to turn off any of my graphic cards in BIOS.  Is there any solution to this issue?
    • ya no documentation ..and iam so confused to ..can some one make tutorial
    • Desktop Specs 
      Mob-: MSI X99a Godlike Gaming (MS-7883) (supports Legacy+UEFI)
      CPU- Intel 5820k (Haswell E)
      Graphics- MSI 980ti
      Ram- Avexir ddr4 8x4gb also, i have attempted using: OsxAptioFix2Drv-free2000.efi At the moment i typically get stalled with: Only single RAM bank (128 bytes) and some times I am getting: Couldn't allocate runtime area.
      Any advice would be greatly appreciated as im scratching my head wondering what the problem is - currently going to reformat the usb and start a new.
    • getting error (iobluetoothhcicontroller) (searchfortransporteventtimeouthandler) (missing bluetooth controler) apple loading bar stuck in middle if i boot normally. So i tried these  boot flags npci=0x2000 -v npci=0x3000 -v  -x-v PCIRootUID=1 -v PCIRootUID=0 -v still same error ?? Stuck in loading bar any solution?? thanks Acer Aspire 5733 (pew71) 

      Core i5 m560 @ 2.67 Ghz
      Intel HD Graphics
      Atheros AR5B125 Wifi
      Broadcom Net Link
      Realtek HD Audio
  • Download Statistics

    • Files
      848
    • Comments
      2,135
    • Reviews
      2,568

    Latest File
    By Vale1831

    1    0

×