Dual boot issue (8.1/10.9) - Only USB Boots OSX - Hackintosh Mavericks - Hackintosh Zone Jump to content
dudeinco

Dual boot issue (8.1/10.9) - Only USB Boots OSX

Recommended Posts

Well, I have a working copy of OSX running perfectly, so I guess that's a good start.

 

Here's what happened:

 

I had W8.1 installed on a machine, and decided to make a dual boot 10.9.  First off, I had to mix a Niresh .dmg I found with a Niresh ISO just to get the thing to boot (SMC failures).   Then I had to copy files into the kexts directory for my machine from some random zip.  Needless to say, the install is a total Frankenstein.

 

Anyhow, I went and installed 10.9 into disk 2, and everything was great (video acceleration, sound, etc). Everything worked great, EXCEPT I could only boot into OSX by booting from the USB install bootloader.  I went through the process of marking the drive partition for OSX as active. (also upgraded to 10.9.4)

 

I booted into Windows, and used EasyBCD to create an entry for OSX, and set the drive to d: for the operating system (where OSX lives).  When I select OSX from a new boot, I get a different loader (chameleon logo - press any key to boot - press f8 for advanced options).  If I just hit a key, it will think for a few, then reboot.  If I hit F8, it shows the expected drives to boot from.  If I let it go, it will perpetually go through the think, then reboot, again and again.

 

So, what am I missing here?  Does this have something to do with the kexts in the installer needing to be copied over to my current copy?  Does it seem like I missed something?  Here's what I'm thinking: since I copied the kexts into the extensions directory of the installation USB that allows the installer to work without the SMC issues, perhaps I need to copy those kexts to my Mac install as well?  Totally shooting from the hip, being new at this.

 

Edit:  I used the copy process for kexts from the sticky on the 10.9.2 to copy the kexts from the install extras directory (how I originally got past the SMC failures).  No love.  Complete failure even with installer - had to reinstall. 

 

I like the idea of using the Windows BCD to boot into Mavericks - not gonna happen?

 

P6T Deluxe + 12Gb + I7 920

 

 

Share this post


Link to post
Share on other sites

Anyone?  There has to be something that can be copied from the USB if the USB will boot Mavericks on the disk, but the installed Mavericks won't, right?

 

Share this post


Link to post
Share on other sites

As an update, when it goes to the loader and reboots, just before the reboot, there is a message on the top that is too fast to read, but what I can make out is that "NULL" is in the sentence.

 

And maybe "string?"  Not sure - I'm a developer, so perhaps I'm seeing things...

 

There's definitely a "get_" and "develop" and "efi_inject" in the message... It is a split second message, so I am going to have to restart a few hundred times to get the message.

Share this post


Link to post
Share on other sites

Got the full error message!!  By hitting a key and then pause over and over (and rebooting about 5x, because the timing had to be perfect):

 

efi_inject_get_devprop_string NULL trying stringdata

 

Now we've got something to work with.

 

Tried reinstalling Chameleon using the stand alone installer, still no good.

Share this post


Link to post
Share on other sites

Looks like the current installed Chameleon is v2.0-RC4, so something is very wrong here.  I ran the installer for 2.2, but apparently it didn't take.

Edit:  Turns out installing the bootloader on Disk1 doesn't do anything because Disk0 is the default bootloader.  Now, that's Windows, which means EasyBCD is injecting the Chameleon bootloader?  Hmm... so this makes things more difficult.

 

Edit:  Doesn't matter anyways - booting from Disk1 does the same reboot - At this point, it looks like I'm stuck with a USB for a bootloader, which kind of sucks, but hey... what are you going to do?  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $40.92 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • @Niresh i forgot to say that that error was given because i have a Samsung M2 NVMe 960pro. I tried to remove it and it kinda worked but with a lot of bugs even during the installation. I can't remember everything clearly now cause it's been like 4 months ago
    • Thanks. I Have One Ethernet And One Wifi. Here Is The Terminal Log :  iMac:~ marcus$ lspci -nn 00:00.0 Class [0600]: Device [8086:190f] (rev 07) 00:01.0 Class [0604]: Device [8086:1901] (rev 07) 00:08.0 Class [0880]: Device [8086:1911] 00:14.0 Class [0c03]: Device [8086:a12f] (rev 31) 00:14.2 Class [1180]: Device [8086:a131] (rev 31) 00:16.0 Class [0780]: Device [8086:a13a] (rev 31) 00:17.0 Class [0106]: Device [8086:a102] (rev 31) 00:1c.0 Class [0604]: Device [8086:a110] (rev f1) 00:1c.2 Class [0604]: Device [8086:a112] (rev f1) 00:1d.0 Class [0604]: Device [8086:a118] (rev f1) 00:1d.2 Class [0604]: Device [8086:a11a] (rev f1) 00:1d.3 Class [0604]: Device [8086:a11b] (rev f1) 00:1f.0 Class [0601]: Device [8086:a145] (rev 31) 00:1f.2 Class [0580]: Device [8086:a121] (rev 31) 00:1f.3 Class [0403]: Device [8086:a170] (rev 31) 00:1f.4 Class [0c05]: Device [8086:a123] (rev 31) 01:00.0 Class [0300]: Device [10de:1c82] (rev a1) 01:00.1 Class [0403]: Device [10de:0fb9] (rev a1) 03:00.0 Class [0c03]: Device [1b21:1242] 05:00.0 Class [0604]: Device [1b21:1080] (rev 03) 07:00.0 Class [0200]: Device [10ec:8168] (rev 15)
    • How many network adapters do you have? Like WiFi or Ethernet? Post output of lspci -nn command
    • Unfortunately i dont have any Option to disable my Grahpic Adapter. Can i disable it in an other way? Like any Boot Flags?   EDIT: I did just an Update for my BIOS but it didn't add any Options to disable my Graphics Adapter
    • This issue is called Discrete Graphics issue of High Sierra, To bypass this you have to disable either Intel HD Graphics 630 or Nvidia GeForce GTX 1060 from BIOS, Check into your BIOS to see if you have any options to disable Graphics, Then try booting Keep me updated
  • Download Statistics

    • Files
      845
    • Comments
      2,130
    • Reviews
      2,555

    Latest File
    By 8osm3rka

    21    0

×