OSX recognize graphics card, but is not using it. - Hackintosh Mavericks - Hackintosh Zone Jump to content
  • 0
endifreekolesio

OSX recognize graphics card, but is not using it.

Question

Hi all,

I had a problem to run hackintosh with integrated graphics card support on my laptop for months. Today I achieved some progress and my pc finally is recognizing graphics card as 'Intel HD4000 1024mb' but still, works the same as on 64mb(safari still goes to fullscreen in 8sec with nice slideshow). I tried every combination with 'org.chameleon.Boot' file and I no longer know what to do. Could anyone tell what a problem is? 

Here is some info:

Laptop: Lenovo G580, i3-3110M, 4gb ddr3, HD4000 + NVidia GeForce 710M 1024 mb gddr3.

OS: Niresh 10.9.

Bootloader: Chameleon-2.2svn-r2377.

And my boot flags:

<key>Credits</key>
<string>www.hackintosh.zone</string>
<key>EthernetBuiltIn</key>
<string>y</string>
<key>Graphics Mode</key>
<string>1366x768x32</string>
<key>device-properties</key>g
<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000003006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>
<key>Kernel Flags</key>
<string>npci=0x2000 dart=0</string>
<key>Timeout</key>
<string>2</string>
<key>USBBusFix</key>
<string>y</string>
<key>UseKernelCache</key>
<string>y</string>
 
I would really appreciate some help :).

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I have tried a few values of IntelCapriFB but I will try again. I forgot to mention that my computer recognized the graphics card after i installed AppleIntelFramebufferCapri.kext. Is there any other kext i should apply to get HD4000 working?

Share this post


Link to post
Share on other sites
  • 0

Ohhh did you only install AppleIntelFramebufferCapri.kext ?

If yes, yeah there is others kexts you should install. Just use Multibeast or download HD4000 kexts from internet. There is defenetely a few more kexts to install, not just one.

 

Hope it will works dude :)

Share this post


Link to post
Share on other sites
  • 0

Yea, but everything I need is working: mouse keyboard, usb, touchpad. Only one thing I need more is graphics acceleration for better performance. I need mac only for programming and it doesnt matter for me if net or sound doesnt work. So my question was about graphics, I need to install any other kexts to get it working?

Share this post


Link to post
Share on other sites
  • 0

Okay, problem solved. I updated system from 10.9 to 10.9.4 because xcode 6 ask me to do and everything is working after that(except wifi and builtin speakers). Thank you for help. 

 

Writing from smoothly working mac os x. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $54.09 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hi guys, I installed the Hackintosh Sierra Zone image and most things work except my graphics. It detects as AMD R9 290X when I use FakeID 0x67B01002 on boot, however I only get 7MB of VRAM with no QE. My screen also tears as well. Hope someone can help me - Intel Core i5 2500K - AMD R9 290X 4GB - ASUS P8Z77-V LX
    • Hey guys, I'm looking into dual booting OSX Sierra or High Sierra on my ASUS Zenbook Pro UX501V. I use a lot of mac only software like sketch at uni and it would make my life a lot easier to just be able to boot into it instead of going to campus to use one of their Mac's. I'm currently running windows 10 and would prefer to not have to lose all my files or reinstall windows 10, however if this is unavoidable I would consider it. Specs are Processor    Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz, 2592 Mhz, 4 Core(s), 8 Logical Processor(s)
      GPU    NVIDIA GeForce GTX 960m 4gb DDR5
      RAM    12GB DDR4
      BIOS Version/Date    American Megatrends Inc. N501VW.300, 9/05/2016
      BIOS Mode    UEFI Does anyone know of any guides? Or has done this before? Even a link to point me on my way. Looked into the clover bootloader and I'm under the impression that's the route I'll have to take. Thanks for any help you may have      
    • Hi everyone. Here are my specs MOBO :Gigabyte Z68 XP UD3 (1155) GPU : HD 6870 1gb CPU Intel i7 2600k (1155) 60gb SATA SSD   MOBO is using legacy Bios. This machine has served me well for years. I tripped a circuit breaker a few weeks ago and now it's stuck in a boot loop. I have setup a new bootable USB to reinstall but for some reason the boot loop is happening when I startup from this as well. I can manage to get to the desktop using the safe mode boot flag (-x) but after a few moments, the desktop freezes and the computer reboots. I used the 10.10.1 disc image to create the new USB stick I am not sure if this could be causing the boot problem in the USB. Should I have used the 10.10.0? At first I suspected a hardware issue but I left the computer on for two days at in the bios screen and it stayed on just fine. Hoping someone can give me a hand figuring out which boot flags can get me going again or how I can reinstall the OS. I really need to get past the freeze/reboot cycle I am in. I am almost ready to nuke this thing and install windows
    • i also have this problem if you will finde the solution please inform me right away and thank you
    • I built a Hackintosh on a GIGABYTE GA-EP45-UD3P in 2010, and upgraded it to Sierra about 4 months ago. It's been working great until a few days ago.  The clock now is losing time, while the computer is on and running. I've been working on the computer all morning, and have had to bump it forward to the current time it 3-4x. Right now it says 9:40am, but it's really 9:47am.  I have "Set time and date automatically" set in settings and "Apple Americas/U.S. (time.apple.com.)" selected on the drop down. Deselecting it, and selecting it again, brings the clock back to the current time.  Is this a hardware issue or a software issue? Do I have to replace the CR2032 on the motherboard? If so - why? The computer is on, and running, why would it need that battery to maintain the time?       
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,538

    Latest File
    By rembrandt63

    316    0

×