HP Laptop Support ? HP Laptop Support ? - OS X Mavericks 10.9 - Hackintosh Jump to content
  • 0
Gerhard Botha

HP Laptop Support ?

Question

Hi Guys,

 

I have an : HP Envy 15 j163ei notebook and would like to find out how compatible it is with Hackintosh, i've managed to get it loaded with Hackintosh however it seems like there is a lot of problems.

 

  • Sound is not working
  • Wifi not working
  • LAN not working

 

There could be more, if anyone else has this exact same notebook could you please let me know if you got these sorted perpaps or if anyone else has some information that may help ?

 

link to my exact notebook : http://www8.hp.com/za/en/products/laptops/product-detail.html?oid=6894560

 

Thanks in advance...

 

 

 

 

Share this post


Link to post
Share on other sites

62 answers to this question

Recommended Posts

  • 0

@5pArxz 740m might be supported but not officially, so i think you need to boot with hd graphics first, you are only able to boot with -x is because the nvidia graphics not working properly. try to boot with boot flag: '-v nv_disable=1 "Graphics Mode"="1920x1080x32" GraphicsEnabler=Yes IGPEnabler=Yes IntelAzulFB=XX'(ranging from 0 to 15, usually work with 10-12, just by trial and error) you should be able to boot without safe mode(-x). 

 

edit: oops, i just checked, 740m may not be support in any way now

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

@

sound: just use voodoo, and normally you will get a kernel panic, just modify according to this, will be fine

http://www.insanelymac.com/forum/topic/267905-voodoohda-common-problems/

lan: you can use niresh's all in one network solution.

wifi: i am using newer model, with different wifi, can't help you. but i remember that someone with j model can use wifi, try to find out on Google

Share this post


Link to post
Share on other sites
  • 0

@

 

Thanks for the support :) much appreciated. This will be a very noob question but i cannot get lan or wan working obviously so how will i go about getting niresh all in one network solution on my laptop ? as i cannot transfer files from a windows machine ?

 

I've sinse this post re installed windows and am now running maverics 10.9 successfully in VmWare but thats only in fullscreen mode in windows which is not optimal.

 

I'm very new to this whole thing. and have no idea what what is :P LOL

Share this post


Link to post
Share on other sites
  • 0

@

 

Thanks for the support :) much appreciated. This will be a very noob question but i cannot get lan or wan working obviously so how will i go about getting niresh all in one network solution on my laptop ? as i cannot transfer files from a windows machine ?

 

I've sinse this post re installed windows and am now running maverics 10.9 successfully in VmWare but thats only in fullscreen mode in windows which is not optimal.

 

I'm very new to this whole thing. and have no idea what what is :P LOL

@ oh you only get 1 computer with you? then you need to download the all in one solution first in windows, then install. i have my envy 15 with dual booting

Share this post


Link to post
Share on other sites
  • 0

@, no i have 2 notebooks. other one is an Acer but how will i get the files from that notebook to the other with mac installed ?

@ just use a usb, mac can read and write fat and exfat, read ntfs, so all format you used on windows can help you transfer those drivers file

Share this post


Link to post
Share on other sites
  • 0

@ Yes i've tried that initially but if i format the usb mac osx extended or whatever then windows cannot read it and if i format it fat32, exfat or ntfs then mac cannot mount it ? ( at least that is what is happening to me ) because if i can get the Lan working i guess i can get more things going.

 

Thanks for the help :) 

Share this post


Link to post
Share on other sites
  • 0

@ Yes i've tried that initially but if i format the usb mac osx extended or whatever then windows cannot read it and if i format it fat32, exfat or ntfs then mac cannot mount it ? ( at least that is what is happening to me ) because if i can get the Lan working i guess i can get more things going.

Thanks for the help :)

@ windows cannot mount hfs+ without additional software, but mac can mount fat32 and exfat to read and write, only read can be done for ntfs.

Share this post


Link to post
Share on other sites
  • 0

@ Thanks i will give it another go, else i was thinking of downloading it on my vmware and formatting the usb mac osx, put it on and then load notebook, cause then i will have a mac formatted usb with the all in one solution on it. can you suggest any other post installation software that may / may not help ? as well as boot flags as i mostly only get it working with -x which is safe mode if i remember correctly

Share this post


Link to post
Share on other sites
  • 0

@ my notebook has the switchable graphics, HD4600 and dedicated NVIDIA GeForce GT 740M (2 GB DDR3 dedicated) .

 

here is my notebooks full specs : http://h10025.www1.hp.com/ewfrf/wc/document?cc=us&lc=en&docname=c04191344

 

Copied from source : 

Microprocessor Intel Core i7-4700MQ with Intel HD Graphics 4600 (2.4 GHz, 6 MB cache, 4 cores)
Chipset Intel HM87 Express
Memory 8 GB 1600 MHz DDR3L SDRAM (2 x 4 GB)
Video Graphics NVIDIA GeForce GT 740M (2 GB DDR3 dedicated)
Hard Drive 1 TB 5400 rpm SATA
Display 39.6 cm (15.6â€) diagonal FHD BrightView LED-backlit (1920 x 1080)
Network Card Integrated 10/100/1000 Gigabit Ethernet LAN
Wireless Connectivity 802.11b/g/n (1x1) and Bluetooth 4.0 combo
Sound Beats Audio with 4 speakers and two subwoofers
Keyboard Full-size island-style backlit with numeric keypad
Pointing Device HP Imagepad with multi-touch gesture support
External Ports 1 multi-format SD media card reader
1 HDMI
1 headphone/microphone combo
4 USB 3.0 (1 HP USB Boost)
1 RJ-45 Dimensions 37.95 x 25.07 x 2.79 cm
Weight 3.54 kg
Power 120 W AC power adapter
6-cell (62 WHr) Li-ion
Camera HP TrueVision HD Webcam (front-facing) with integrated dual array digital microphone
 

Share this post


Link to post
Share on other sites
  • 0

@ Thanks man, i will give it another go with all this new information :) Thanks a lot for the assistance! Hopefully my next post will be here from my working mac. So lets get to work! :) 

Share this post


Link to post
Share on other sites
  • 0

@5pArxz 740m might be supported but not officially, so i think you need to boot with hd graphics first, you are only able to boot with -x is because the nvidia graphics not working properly. try to boot with boot flag: '-v nv_disable=1 "Graphics Mode"="1920x1080x32" GraphicsEnabler=Yes IGPEnabler=Yes IntelAzulFB=XX'(ranging from 0 to 15, usually work with 10-12, just by trial and error) you should be able to boot without safe mode(-x). 

 

edit: oops, i just checked, 740m may not be support in any way now

 

If 740 is not supported do i need to boot without GraphicsEnabler ?

Share this post


Link to post
Share on other sites
  • 0

If 740 is not supported do i need to boot without GraphicsEnabler ?

i don't know as i am booting with both GraphicsEnabler and IGPEnabler for my envy 15 which has a 850m that is not supported too and i boot with both for HD4600. still boot with GraphicsEnabler, because i think that it enable the QE/CI.

Share this post


Link to post
Share on other sites
  • 0

@ i use dmg and write it in windows, seems if you have a usb, dmg will be better, iso for dvd. and there is no any website have a very precise list, usually just know your parts model number, and search it with google.

Share this post


Link to post
Share on other sites
  • 0

@ I've tried the boot flags you recommended and i just get instant reboot when trying to load laptop. I've also now tried -x and about 10 000 other combinations but now i keep getting instant reboot. Any Boot flag ideas ?

Share this post


Link to post
Share on other sites
  • 0

@ I've tried the boot flags you recommended and i just get instant reboot when trying to load laptop. I've also now tried -x and about 10 000 other combinations but now i keep getting instant reboot. Any Boot flag ideas ?

@5pArxz are you booting niresh 10.9 installer? if yes, boot with xpcm-free kernel, and in the installer, no need to do the graphics, just type in:'xlcm-free -v' and it should successfully boot up the installer

Share this post


Link to post
Share on other sites
  • 0

@ Thanks, yeah i forgot about that one... finally got it installed but i cannot boot from HD without -x flag as it seems like i keep getting Kernel Panic something regarding Audio, i've looked at the post link you linked to earlier, but where do i change this ? i have absalutely no idea ?

 

Problem: kernel panic.
Solution 1: remove AppleHDA and restart the system before installing VoodooHDA.
Solution 2: edit Info.plist, replace the key IOPCIClassMatch by IOPCIPrimaryMatch and put the PCI ID of your Audio card in string.
Before

 

What does that mean ? haha

 

Thanks for the help and patience with me :)

Share this post


Link to post
Share on other sites
  • 0

@ Thanks for the info, here comes yet another noob question, 1) where can i find the file and 2) do i boot in safe mode (-x) and do the changes and then restart ? or do i need to change it on my installer and then re install mac ?

 

ps. Thanks for assisting me with all my noob questions, much apreciated. :)

Share this post


Link to post
Share on other sites
  • 0

@ if you have a dual boot, then go into windows and download the file, if not, boot into safe mode and first move away voodoohda.kext then reboot without safe mode, afterthat find a usb on another computer to download the file, and put it into you mac, run it and find out the pci id. then put back the voodoohda with modified info.plist. abd reboot without cache for once.

Share this post


Link to post
Share on other sites
  • 0

@ i tried installing dual boot but i keep getting the windows is hibernated hang and then i cannot format my other drive partitions which also sucked.. is it much more complicated to get dual boot working then just a normal mac install using the entire hard drive ?

Share this post


Link to post
Share on other sites
  • 0

@ you need to know that the basic skills, nearly all kext are installed in the /S/L/E(/System/Library/Extensions) path in your mac harddisk

Share this post


Link to post
Share on other sites
  • 0

@, oh okay i just wanted to confirm that because i read somewhere else while strugling with the Audio crash that it's that kext and i searched around for it and actually deleted that one and i still got kernel panic without it. ? or will the Kernel Panic only go away once i updated the Info.plist ?

Share this post


Link to post
Share on other sites
  • 0

@ try to boot with -f and the flag i type before too. it will not boot with kernel cache. by the way, try to take a picture of the kernel panic as there maybe other problem

Share this post


Link to post
Share on other sites
  • 0

Okay i will do that, I will do all of this above and post a detailed post of what flags i used etc. with a Photo of the Kernel Panic if all this didn't work. I'm going to try a new fresh install. :) will be reporting back in a little while.

Share this post


Link to post
Share on other sites
  • 0

@ Good news finally got it working.

 

Firstly installed with boot flags :

 

xpcm-free -v

 

Then after installation i used :

 

-v -x 

 

I moved the voodooHDA.kext file out of /s/l/e and restarted with these boot flags :

 

-v -f nv_disable=1 "Graphics Mode" = "1920x1080x32" GraphicsEnabler=Yes IGPEnabler=Yes IntelAzulFB=11

 

However the graphics stuttered so i changed the screen resolution and then changed it back to 1920x1080 and that got fixed.

 

Then i installed the all in one network Solution that didn't work for me, but then i got hold of a Realtek 8111 kext around here somewhere ( will link later ) which i installed with Kext Wizzard and that resolved the Ethernet problem.

 

Now todo is : 

 

  1. Install bootloader on Hard Drive
  2. Fix Sound
  3. ????

@ can you perhaps help me with the installing bootloader part ? i have no idea how, and also i keep having to type in the boot flags, is there a way around it ?

 

I also get Graphics  Intel HD Graphics 4600 1024 MB is this the highest i will be able to get ?

 

Thanks @ for all the help with Achieving this success :)

Share this post


Link to post
Share on other sites
  • 0

@ No problem i've found macpoison it looks simple enough, testing it as we speak, i've done the Audio thing by replacing the values in info.plist now do i have to boot without -f ? because the sound is still not working 

Share this post


Link to post
Share on other sites
  • 0

@ I've just rebooted without any flags, just used -v and still no sound, ive checked System Preference and it shows nou input / output devices and also if i click on voodooHDA it says : No VoodooHDA devices detected.

Share this post


Link to post
Share on other sites
  • 0

@ i've tried that here is that section of the kext file :

 

 

<key>IOPCIClassMatch</key>

<string>0x04030000&amp;0xffff0000</string>
<key>IOPCIPrimaryMatch</key>
<string>0x8c148086</string>

 

maybe i've missed something ?

 

System Info Shows me 2 Audio Devices

 

1: Lynx Point HD Audio Controller : 

 

Ven ID : 8086

Dev ID : 8c20

 
and 2 : Haswell HD Audio Controller : 
 
Ven ID: 8086
Dev ID: 0c0c
 
Which one should i enter in the kext file ?

Share this post


Link to post
Share on other sites
  • 0

@ I've tried both mine now as well as yours it has no effect ,i restart and boot with flags : -v nv_disable=1 GraphicsEnabler=Yes IGPEnabler=Yes IntelAzulFB=11 

 

Could it be boot flag related ? also i don't get kernel panic with voodooHDA file in, i'm not sure if it reloads all the kext files ? is there a way to force it to reload the kext files ? or is it done by default

Share this post


Link to post
Share on other sites
  • 0

@ I've just updated System Info and now i get this Audio Device :

 

8 Series/C220 Series Chipset High Definition Audio Controller :

 

8086 / 8c20

 

Funny enough et also picks up my Graphics Card :

 

GK208M [Geforce GT 740M] : 10de / 1292

 

But still no sound... :(

Share this post


Link to post
Share on other sites
  • 0

@ might you upload your info.plist? let me have a look. and sorry, i may not reply in a couple hours, i am going to sleep.

Share this post


Link to post
Share on other sites
  • 0

@ Great news i got sound working, i moved the kext to my desktop, restarted with no kext then used kext wizzard to add it and cleared cache and permisions. restart and working like a boss! now it's just the bootloader issue getting Error 0 :(

Share this post


Link to post
Share on other sites
  • 0

@5pArxz https://www.hackintosh.zone/page/osx86.html/hackintosh/articles/how-to/how-to-fix-the-boot0-error-for-your-hackintosh-r25

try to fix with this guide, reminded that the first solution, disk0s2 should be your mac drive, check with diskutil list, after you successfully install the chameleon, i will help you to do something in order not to enter the boot flag every time you boot.

Share this post


Link to post
Share on other sites
  • 0

@ Thanks for all the help so far, i've managed to get to boot without any boot flags :) by editing chameleon plist or whatever in Extras folder so all my bootflags are in there now so i can now boot just by pressing Return which is great. let me check the guide and hope i can get it working to boot without installer.

Share this post


Link to post
Share on other sites
  • 0

@ i have the RT3290 Wireless 802.11n 1T/1R PCIe but i did some googling around and it seem like there is no support for the RT3290 Wireless card :( maybe you know of something ? but that would be the final fix then everything works ;) Else i will go buy a usb wireless if you can suggest one ?

Share this post


Link to post
Share on other sites
  • 0

@5pArxz i can't find a solution for that too, so sorry. i bought a usb wifi as mine intel wifi are not working too. mine wifi USB is D-Link DWA-182. it is an AC 1200 usb3.0.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting April 2018

    Please donate to support the community.
    We appreciate all donations!

    Thanks



    $31.08 of $100.00 goal reached.
    Donate Now
×