ATI Radeon Sapphire HD4870 no 3D acceleration - Graphics Kexts - Hackintosh Zone ATI Radeon Sapphire HD4870 no 3D acceleration Jump to content
didair

ATI Radeon Sapphire HD4870 no 3D acceleration

Recommended Posts

Hello, my Hackintosh is up and running thanks to Niresh 10.8.2 distro, also updated to 10.8.4 using an combo update from apple.com and everything is really working great, except 3D acceleration. I'm booting with GraphicsEnabler=Yes.

 

Does anyone have any experience on what drivers I should use? 

 

Additional info is that i can play Minecraft with good fps, but when i try games like Garrys Mod or HoN it just does not work, no 3D objects are loaded in-game. 

Share this post


Link to post
Share on other sites

Hello, 

 

I've installed 10.9 using niresh. And I'm facing graphics, sound and usb wifi issues. 

 

I've got Asus M4A87TD/USB3 motherboard, Sapphire HD 4830 gpu and AMD Athlon II X3 cpu. 

 

Could you please guide me through what you have done to be able to use your system with the graphics. 

Share this post


Link to post
Share on other sites

Hello @nartcan, sorry for the late answer. I've been very busy the last couple of weeks. 

I've upgraded my Radeon HD4870 and replaced it with a R9 270X card. 

I solved the 3D acceleration problems by reinstalling my computer.

When it comes to installing hackintosh it's usually (in my experience) the kernel that is causing problems. But if you're certain that your graphics is causing problems I would recommend checking if you need GraphicsEnabler or not. Usually HD cards like mine (also R-Series) does. If you want help I will need you to be more specific and include things like: Bootflags, kernel, specs on your PC, errors et.c. A good tip is including your computer specifications in your signature like i have. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting May 2018

    Please donate to support the community.
    We appreciate all donations!

    Thanks



    $53.73 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • I have searched all over and there is a LOT of info on what to do to install Mac OS w/e once you have set up the Mac VM. I am brand new at this so I may just be missing something very simple. How do I get from this... https://imgur.com/vQrLPXH To this.... https://imgur.com/RunPZ1C  
    • Hello everyone,  I'm trying to install High Sierra (with AMD support) on my AMD 4500m Lenovo G505s laptop. When booting from Clover in EFI with i get some really fast screen log then the pc reboots. Now, i know there isn't a way you could help me without some info/logs, unless i'm missing a major malfunction known on these kind of laptops, so, do you know a way i could prevent it from rebooting in order to at least understand what is causing this problem? Do you think even trying to put OSX on this laptop is worth it? Thank you.
    • Hello, i am trying to install High Sierra on my ASUS X75VB but i am getting multiple errors with the ACPI.
      I believe it is CPU related?

      Mainboard: HM76 (X75VB SOCKET 0)
      CPU: Intel Core i5 3320m (Not the original CPU of this laptop!)
      GPU: Intel HD Graphics 4000 & NVIDIA 2GB Geforce 740M
      RAM: DDR3 8GB
      Storage: 120GB SSD (SATA-2)

      I have used the DSDT.aml & SSDT.aml from the following resource:
       https://github.com/xxx10101xxx/ThinkPad-X230-macOS/tree/master/i5-3320M

      My config.plst can be found here:
      https://drive.google.com/open?id=1lK7ixY8fAvtIJv8gY6Gf-RQvKJBVcFLm

      Thanks in advance!
    • im already download 10.12 and 10.13 . when im trying install 10.12 . all works fine , like resolution already 1920x1080 , sound , network all fine .. but when im trying install 10.13. resolution wont 1080 , already install nvidia web drivers , but hopeless..

      using Nvidia GT630 , btw .
    • I have Yosemite Zone working on Virtualbox fine.  After downloading High Sierra Zone there is only a dmg and no ISO.  I tried converting the dmg with hdiutil but it goes to 8GB and I get "no bootable media" in Virtualbox.  Has anyone been able to do this yet? 
  • Download Statistics

    • Files
      849
    • Comments
      2,144
    • Reviews
      2,627

    Latest File
    By ka209

    116    0

×