[Successful] Asus A43Sj Laptop (10.8.5) - OS X Mountain Lion 10.8.5 - Hackintosh Zone Jump to content
  • 0
cordovaputra

[Successful] Asus A43Sj Laptop (10.8.5)

Question

Hello, nice to meet you all.

Today i'll be giving you an interesting news about Mountain Lion 10.8.5 which suits perfectly with ASUS A43SJ, and i would recommend you this laptop as a hackintosh laptop. Why? Well, i used Niresh distro's since Lion 10.7.3 and all of them works flawlessly.

 

Okay, let's get started !

Here's the screenshot of my machine specs :

post-3013-0-88409500-1387940404_thumb.pn

 

Here's the desktop view, which works flawlessly ( The Battery, Wi-fi, Disk Drive, etc )

and the iCloud & iMessages are also work like shit ( sorry, i'm so happy for it since epic failures and issues on 10.8.2 LOL )

post-3013-0-48486600-1387940860_thumb.jp

 

Alright. So, how to reach this paradise of Mountain Lion 10.8.5 with less issues during the first install ( this is my very first install and it succeeded directly ) ?.

1. Download Mountain Lion 10.8.5 ( ISO version ) from Niresh 

2. Make sure you download it properly and finished in the same amount of the size ( if it's 4,32 GB, it must be finish in 4,32 GB ). Why? well sometimes error occurs from this tiny mistake :)

3. Burn it to a disc. ( mine was DVD-RW ) and burn it using IMGBURN by the speed of 8x ( make it solid )

ATTENTION :

When i finished burning the iso, it says to close the disc tray and it says ERROR when validating the iso. Don't panicked yourself, just eject it and make sure you have BACKUP THE ENTIRE DATA and DON'T REGRET ANY LOSING FILES 

 

4. Boot up to your BIOS to change your default BIOS from IDE to AHCI mode !.

5. Restart

6. Normal boot and select the Niresh Mountain Lion 10.8.5 disc, then type -v ( verbose mode ) and enter

7. Take some times to load dozens of white texts, make sure you still heard your disc circling sound, if it's stop and you feel stuck for about 10 - 15 minutes by the white texts, RESTART YOUR LAPTOP. But then if you keep finding yourself with the error, RE-BURN YOUR MOUNTAIN LION.iso WITH ANOTHER DVD DISC, but if the problems keep appear, YOU DOWNLOAD THE FILE UN-PROPERLY. So, don't get to panic 'cause i serve you the other reasons and options.

8. Mountain Lion language selection appears ( i choose English )

9. In the next installation window, you'll see an active taskbar on the top of your screen, choose UTILITIES and click on the DISK UTILITY selections.

10. PARTITION your main or test-drive ( test-drive was meant for them who still concern about the installation success rate on your laptop, if you do this, don't use the main drive !!! ) to some amount of partitions ( i picked 2 PARTITIONS, FOR THE MAIN DRIVE AND DATABASE ) then change the type to MAC OS JOURNALED ( you can even rename your file ).

11. CLICK APPLY and it'll load for some minutes. If it appears to be an error, try the partition again, but if it keeps the same, then restart your laptop to begin from the start. DON'T GET TOO HURRIED, BE PATIENT, THIS IS NOT A THEME, THIS IS A HACKINTOSH 

 

12. close the Disk Utility window and click next to begin the installation

13. You will have to choose the drive for your main installation area. But...WAIT UP! YOU NEED TO CLICK COSTUMIZE IN THE BOTTOM-LEFT CORNER OF THE BOX !

 

14. This is when people get crazed because they don't pay attention to what things they should choose. And for this tutorial, this is for Asus A43SJ but if it appears to be success with the other laptops, then it's great.

DON'T TICK GRAPHICS ENABLER, SINCE NVIDIA GT520M was FULLY SUPPORTED !

DON'T TICK THE TRIM ENABLER FOR SSD, SINCE OUR DRIVE WASN'T SSD !

For the rest, leave it be ! don't try to change 'em if you don't know how it works !

 

15. Installation process begins ! it takes 20 minutes or so.

16. After finishing the installation, reboot your system and CHOOSE THE DRIVE WHICH YOU HAVE RENAME IT AS THE MAIN DRIVE FOR MOUNTAIN LION INSTALLATION. DON'T CHOOSE THE DISK NAME ANYMORE !

17. Type -x to enter the Safe Boot mode

 

18. Let the notifications that told you 'repairing, building caches or so' works ! don't restart your system untill they said 'YOUR HACKINTOSH IS FULLY OPTIMIZED'.

19. While waiting them, you can install several kexts that i upload on this link ( and also for some DSDT and SSDT too ! )

 

KEXT 1 : http://www28.zippyshare.com/v/79518364/file.html

KEXT 2 : http://www28.zippyshare.com/v/19147354/file.html

 

IT'S WORKING FOR 10.8.5 !

 

Description of the file

Kext 1 : Kexts that i put into a single folder, you'll need to install all of them by using KEXT UTILITY. Where can i get the Kext Utility?. It's automatically installed on the Mountain Lion 10.8.5 :)

Kext 2 : Kexts that contains SSDT, DSDT, 'Extra' folder customization and some other kexts that need to be installed such as Wi-Fi, sound, etc.

 

20. Restart your hackintosh after installing the kexts. 

WELCOME TO THE PARADISE ^_^

YOU'VE FINALLY MADE IT !

HAPPY HACKINTOSHING !

 

P/S :

1. If your Wi-Fi cannot connected even you've installed the kexts.

Here's what you have to do ( i got frustated but i tricked them by using multibeast and it works like hell yo ~ )

1. Download Multibeast from Tonymacx86

Wait, i don't have any internet connection !. Well think smart by using the other laptops or a tablet, then send it to your laptops and install as usual.

2. Choose the network driver and select this one :

post-3013-0-10190600-1387942697_thumb.pn

3. There will appear a installer window. Just install it as normally

4. Restart

 

5. Still not working? Good !

Yeah, it won't work ! it won't work !. LOL don't panic, now you go to SLE ( System Library Extensions ) and delete the REALTEK RTL81XXX kexts. Then, you restart your system and GO TO SYSTEM PREFERENCE - NETWORK - TURN ON WIFI - CHOOSE YOUR NETWORK AND INSERT THE PASSWORD IF IT'S NEEDED.

 

Your Wi-Fi issue saved !

What else? nothing, it all works flawlessly.

^_^

 

Source : 15 times failures in installing 10.7.3 , 8 times failures in installing 10.8.2 , EPIC SUCCEED in installing 10.8.5

Experience is the best teacher, indeed !

 

If you wanna ask, just post to my Facebook : https://www.facebook.com/ddopha?ref=tn_tnmn

Mail me : cordovasmart@gmail.com

 

Hope it works, i'll be testing the Maverick 10.9 pretty soon !

 

Edited by deadmau5

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0
deadmau5    54

Glad to hear that man. Thanks for taking your time and posted it.

Ps: I edited your post with the [successful] tag. Hope it doesn't mind.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Glad to hear that man. Thanks for taking your time and posted it.Ps: I edited your post with the [successful] tag. Hope it doesn't mind.

Thanks man, whoops nevermind about that :)Anyway, can i send you some messages for asking about the upgrade to Mavericks? :)

Share this post


Link to post
Share on other sites
  • 0
deadmau5    54

Thanks man, whoops nevermind about that :)Anyway, can i send you some messages for asking about the upgrade to Mavericks? :)

It would be better to open a new thread, so just everybody can help you. But, it's safe to upgrade to Niresh's Mavericks.

Share this post


Link to post
Share on other sites
  • 0
laxbb    0

Alright, try to add some other boot flags that compatible with your system. you can search it on osx86 wiki :)

 

I have msi cx640 laptop

 

intel core i3

chipset : intel HM65

memory : 4 gb

graphics : nvidia geforce gt520m

hdd : 500gb

 

Can you, or someone else help me because i am newbie with this stuff... i follow tutorial everything was ok, but after instalattion i tried with -X and stuck at apple logo

 

here is some pictures : 

 

i tried with -X

Posted Image

 

Also tried with -x -v or -f -v or with -x graphicsenabler=no  .. tried several options

 

My BIOS SETTINGS : 

Posted Image

 

Any advice please help me 

Share this post


Link to post
Share on other sites
  • 0

Okay how long did you stuck at the apple white logo? If it stucks for some long time, you need to follow the tutorial from the beginning. It's normal for being confused by the problems, try it again.Honestly, i ever met several failures but believe that you'll made it through some hard efforts :)

Share this post


Link to post
Share on other sites
  • 0
Sumon Khan    3

Hi, I installed successfully too on my AMD Machine and I'm using AMD Radeon HD 6780 Graphics Card but after installation I'm getting lots of glitch. How may I fix that?

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Hey!  I successfully installed macOS Sierra with the Version SierraAMD v3 on my AMD Pc.  But after setting up the PostInstall via Terminal, the OS stops booting at this line : ioconsoleusers: gioscreenlockstate 3, hs 0, bs 0, now 0, sm 0x0 Any solutions?    My System Specs: Mainboard: Asrock 970 Pro3 r2.0 Processor: AMD FX-6300 Graphics: Sapphire Radeon RX460 4GB   Thanks!
    • Ok, so I built a new hackintosh with Niresh Mavericks 10.9.0 on a modified Dell Precision T7400 and mostly everything seems to be working correctly except for two things: Sound (The obvious one), and Online video content (Youtube, Facebook videos, etc) play at lower than 1 fps, frozen speed, after 10 seconds of playback it reaches 4 seconds of elapsed time and I have found no other forums explaining this or talking about this so I decided to bring it up here. As for the sound situation, I already bought a new card to replace the X-FI, so yes, I am aware of the Sound Blaster Audigy X-FI Xtreme Audio not being supported, but what caught my attention is that the sound was working and video playback problem was gone temporarily, I happened to hear the sound from my headphones sitting on my desk and put them on, and sound. I decided to test a video on youtube, the problem with the videos, gone. But after a reboot, they were back. However I have the logs from today and can give them to whoever wants/needs them to figure out what may have caused the sound to kick in on the X-FI and maybe add support for this sound card. I copied as far back in the time that the system was on while sound was working that I could up to the shutdown event. I know it's pretty large but I am not sure where to look, I am simply handing this out to whoever wants to see what may have given me audio on this card for the session. From what I can see that looked to be the most closely related to my issue is something to do with bluetooth (I don't have bluetooth, btw), it says in console: "9/20/17 6:49:55.785 PM com.apple.audio.DriverHelper[200]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the mach service named com.apple.bluetoothaudiod." repeatedly many times. This could be completely unrelated.   The only recent actions I made that I personally can think of that may have triggered this would be: I installed several different versions of a music player through Winebottler and it failed to start, more and likely because of the lack of .net framework 2.0 and 4.0, this is my highest suspicion of being the likeliest cause, but I could be wrong. I installed Crossover and installed the music player in it, which it ran in and is where I discovered that you need .net 2.0 and 4.0 (It had the player in it's database and installed .net automatically) Ran Discord (It uses output/input, so may as well add that in) The player was MusicBee, and when it crashed, it also left a log that I could probably try to reproduce if needed.   Specs: Dell Precision T7400, 1x Intel Xeon x5482 Nvidia Geforce GTX 660 16GB ddr2 ram 667mhz (Tested to be working correctly, please don't ask me to run a mem test I am impatient enough as it is)
    • 980m+intel 530, 6820hk 512ssd+120ssd+1TB im trying to install macOsierra, and i tried a lot of combinations of arguments and configuration, nothing seems to work, i got the same problem every time ofter i start the installation! Is saying: System uptime in  nanoseconds: some random numbers.
    • Hello guys!


      Today I tried to install macOS High Sierra from a bootable usb, but my pc froze during the booting process.
      I need help. Can you help me?

      Here I attached a demo with the problem.
      https://goo.gl/cp5E8M


      Thanks in advance!
    • Hi, I am new at this, I installed maverick on a Lenovo g460 and everything ok but when I try to start appear a screen and say "system uptime in nanoseconds..." , I use -x and -x and others but I can't solve my problem. Sorry for my English. Thanks 
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,532

×