How to Enable HD4000 with Mavericks 10.9 - OS X Maverick Zone Hackintosh 10.9.0 - Hackintosh Zone Jump to content
  • 0
Stephan Ihm

How to Enable HD4000 with Mavericks 10.9

Question

Stephan Ihm    0

Hello,

this is my Guid on how to Enable the HD4000.

This Guid probably works only on P8H61 Asus mainboards and HD4000 with the Device ID 0162 and Version ID x0009.

But you can try it!

 

MAKE SURE YOU UNPLUGGED YOUR GRAPHICSCARD (if you have one)

 

1) Create Bootable Mavericks Niresh 10.9 USB Drive

      -> Downloadsection

 

2) Go into your Bios and reset all changes. There should be an option for that.

 

3) Enable AHCI Hard Drive Mode.

 

4) Set VRAM to 96MB and chose X.M.P mode

 

5) Boot from your USB drive and start the launcher with following Bootflag:

   "UseKernelCache=No"

 

6) Set up the HardDrive for an OS x installation (Format etc.) 

 

7) Close DiskUtility and choose your Partition/HardDrive to install Mavericks.

 

8) Before clicking on Install hit the config button and make sure you use Chameleon as Bootloader and disabled:

 

"GraphicsEnabler=Yes"

"UseKernelCache=Yes"

"TRIM-support for SSD"

 

and enabled: 

 

"IGPEnabler=Yes"

"IgnoreCaches"

"AHCI-3rdParty-SATA"

 

9) After the Installation reboot your pc and boot with bootflag "-s"

 

10) After a lot of codes the screen should freeze for a moment and you are able to write

 

11) type in:

 

mount -uw /

 

cd /System/Library/Extensions

 

mkdir intel_back

 

mv AppleIntelHD* AppleIntelF* intel_back/

 

touch ../Extensions

 

reboot

 

(you should hurry up because sometimes i got an kernelpanic :D i dont know why)

 

12) after setting up your Mac you have to download Multibeast Mavericks (tonymacx86.com)

 

13) Select:

EasyBeast

IntelGraphicsPatchForMixedConfigurations

NullCPUPowerManagment

Chimera v.3.0.1

Hibertatemode Desktop

1080p Display Mode

 

14) Replace your Extra/chameleon.boot file with mine :) 

 

15) Go to System/Library/Extensions/intel_back

 

16) COPY all kext and bundels and paste them back in System/Library/Extensions/

 

17) Open KextWizard and install the 10.9 HD4000/3000 Kext files (without makeing backup of them)

 

18) after that rebuild cache and repair permissions (Option in KextWizard)

 

19) Edit the replaced chameleon.boot file {step 14}

 

"apple logo" -> System Report -> Graphics/Monitor 

 

you can your HD Device ID and the Version ID.

note your Device ID.

 

now replace the IGPDevice string.

If your Device ID is allready 0162 you can leave that.

If it is 0166 you have to edit it.

 

If your Device ID is 0166 you have also to edit the IGPlatformID string.

change the 0166000A to 01660003.

If this doesnt work try one of the following:

 

01660000 HD 4000 Mobile
01660001 HD 4000 Mobile 
01660002 HD 4000 Mobile 
01660003 HD 4000 Mobile - Chimera Default
01660004 HD 4000 Mobile - 1600x900 or 1920x1080
01660008 HD 4000 Mobile 
01660009 HD 4000 Mobile 
0166000A HD 4000 Desktop Chimera Default
0166000B HD 4000 Desktop

 

 

Reboot your PC :)

Done!

 

hope it worked.

I am sorry for my bad english ^^ xD

org.chameleon.Boot.plist.zip

10.9_Intel_HD_3000_&_HD_4000_Driver_.zip

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Hey!  I successfully installed macOS Sierra with the Version SierraAMD v3 on my AMD Pc.  But after setting up the PostInstall via Terminal, the OS stops booting at this line : ioconsoleusers: gioscreenlockstate 3, hs 0, bs 0, now 0, sm 0x0 Any solutions?    My System Specs: Mainboard: Asrock 970 Pro3 r2.0 Processor: AMD FX-6300 Graphics: Sapphire Radeon RX460 4GB   Thanks!
    • Ok, so I built a new hackintosh with Niresh Mavericks 10.9.0 on a modified Dell Precision T7400 and mostly everything seems to be working correctly except for two things: Sound (The obvious one), and Online video content (Youtube, Facebook videos, etc) play at lower than 1 fps, frozen speed, after 10 seconds of playback it reaches 4 seconds of elapsed time and I have found no other forums explaining this or talking about this so I decided to bring it up here. As for the sound situation, I already bought a new card to replace the X-FI, so yes, I am aware of the Sound Blaster Audigy X-FI Xtreme Audio not being supported, but what caught my attention is that the sound was working and video playback problem was gone temporarily, I happened to hear the sound from my headphones sitting on my desk and put them on, and sound. I decided to test a video on youtube, the problem with the videos, gone. But after a reboot, they were back. However I have the logs from today and can give them to whoever wants/needs them to figure out what may have caused the sound to kick in on the X-FI and maybe add support for this sound card. I copied as far back in the time that the system was on while sound was working that I could up to the shutdown event. I know it's pretty large but I am not sure where to look, I am simply handing this out to whoever wants to see what may have given me audio on this card for the session. From what I can see that looked to be the most closely related to my issue is something to do with bluetooth (I don't have bluetooth, btw), it says in console: "9/20/17 6:49:55.785 PM com.apple.audio.DriverHelper[200]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the mach service named com.apple.bluetoothaudiod." repeatedly many times. This could be completely unrelated.   The only recent actions I made that I personally can think of that may have triggered this would be: I installed several different versions of a music player through Winebottler and it failed to start, more and likely because of the lack of .net framework 2.0 and 4.0, this is my highest suspicion of being the likeliest cause, but I could be wrong. I installed Crossover and installed the music player in it, which it ran in and is where I discovered that you need .net 2.0 and 4.0 (It had the player in it's database and installed .net automatically) Ran Discord (It uses output/input, so may as well add that in) The player was MusicBee, and when it crashed, it also left a log that I could probably try to reproduce if needed.   Specs: Dell Precision T7400, 1x Intel Xeon x5482 Nvidia Geforce GTX 660 16GB ddr2 ram 667mhz (Tested to be working correctly, please don't ask me to run a mem test I am impatient enough as it is)
    • 980m+intel 530, 6820hk 512ssd+120ssd+1TB im trying to install macOsierra, and i tried a lot of combinations of arguments and configuration, nothing seems to work, i got the same problem every time ofter i start the installation! Is saying: System uptime in  nanoseconds: some random numbers.
    • Hello guys!


      Today I tried to install macOS High Sierra from a bootable usb, but my pc froze during the booting process.
      I need help. Can you help me?

      Here I attached a demo with the problem.
      https://goo.gl/cp5E8M


      Thanks in advance!
    • Hi, I am new at this, I installed maverick on a Lenovo g460 and everything ok but when I try to start appear a screen and say "system uptime in nanoseconds..." , I use -x and -x and others but I can't solve my problem. Sorry for my English. Thanks 
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,532

×