• Download Hackintosh

  • Files

  • Posts

    • Help with Intel G530 graphics @Niresh I need your help please! On my desktop computer I have an Asrock H61M-VS mobo with Intel Celeron G530 CPU and integrated graphics. The only successful Hackintosh installation I’ve ever done is the one with your Sierra distro 10.12.3 in which graphics works perfectly. I wanted to ask you what did you put in your distro to make also G530 integrated graphics working. With every other way to install Hackintosh on a pc I’m unable to get to the installer as I’m stuck in verbose mode due to unsupported graphics. Please answer me, thank you so much!
    • Yes truely its possible to upgrade its kinda hard todo because if you have AMD Proccessor you need to wait until niresh releases a new hackintosh distro. and then make a backupwith time machine and install the newer mac from usb and then you will be asked to have your old data back from windows machine or from your old mac version which if you choose from mac all data will be copied to your new sierra from yosemite so you don't need to lose any data or backup everything on a different usb drive and then use time machine to recover files from usb if its possible because i never use time machine. If you don't want to recover any data then just click on configure as new mac. And it is safe to download app store updates if you have a good intel processor if you have amd you need to use a custom kernel which somebody has patched.   Just search on google with this search term: (example) hackintosh sierra amd patched kernel update 10.12.6 is the latest or you want to update yosemite to 10.10.5 search for update patched kernels amd 10.10.5   https://www.google.nl/search?q=amd+kernel+patched+hackintosh+yosemite+10.10.5&source=lnms&sa=X&ved=0ahUKEwiv5teI6ZzVAhUMmBoKHaHrAkQQ_AUICSgA&biw=1920&bih=925&dpr=1 Here is the search term i already have for you if its only what you need the search term i used =: amd kernel patched hackintosh yosemite 10.10.5 Or find on youtube a good video how to upgrade a hackintosh yosemite to sierra
    • Loos like a kext eror or a missing dependencie try to boot with -x for safe mode it disabled dangerous kexts to boot mac without issues and maybe by updating or find another or delete the highlighted kext that is causing a kernel panic   try also when you setup the mac try also with: -v -x xcpm kext-dev-mode=1 maybe that should initialize all kexts. Mostly a kernel panic will come if a kexts is required for booting the system is corrupted, missing or you must to update the kext because its outdated or you need to downgrade the kext to older version using kext wizard doesnt matter to install older or newer kexts supported for your lapotp model or desktop and the right mavericks so your system could boot normally.   i looked up for ya the patched kernel you use i think its not supported with your cpu and i think that will only cause more problems.   Bronzovka's (A.K.A. Bronyas) 10.9.0 mach_kernel_rc7     AMD Athlon(tm) II X2 250 AMD Opteron™ Processor 3350 HE AMD FX-8320 AMD FX-8350 AMD FX-8150 AMD Athlon™ X2 340 AMD Phenom II X4 955 [Black Edition] AMD Phenom II X6 1055T Intel Paxville Xeon DP AMD A8-4500m APU Others (Maybe others like i3 i5 i7 maybe not pentium D) im not sure but try to use the vanilla way. And the kernel extensions one of them are faulty. Like it says kernel extension in backtraces. i think you found your problem by download and replace the corrupted com.apple.kec.CoreCrypto kext which maybe can be found in /System/Library/Extensions so first try to reinstall from usb with original niresh kernel dont use amd kernel because you have intel and after it says installation complete... restart ETA like 10 seconds click restart you see a chameleon bootloader so as you mentioned in your problem then try -v -x xcpm npci=0x2000 dart=0 then setup the mac and reboot without -x  see if that works.    
    • Only if you have 2 partition or 2 hard disk because Sierra and yosemite includes the same folders for system files like application there within safari etc utilities it will overwrite so you have to install it on a different hard disk or shrink/split your volume in 2 partition so just split 1 harddisk in 2 partitions   BTW: You need to search the tutorial (how to partition 1 hard disk in 2 partition for hackintosh etc....) it doesnt matter which search term you use you got to search it on google bc im not gonna advertise other tutorials for sites maybe you can find a tutorial on https://hackintosh.zone look in the forums there is something useful in here.
    • Use another tool or wait for a update or just do it like terminal way and then install uefi clover or legacy boot mode so hard shouldn't it be.  
  • Download Statistics

    • Files
      846
    • Comments
      2,134
    • Reviews
      2,536

  • 0
mahmoud asem

problem with niresh on lenovo s510p

Question

my laptop is lenovo s510p specs as follows

processor : Intel® Coreâ„¢ i3 4010U Processor (3M Cache, 1.7 GHz)

ram  :          6 gb

video card : intel HD graphics 4400

 

when booting niresh installation on hp probook 4540s the installation works like charm , 

and when booting on lenovo s510p the bootloader doesnt even show up 

 

please help !!

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

Ya ... same problem. When booting on lenovo s510p the boot loader doesn't even show up.

Tried making different bootable pendrives from Niresh DMG and ISO versions as detailed in the guides.

The pendrive works flawlessly on other laptops i.e. my Asus K53SD , installed and working fine.

But when booting on Lenovo S510p , the bootloader doesn't even show up giving up a black screen.

I am not able to reach the Niresh's Mavericks boot screen.

Also tried with different bios settings ... like changing UEFI and Secure boot... etc.

 

Please HELP .!

 

My Specs

 

Lenovo Ideapad S510p..came with pre-installed Windows pro 8.1
 
CPU
            Intel Core i3 4010U @ 1.70GHz
            Haswell ULT 22nm Technology
RAM
           8.00GB
Hard Disk
           1 TB
Motherboard
           Lenovo IdeaPad S510p (CPU Socket - U3E1)
Graphics
           2047MB NVIDIA GeForce 820M 
Audio
           Realtek High Definition Audio
Network
          Qualcomm Atheros AR8172/8176/8178 PCI-E Fast Ethernet Controller (NDIS 6.30)
          Qualcomm Atheros AR956x Wireless Network Adapter

Share this post


Link to post
Share on other sites
  • 0

Hi, I've got a Lenovo ideapad s510p as well.

Mine has got i7 but is anyway an haswell CPU.

Well, I tried and tried lots of times booting the Hackintosh Zone USB distro, but nothing. All your problems are because of the Haswell CPU

I made the Yosemite 10.10.1 by Hackintosh Zone DVD (It's very important to burn the iso file on a DVD, USB doen't work with haswell cpus) with the iso file  you'll find in hackintosh zone site (you must buy a DVD DL),

I booted with /haswell flag and it worked!!!!

Be careful, you first MUST DISABLE THE DEDICATED GRAPHICS CARD, because it doesn't work (You must go to the BIOS and select Graphics Mode - UMA Only).

Install it DISABLING THE INTEL VIRTUALIZATION TECHNOLOGY.

Possibly your INTEL HD 4400 will not work immediately, just shutdown and turn on the pc several times.

Idk wich network card you have, but mine did not work and there were no kext for it anywhere, it were not compatible. If this happens also to you It's a very big problem, because lenovo put a block in the Bios that impede to change it (this block is called Whitelist), I spent weeks trying to understand what did I have to do.

All what you have to do is go here https://www.bios-mods.com create a new account and ask them for a modified bios without the Whitelist for your lenovo, they will answer immediately. It's free of charge. Than you must patch your bios ( is very easy and you'll find the instructions in that site) and then you can buy a new network card. I bought the Azurewave NB037H on eBay (15 euros), and with the kext that I've attached here it will work (Idk if the Bluetooth works, just try)...

Now I've got my hackintosh perfectly working... sorry if the screenshot that I've attached is in Italian...

If you have any problems ask me, I'm not an expert but I'll try to help you.

Let me know...

P.S. I'm so sorry for my incorrect English, excuse me....

AirPortAtheros40.kext.zip

2628-Bluetooth_10.7_10.8.zip

Senza titolo.png

Edited by Alcatraz_2000

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now