Sapphire AMD 7850 2 GB driver install error. - OS X Mavericks 10.9 - Hackintosh Zone Jump to content
  • 0
Guest sexenx

Sapphire AMD 7850 2 GB driver install error.

Question

Guest sexenx
Hi there, 
 
My system information: 
 
Processor: AMD FX 6300 
Graphics card: Sapphire Radeon 7850 2GB 
Motherboard: MSI 990FXA-GD65 
 
Bios settings: 
 
ACPI S3, 
HPET Mode: Yes, 
SVM Mode: Yes 
 
My story: 
 
I installed niresh 10.9 maverick with usb boot. During boot: amdfx -v. 
During the selection of the disc "Customize" setting did not touch. 
 
I installed smoothly  and usb drive off. Then on first boot "Memory allocation. System halted." I got the error. 
 
I went back to Windows. TransMac using the S / L / E erased all the graphics drivers. Except "amdsupport.kext". 
 
Restart the computer. Boot: "GraphicsEnabler=No". System is opened successfully. 
But the display board showed 3 megabytes. Continuous scratching and freezes. 
 
(Google translate and edit. sorry.)
 
 
Now I got to do to install the graphics driver? 
 
Thank you. 
Take it easy.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I have the same gpu and solved the problem! You don't need any other kexts except for the one that come with the niresh installation (so don't just go deleting some and adding some).

 

1.) Locate AMD7000Controller.kext and AMDRadeonX4000.kext/ in S / L / E

2.) Drag these two files on to the desktop

3.) Right click on AMD7000Controller.kext and choose "Show Package Contents"

4.) Now inside the kext, go into "Contents" then open Info.plist

5.) Inside Info.plist, Press command & f together to pull up a search box

6.) Search for the number sequence "0x68181002" and replace the second number "8" with a number "9"

7.) This should be the new number: "0x68191002". Save that Info.plist and install the kext with Kext Utility

8.) Now do the exact same process for the other kext file: AMDRadeonX4000.kext

 

Now that you edited and installed those two kexts, you need the OS to recognize your Graphics Card on boot 

1.) Locate /Extra folder that is in your Mac OS drive and look for Boot.plist (may be called something else but it always has "boot" in it)

2.) Add this boot option to your boot plist:<key>device-properties</key>

<string>8900000001000000020000003f0000000100000002010c00d041030a000000000101060000040101060000007fff0400160000006200750069006c0074002d0069006e00000005000000013e0000000100000002010c00d041030a000000000101060000117fff0400180000006400650076006900630065002d006900640000000800000081260000</string>
Note: Those numbers are the hexadecimal code for my Graphics Card (AMD Sapphire HD 7850 2GB), so assuming we have the same GPU, this code will work.
If you need a different code for a different GPU, that will a series of extra steps
 
If all goes well, your Hackintosh should fully utilize and recognize your Graphics Card. Enjoy the smooth graphics!!!

Share this post


Link to post
Share on other sites
  • 0

sir you give me mind

thankyou i will follow you

i have

sapphire 7850 1g

please give me a code into my  chameleon boot list

 

your code insted  GraphicsEnabler=Yes, right ?

 

we use GE=NO because chameleon dont support 7850

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $49.70 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Niresh, first of all, thank you for your help. I can't disable the NVIDIA GPU, even on the BIOS settings, there is no such option. I have even looked on the manufacturer help fórum, there is nothing in that regard. Is there a way to make these DSDT patches on your release? Could you make a guide or a video of it? I tried looking at some guides on tonymacx86.com, but it's too complicated for me (and also, I don't have a running version of MacOS on my computer). https://www.tonymacx86.com/threads/fix-window-server-service-only-ran-for-0-seconds-with-dual-gpu.233092/ https://www.tonymacx86.com/threads/guide-dell-inspiron-14-7460-series-7000-uefi-hotpatch.236039/ 
    • And about the SMBIOS, can you tell me about it?  cause, i dont know what is that for. and where can i find that thing? And the /haswell boot-arg, do i have to enter it everytime that i want to boot in Mac OS X? (Also thanks for the help about the graphics again.) (tries again) I tried t install but kernel panic. i ut the haswell boot flag and verbose mode. 
    • hi ive tried the install from this topic https://www.hackintosh.computer/868/hackintosh-sierra-zone-aka-niresh-sierra-guide/   but it failed everytime dont know if my parts are not compatiple or im stupid (and sorry for my bad english) when i try to but the usb stick in my bios Uefi:USB Stick name i get to the screen where i can see 2 disks the hackintosh install disk i think and my hard drive when i try to launch it the apple logo shows up and 5-10 seconds later a white circle https://imgur.com/vpujoR1 and when i try to start the usb stick without the uefi name in bios and click run it gives me this error https://imgur.com/a/M7Ymk   intel core i7 6900k gtx 1080 asus x99 rampage v extreme     can someone help me
    • @Niresh Its going to this error ONLY sometimes i have other problems one Is With WiFi connection 2. Is With flashes (Graphics drivers i think?)  And next is bootloader i need my flash drive With bootloader to load MacOs There Are too bugs And more in this link Are all my notebook specs Notebook specs
    • I'm trying different boot-flags, but still nothing. Let me know if you find a solution.
  • Download Statistics

    • Files
      845
    • Comments
      2,132
    • Reviews
      2,557

    Latest File
    By 8osm3rka

    24    0

×