AR9285 installed but no wlan - OS X Yosemite 10.10 - Hackintosh Zone Jump to content
  • 0
Sign in to follow this  
Swen Pelzer

AR9285 installed but no wlan

Question

i have installed my AR9285 WLAN Card to my notebook and Installed the new kext.

so now i restarted the notebook and it shows me the WLAN symbol and it says it searches but it doesn't find any.

 

anyone an idea?

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

This is patch for DSDT

Device (ARPT)
                {
                    Name (_ADR, Zero)
                    Name (_PRW, Package (0x02)
                    {
                        0x09, 
                        0x04
                    })
                    Name (_SUN, One)
                    Method (_DSM, 4, NotSerialized)
                    {
                        Store (Package (0x12)
                            {
                                "AAPL,slot-name", 
                                Buffer (0x08)
                                {
                                    "AirPort"
                                }, 

                                "device-id", 
                                Unicode ("*"), 
                                "device_type", 
                                Buffer (0x08)
                                {
                                    "AirPort"
                                }, 

                                "model", 
                                Buffer (0x33)
                                {
                                    "Atheros 9285 802.11 b/g/n Wireless Network Adapter"
                                }, 

                                "subsystem-id", 
                                Buffer (0x04)
                                {
                                    0x8F, 0x00, 0x00, 0x00
                                }, 

                                "subsystem-vendor-id", 
                                Buffer (0x04)
                                {
                                    0x6B, 0x10, 0x00, 0x00
                                }, 

                                "compatible", 
                                Buffer (0x0B)
                                {
                                    "pci168c,2a"
                                }, 

                                "IOName", 
                                Buffer (0x0B)
                                {
                                    "pci168c,2a"
                                }, 

                                "name", 
                                Buffer (0x0B)
                                {
                                    "pci168c,2a"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $80.78 of $100.00 goal reached.
    Donate Now
×