[Need Help] Niresh Mavericks (Partially) Working on Asus Q550LF - OS X Maverick Zone Hackintosh 10.9.0 - Hackintosh Zone Jump to content
  • 0
pacificfils

[Need Help] Niresh Mavericks (Partially) Working on Asus Q550LF

Question

pacificfils    0

Hello,

 

Recently I installed Niresh 10.9.0 Vanilla 10.10 onto my Asus Q550LF.

 

The install went smoothly, but some things still do not work.

 

Working So Far:

Out Of The Box:

  • Base System
  • USB Ports
  • Bluetooth
  • USB HID
  • Keyboard Mapping
  • Webcam
  • Touchscreen (Single Touch Only)
  • Graphics (Accelerated)

Needs KEXTs/Patched Config:

Not Working So Far (Sorted by Priority):

  • [DSDT In Progress] Backlit Keyboard - Works, but can't adjust it. Might be a KEXT issue.
  • Brightness Control - DSDT hell
  • Audio after Sleep (This looks promising)

Not Going To Work:

  • WiFi. I use an Intel 7260 card, so this is very unlikely to ever work.
  • nVidia Graphics w/ Optimus Graphics

 

Output of lspci:

00:00.0 Host bridge: Intel Corporation Device 0a04 (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Device 0a16 (rev 09)
00:03.0 Audio device: Intel Corporation Device 0a0c (rev 09)
00:04.0 Signal processing controller: Intel Corporation Device 0a03 (rev 09)
00:14.0 USB Controller: Intel Corporation Device 9c31 (rev 04)
00:16.0 Communication controller: Intel Corporation Device 9c3a (rev 04)
00:1b.0 Audio device: Intel Corporation Device 9c20 (rev 04)
00:1c.0 PCI bridge: Intel Corporation Device 9c10 (rev e4)
00:1c.2 PCI bridge: Intel Corporation Device 9c14 (rev e4)
00:1c.3 PCI bridge: Intel Corporation Device 9c16 (rev e4)
00:1c.4 PCI bridge: Intel Corporation Device 9c18 (rev e4)
00:1f.0 ISA bridge: Intel Corporation Device 9c43 (rev 04)
00:1f.2 SATA controller: Intel Corporation Device 9c03 (rev 04)
00:1f.3 SMBus: Intel Corporation Device 9c22 (rev 04)
00:1f.6 Signal processing controller: Intel Corporation Device 9c24 (rev 04)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 0c)
03:00.0 Network controller: Intel Corporation Device 08b1 (rev 6b)
04:00.0 3D controller: nVidia Corporation Device 0fe3 (rev a1)

I come from the world of Linux, so I am comfortable with the command line. If you can please help fix the majority of the problems, I will be very grateful.

 

Specs:

 

CPU: Intel® Core i7-4500U

GPU 1: Intel® HD Graphics 4400 (Integrated)

GPU 2: NVIDIA GT 745M (Dedicated)

Chipset: Unknown (sorry)

WLAN: Intel® Dual Band Wireless-AC 7260 (Supports Bluetooth)

LAN:  Realtek RTL-8111 PCI Express Gigabit Ethernet controller

Audio: Realtek ALC668

 

 

---

 

I will keep this post updated with progress, so that other users may find success with the Q550-LF.

 

---

 

This is my first ever Hackintosh, so please forgive me if I do not give enough information or similar. Ask and I will try my hardest to get that info for you.

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi,

 

Praise the lord. I've found a post on the Yosemite install for this notebook. I've been trying to do it myself with no avail. First, I would like to thank you for making this post. I would really appreciate your guidance in helping me install Vanilla Yosemite on this Asus Q550LF. It's a really hard thing to do for me. I have computer experience but NEVER tried to do hackintosh before and I'm lost. I have followed many guides to make USB to "Install OS X Yosemite" on my laptop. My specs are exactly like yours except I removed the cd/optical drive and put an HDD caddie for PNY Optima 240GB SSD. I would like to install a dual boot OSX Yosemite 10.10 with Win8.1 thru Clover (latest version). Also, I want a vanilla install so no need for usb key to boot.

 

Could you please show me? Any chance I can touch base with you via email?

Share this post


Link to post
Share on other sites
  • 0
pacificfils    0

Hello trance!

 

This was also my first Hackintosh, so I logged almost everything I did. Before any of this, you're going to want to do some partitioning. Using a partition tool like GParted or similar (use a Ubuntu Live CD), shrink your Windows partition and make room for an OSX partition. I made 200GB of space, but you can make whatever you want. Just make sure it's above 10 GB. Alternatively, you can also use your 320GB drive, but that can be a "shared data" space too. Your call.

 

You're going to need these things to make a working Hackintosh:

 

  • One 8GB USB drive (OSX Install Disc)
  • One <Any Size> USB drive (File Container)
  • A current Mac computer running OS X Mavericks or Yosemite
  • Terminal Experience
  • A USB Mouse and Keyboard (builtin ones don't work during install)

Preparation (Do all of this on a Mac): 

  1. Follow these instructions to create your boot disc with the 8 GB drive. - Use the linked Network driver. You can get FakeSMC from here.
  2. Download all of the above linked KEXTs to your second USB drive. Also, get Kext Wizard. It makes installing KEXTs 100000 times easier.
  3. Download the Clover installer to your second drive.
  4. PATCH YOUR KERNEL! This is by far one of the most important steps. Without this, your system will not boot no matter what you do.

Installation:

  1. On your PC, you're going to need to enter the BIOS. When there, go find the SecureBoot setting. Make sure it is disabled. Save your settings.
  2. Plug in your prepared USB drive (Installer) with the patched kernel. If you did not patch the kernel, go back and do it now.
  3. Spam ESC when your system is booting. Select the USB drive.
  4. Select the USB drive ("Install Mac OS X")  in Clover. If all goes well, you should boot to the Setup screen.
  5. Go up to the Utilities menu and select Disk Utility.
  6. Find the partition you made for OS X and format it as "Mac OS X Extended (Journaled, Case-Sensitive)" -- You can also use the case-insensitive version if you want. BE SURE TO FORMAT THE RIGHT DRIVE!
  7. Exit out and start the install.
  8. When prompted, select the hard drive partition you made.
  9. Let OSX install
  10. When it's done, let it reboot.
  11. Boot back into the USB drive (ESC, select USB).
  12. Boot into the Installer again and patch your kernel. The post I linked earlier will explain this.
  13. Reboot back into the USB again.
  14. Now, select the Clover option for your new OS X install. If all goes well, you've successfully installed Mac OS X!

Post-Install:

  1. The very first thing you want to do once you've booted to the desktop is to swap to your "storage" USB drive.
  2. Install Clover. There are tons of good guides all over the internet. (You may also need to get Clover Configurator)
  3. Copy your FakeSMC to the Clover install. (If you don't see the EFI partition, install/open Clover Configurator and mount the EFI partition)
  4. Install KEXT Wizard. Now, take all of the KEXTs you've downloaded earlier and install them. You should also install the FakeSMC kext. DO NOT INSTALL THE ELAN DRIVER YET! You need to configure that.
  5. Make sure that FakeSMC is in its 10.10 folder. If not, you won't be able to boot without your Installer USB.
  6. Reboot. You should have working networking now!
  7. Go to the ELAN driver thread and read how to configure it. Once that's done, install it using KEXT Wizard. Most everything should work.
  8. Now, the fun part. DSDT. I'll upload my DSDT here soon. You may need to configure it a bit (guides online). Once done, place it in the root of your hard drive with this exact name: `DSDT.aml`
  9. Open Clover Configurator and mount the EFI partition. Navigate to EFI/BOOT/CLOVER. You'll see a config.plist
  10. Using a good PLIST editor, change the KernelPm setting under KernelAndKextPatches. It should be TRUE.

You should have a working base OSX install now. You'll need to make your own changes, but this should get you started.

 

Keep in mind that when updating, you're going to need to re-install the AppleHDA kext. But otherwise, everything should work.

 

Battery indicators may be a bit of an issue. See how it works for you. If it doesn't, there's a guide on DSDT patching somewhere. Post back if you have problems or questions.

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

So I managed to install the OS yesterday. I believe in step 2 post install is where I install the clover bootloader onto the hard drive. But I don't know how to do that . Please point me to a guide that you've used. I ultimately want a "vanilla" bootable OS X Yosemite w/o the USB stick always connected to my laptop. Please help and refer me to a guid for a direct install of the clover bootloader onto the HDD.

Share this post


Link to post
Share on other sites
  • 0
beniah1287    0

PLease help!

 

I'm attempting to hackintosh my asus q551.

 i7-4510U

Nvidia Geforve 840m (I'm not expecting this to work)

Intel HD 4400 Graphics (it might be intel HD 4000)

1 TB 5400 rpm HDD (instea of CD Drive)

480 GB SSD (In Primary HD spot)

 

I have successfully created a boot disk using these instructions with Unibeast instead of the method describedabove. I have patched the kernal and the disk boots into the installer. When running in verbose mode my install appears to freeze up after loading bluetooth. I have tried combinations of these bootflags: -x -v -f GraphicsEnabler=No GraphicsEnabler=Yes CPUs=1. I'm giong to post a picture of where verbose mode stops.

 

Please help, I'd really love to get Mavericks running, I know that my laptop is slightly different from the Q550, but I think the only difference is the dedicated graphics card, which I don' plan on using. Thank you so much and thanks for making this easy for guys like me!

 

Screen SHot Of Verbose Mode:
http://picpaste.com/IMG_0880-UDM9r2ld.JPG
 

 

IMG_0880-UDM9r2ld.JPG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Hi guys. Well, this is my second day of troubles, I touched everything, I installed max like 5 times in the same day, trying to figure out things and well. My Mac it display my graphic card on the #About this Mac tab With 2047MB ( So I guess all is right ) I installed the latest nvida drivers and on clover I activated the NvidaWeb. The problem is the resolution. Max resolution allowed is 1280 x 1024 and 800 x 600. I used to boot with nvd_drv 1 with nvd dry 0, I used to boot with all that things, and without them.  BUT No way to fix the resolution. Someone knows what-s going wrong and how can I fix it? Bdw im using iMac14,2 and OS X Sierra 10.12.3 Im connecting to the screen with DVI adapter. ( Maybe that causes the problem ) But it shows Im running 2047 MB so... idk why I can't change resolution. Thanks!  
    • Hello , i have a big problem , help me please, i have installed properly Mac OS Sierra , but now i can’t boot Windows 10, when i click on a image , which has written for example boot Windows from legacy hd3 , it blocks on an image with the Apple sign on an hard disk image, and when i enter the bios i can’t see tue hard disk in boot options, how can i add Images? Pleaseeeee
    • Im trying to install MacOSierra on Alienware 15 r2,  512ssd nvme 951 and 120gb intel sataIII samsung, i6820 hk 980m, intel 530. Ofter many attempts i solved a lot of erros during the installation, and finnaly i found out that macOs does not suport SSD. I created a patch for my ssds but now, i have this error: ACPI ERROR; and last: AppleNVMe Assert failed;  2 SSD: // Inject bogus class-code for NVMe SSD to prevent IONVMeFamily.kext from loading
      DefinitionBlock("", "SSDT", 2, "hack", "NVMe-Pcc", 0)
      {
          External(_SB.PCI0.PEG0, DeviceObj)
          Method(_SB.PCI0.PEG0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
          External(_SB.PCI0.SAT0, DeviceObj)
          Method(_SB.PCI0.SAT0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
      }
      //EOF   I did the patch in virtual machine as they instructed. but still nothing.
    • Hey!  I successfully installed macOS Sierra with the Version SierraAMD v3 on my AMD Pc.  But after setting up the PostInstall via Terminal, the OS stops booting at this line : ioconsoleusers: gioscreenlockstate 3, hs 0, bs 0, now 0, sm 0x0 Any solutions?    My System Specs: Mainboard: Asrock 970 Pro3 r2.0 Processor: AMD FX-6300 Graphics: Sapphire Radeon RX460 4GB   Thanks!
    • Ok, so I built a new hackintosh with Niresh Mavericks 10.9.0 on a modified Dell Precision T7400 and mostly everything seems to be working correctly except for two things: Sound (The obvious one), and Online video content (Youtube, Facebook videos, etc) play at lower than 1 fps, frozen speed, after 10 seconds of playback it reaches 4 seconds of elapsed time and I have found no other forums explaining this or talking about this so I decided to bring it up here. As for the sound situation, I already bought a new card to replace the X-FI, so yes, I am aware of the Sound Blaster Audigy X-FI Xtreme Audio not being supported, but what caught my attention is that the sound was working and video playback problem was gone temporarily, I happened to hear the sound from my headphones sitting on my desk and put them on, and sound. I decided to test a video on youtube, the problem with the videos, gone. But after a reboot, they were back. However I have the logs from today and can give them to whoever wants/needs them to figure out what may have caused the sound to kick in on the X-FI and maybe add support for this sound card. I copied as far back in the time that the system was on while sound was working that I could up to the shutdown event. I know it's pretty large but I am not sure where to look, I am simply handing this out to whoever wants to see what may have given me audio on this card for the session. From what I can see that looked to be the most closely related to my issue is something to do with bluetooth (I don't have bluetooth, btw), it says in console: "9/20/17 6:49:55.785 PM com.apple.audio.DriverHelper[200]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the mach service named com.apple.bluetoothaudiod." repeatedly many times. This could be completely unrelated.   The only recent actions I made that I personally can think of that may have triggered this would be: I installed several different versions of a music player through Winebottler and it failed to start, more and likely because of the lack of .net framework 2.0 and 4.0, this is my highest suspicion of being the likeliest cause, but I could be wrong. I installed Crossover and installed the music player in it, which it ran in and is where I discovered that you need .net 2.0 and 4.0 (It had the player in it's database and installed .net automatically) Ran Discord (It uses output/input, so may as well add that in) The player was MusicBee, and when it crashed, it also left a log that I could probably try to reproduce if needed.   Specs: Dell Precision T7400, 1x Intel Xeon x5482 Nvidia Geforce GTX 660 16GB ddr2 ram 667mhz (Tested to be working correctly, please don't ask me to run a mem test I am impatient enough as it is)
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,534

×