GeForce 9300GE and black screen - Hackintosh Mavericks - Hackintosh Zone Jump to content
  • 0

GeForce 9300GE and black screen


Hi !

My hackintosh is working fine, except for the graphics card.


Here are the GPUs I have now :

 - 7300GT

 - 7300LE

 - 9300GE (G98 chip)

 - The integrated GeForce 7100

 - A stock 8800GT (but the heat is just huge)


First, what GPU would be the best ? (I can buy others if it would be simpler)


For the installation, I used a 7300GT, because it worked without problem.

But currently, I don't have full resolution and no QE/CI (no accelerated graphics).


The nVidia GeForce 9300GE is more recent, so I think it would be simpler to use it.

So I first tried with stock nVidia drivers, but just before reaching the GUI (maybe two seconds after the "NVDANV50HAL loaded and registered" message), I get a black screen (no signal on all outputs). (and the hard drive stops making noise)


I tried these kexts (the 8400gs v2.0 have the G98 too) but no success.


In org.boot.chameleon.plist, I tried with GraphicsEnbaler on or off.


Any idea ?

Thanks in advance !





- CPU : Intel Core 2 Duo

- Graphic Card : to be chosen

- Motherboard : Gigabyte GA-73PVM-S2H (nForce 630i / GeForce 7100 integrated graphics)

Share this post

Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Ok, The problem is solved. I just had to update OSX to the last version using the combo update.


Acceleration and full resolution are fully supported using apple unmodified drivers and an injector.

Share this post

Link to post
Share on other sites
  • 0

I just checked with a nVidia GeForce 8800 GT, but nothing more : still the black screen on all outputs.


Thanks in advance 

Share this post

Link to post
Share on other sites
  • 0

Ok, now it work much better !


I tried lot of injectors but only one worked : NVInject  :D


I have now the full resolution and my 9300GE with its VRAM are recognized.

But... I have, for the moment, no graphic acceleration. The are some artifacts too on the screen.


How can I solve this ?


Thanks in advance



Share this post

Link to post
Share on other sites
  • 0



Unfortunately I dont have a solution for you but I can share my experience. I was messing with an nForce system initially and was getting good results but was also encountering the black screen issue that loads of people seem to be getting. I have temporarily killed the nForce mb so shifted my OSX86 quest on to another system, fortunately its a bit more suited to being a hackintosh. I'm using an 8800GT and I'm still getting the black screen (sometimes).  With Niresh 10.9.0 I can get full acceleration but only if I change the cards bios to a Quadro FX 3700 one; thats using the NVDA4All driver. I had some success when using the 8800GT bios when I was trying out adding an EFI string to chameleon. The last NVDA4All driver I used was version 2.3 for 10.9.4. Just to add I did get the system updated to 10.9.4 and had full acceleration but for some reason I could only update via appstore/system update, the combo installer always freaked out on me (actually quite a few installers have gave me problems). Now that apple have released the 10.9.5 update I'm stuck with graphical issues again lol.


I was using NVInject for a while but only got resolution options back, no acceleration and the screen tearing was doing my head in so I moved away from that solution.  Something kept telling me that the black screen issue is something to do with the card trying to set a strange mode. One reason being I could hear the sound of things going on while I was at the black screen, so the system was still running. I raked out some different monitors, none of them support particularly high settings, one can do 1600x1200 at some seriously low refresh but I was more looking for what the monitors would report back (if anything). A few Lenovo screens I tried did nothing other than going into stand by but a BenQ monitor reported back an unsupported mode, cannot sync message. Thats as far as I got investigating that but it let me know the graphics card was outputting something.


With getting graphics to work being somewhat hit and miss Ive changed my approach a little. Now I'm thinking, get 10.9.0 running with acceleration. Then add the card to the dsdt, then update .... and see what happens. :)


I'll add that I am a super noob in anything mac related. This is my learning experience. I'm still having issues trying to diagnose problems, but hey, getting there. :)


If you get up and running I'd love to know what methods you tried out.

Share this post

Link to post
Share on other sites
  • 0

Something kept telling me that the black screen issue is something to do with the card trying to set a strange mode. One reason being I could hear the sound of things going on while I was at the black screen, so the system was still running.


In my case, my system stops running because the hard drive stops immediately to make noises.

I think this problem is nForce related, because I have a friend who has the same problem with a 8800GT.


We are trying currently to inject by hand properties in Nvidia drivers.


Any idea ?

Share this post

Link to post
Share on other sites
  • 0

Ok, we tried to use the <device-properties> key in the boot.plist using the OSX86Tools generator and I was able to reach to full resolution and have the card name in "About my Mac", without NVInject. :)  But still no acceleration...


Idea ? 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals


    Please donate to support the community.
    We appreciate all donations!

    $62.87 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • I am fairly new to the idea of creating hackintoshes but I would love to dual boot Windows 10 and Mac OS Sierra on this machine listed below, will it be possible? Thanks in advance   Case CORSAIR OBSIDIAN SERIES™ 750D FULL TOWER CASE Processor (CPU) Intel® Core™i7 Ten Core Processor Extreme i7-6950X (3.0GHz) 25MB Cache Motherboard ASUS® RAMPAGE V EDITION 10: E-ATX, USB 3.1, SATA 6 GB/s Memory (RAM) 32GB HyperX PREDATOR DDR4 3200MHz X.M.P (4 x 8GB) Graphics Card   Asus Republic Of Gamers Strix NVIDIA GTX 1080 1st Hard Disk 480GB BiWIN 2.5" SSD, SATA 6 Gb/s (upto 564MB/sR | 513MB/sW) 2nd Hard Disk 6TB SATA-III 3.5" HDD, 6GB/s, 7200RPM, 128MB CACHE DVD/BLU-RAY Drive 16x BLU-RAY WRITER DRIVE, 16x DVD ±R/±RW & SOFTWARE Power Supply CORSAIR 1000W RMx SERIES™ MODULAR 80 PLUS® GOLD, ULTRA QUIET Power Cable 1 x 1 Metre UK Power Cable (Kettle Lead) Processor Cooling Corsair H100i V2 Hydro Cooler w/ PCS Liquid Series Ultra Quiet Fans Thermal Paste ARCTIC MX-4 EXTREME THERMAL CONDUCTIVITY COMPOUND Extra Case Fans 2x 120mm Apache Black Quiet Fan (fitted to extract from rear/roof)     Sound Card ONBOARD 8 CHANNEL (7.1) HIGH DEF AUDIO (AS STANDARD) Wireless/Wired Networking 10/100/1000 GIGABIT LAN PORT (Wi-Fi NOT INCLUDED) USB Options MIN. 2 x USB 3.0 & 6 x USB 2.0 PORTS @ BACK PANEL + MIN. 2 FRONT PORTS Operating System Genuine Windows 10 Professional 64 Bit - inc DVD & Licence Operating System Language United Kingdom - English Language DVD Recovery Media Windows 10 (64-bit) Professional DVD with paper sleeve Office Software NO OFFICE SOFTWARE Anti-Virus NO ANTI-VIRUS SOFTWARE Browser Google Chrome™ Warranty 3 Year Silver Warranty (1 Year Collect & Return, 1 Year Parts, 3 Year Labour) Delivery STANDARD INSURED DELIVERY TO UK MAINLAND (MON-FRI) Build Time Standard Build - Approximately 7 to 9 working days
    • hii i am using samsung laptop intel i3   M370   2.40 Ghz  nvidia geforce  M315  graphics when i boot from usb,  firstly show some code and after this show a dialog box . in this box , showing a phone and laptop, one by one. on the top of the screen, showing apple logo and "Language Chooser". i am not able go next step.   plz help me.
    • Hi guys, I installed the Hackintosh Sierra Zone image and most things work except my graphics. It detects as AMD R9 290X when I use FakeID 0x67B01002 on boot, however I only get 7MB of VRAM with no QE. My screen also tears as well. Hope someone can help me - Intel Core i5 2500K - AMD R9 290X 4GB - ASUS P8Z77-V LX
    • Hey guys, I'm looking into dual booting OSX Sierra or High Sierra on my ASUS Zenbook Pro UX501V. I use a lot of mac only software like sketch at uni and it would make my life a lot easier to just be able to boot into it instead of going to campus to use one of their Mac's. I'm currently running windows 10 and would prefer to not have to lose all my files or reinstall windows 10, however if this is unavoidable I would consider it. Specs are Processor    Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz, 2592 Mhz, 4 Core(s), 8 Logical Processor(s)
      GPU    NVIDIA GeForce GTX 960m 4gb DDR5
      RAM    12GB DDR4
      BIOS Version/Date    American Megatrends Inc. N501VW.300, 9/05/2016
      BIOS Mode    UEFI Does anyone know of any guides? Or has done this before? Even a link to point me on my way. Looked into the clover bootloader and I'm under the impression that's the route I'll have to take. Thanks for any help you may have      
    • Hi everyone. Here are my specs MOBO :Gigabyte Z68 XP UD3 (1155) GPU : HD 6870 1gb CPU Intel i7 2600k (1155) 60gb SATA SSD   MOBO is using legacy Bios. This machine has served me well for years. I tripped a circuit breaker a few weeks ago and now it's stuck in a boot loop. I have setup a new bootable USB to reinstall but for some reason the boot loop is happening when I startup from this as well. I can manage to get to the desktop using the safe mode boot flag (-x) but after a few moments, the desktop freezes and the computer reboots. I used the 10.10.1 disc image to create the new USB stick I am not sure if this could be causing the boot problem in the USB. Should I have used the 10.10.0? At first I suspected a hardware issue but I left the computer on for two days at in the bios screen and it stayed on just fine. Hoping someone can give me a hand figuring out which boot flags can get me going again or how I can reinstall the OS. I really need to get past the freeze/reboot cycle I am in. I am almost ready to nuke this thing and install windows
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By rembrandt63

    328    0