"Installer quit unexpectedly". Installer crashes, cannot install apps. - Hackintosh Mavericks - Hackintosh Zone Jump to content
hcs89

"Installer quit unexpectedly". Installer crashes, cannot install apps.

Recommended Posts

Hi, Hackintosh folks!

 

I have installed Os X 10.9.0 Mavericks from Niresh on my Asus K55VJ laptop. I have Windows 8.1 installed on SSD, and Os X is installed on HDD.
The problem is, that I can't install apps on my Hackintosh, because whenever I mount a dmg, and then start the installer it crashes with message "Installer quit unexpectedly".
When I click on "Report...", I get this in error report:
 

Process:         Installer [395]
Path:            /System/Library/CoreServices/Installer.app/Contents/MacOS/Installer
Identifier:      com.apple.installer
Version:         ???
Build Info:      Installer-721000000000000~67
Code Type:       X86-64 (Native)
Parent Process:  launchd [161]
Responsible:     Installer [395]
User ID:         501

Date/Time:       2014-10-24 15:09:06.248 +0200
OS Version:      Mac OS X 10.9 (13A603)
Report Version:  11
Anonymous UUID:  C6DDA294-0757-C0AA-8CC8-5F288A3E3715


Crashed Thread:  0

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /System/Library/PrivateFrameworks/Install.framework/Versions/A/Install
  Referenced from: /System/Library/CoreServices/Installer.app/Contents/MacOS/Installer
  Reason: no suitable image found.  Did find:
	/System/Library/PrivateFrameworks/Install.framework/Versions/A/Install: unknown file type, first eight bytes: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00

Binary Images:
    0x7fff604e0000 -     0x7fff60513817  dyld (239.3) <D1DFCF3F-0B0C-332A-BCC0-87A851B570FF> /usr/lib/dyld

Model: MacPro3,1, BootROM www.hackintosh.zone, 2 processors, Intel Core i3, 2.49 GHz, 12 GB, SMC 1.30f3
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In, 1024 MB
Graphics: Asus GeForce GT 635M, Asus GeForce GT 635M, PCIe, 1 MB
Memory Module: BANK 0/ChannelA-DIMM0, 4 GB, DDR3, 1600 MHz, Kingston, 99U5582-009.A00G
Memory Module: BANK 2/ChannelB-DIMM0, 8 GB, DDR3, 1600 MHz, Kingston, 99U5428-069.A00LF
Bluetooth: Version 4.2.0f6 12982, 3 services, 22 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
PCI Card: Asus GeForce GT 635M, Display Controller, Slot-1
Serial ATA Device: Samsung SSD 840 EVO 250GB, 250.06 GB
Serial ATA Device: WDC WD7500BPVT-80HXZT3, 750.16 GB
USB Device: Hub
USB Device: Bluetooth USB Host Controller
USB Device: ASUS USB2.0 Webcam
USB Device: Hub
USB Device: USB Optical Mouse
USB Device: USB Keykoard
USB Device: USB2.0 Hub
USB Device: USB2.0 Hub
USB Device: HD Webcam C525
USB Device: USB2.0 Hub
USB Device: USB Receiver
Thunderbolt Bus: 

I have searched the forums, but havent found a solution (not even a thread) for my problem. Does anybody have an idea, how could I fix this?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $48.99 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • ya no documentation ..and iam so confused to ..can some one make tutorial
    • Desktop Specs 
      Mob-: MSI X99a Godlike Gaming (MS-7883) (supports Legacy+UEFI)
      CPU- Intel 5820k (Haswell E)
      Graphics- MSI 980ti
      Ram- Avexir ddr4 8x4gb also, i have attempted using: OsxAptioFix2Drv-free2000.efi At the moment i typically get stalled with: Only single RAM bank (128 bytes) and some times I am getting: Couldn't allocate runtime area.
      Any advice would be greatly appreciated as im scratching my head wondering what the problem is - currently going to reformat the usb and start a new.
    • getting error (iobluetoothhcicontroller) (searchfortransporteventtimeouthandler) (missing bluetooth controler) apple loading bar stuck in middle if i boot normally. So i tried these  boot flags npci=0x2000 -v npci=0x3000 -v  -x-v PCIRootUID=1 -v PCIRootUID=0 -v still same error ?? Stuck in loading bar any solution?? thanks Acer Aspire 5733 (pew71) 

      Core i5 m560 @ 2.67 Ghz
      Intel HD Graphics
      Atheros AR5B125 Wifi
      Broadcom Net Link
      Realtek HD Audio
    •   I have a notebook with an integrated inter 510 graphic card and an nvidia geforce 920MX graphic. The problem is that the intel only takes me 3 Mb and the nvidia directly does not let me. I do not know if there is kext for both or how to fix it. Thanks in advance
    • Hi Guys, I’m stuck with 3mb VRAM, and can’t get my screen resolution! I’ve tried to reinstall 18 times with different configurations but I can’t seem to get it right! PLEEEEASE HELP I really don’t know what to do now. I've tried Enoch but still no success!   MY COMPUTER SPEC: System Model: HP EliteBook 8570p Processor: i7-3520M CPU @ 2.90GHz, 2901 Mhz, 2 Cores GPU:  AMD Radeon HD 7570M RAM: 12GB  

  • Download Statistics

    • Files
      848
    • Comments
      2,135
    • Reviews
      2,568

    Latest File
    By Vale1831

    1    0

×