Acer Aspire 4740 with Yosemite 10.10 Success ! - Installation guides - Hackintosh Zone Jump to content

Question

Well, I finally successfully installed Yosemite on my Acer Aspire 4740, this is my guide ...

First of all you will need a full runing Hackintosh or Mac to do some preparations :

1. Create a Bootable Yosemite USB Drive wih Unibeast using Tonymac's guide
2. Download (1st Gen) Intel HD Graphics Kexts 10.10 from InsanelyMac here 
3. Insert the USB drive, inside the USB's folders open : System/Library/Extensions 
4. Copy all this files into the Extensions folder (overwrite any file if required), these files came from the (1st Gen) Intel HD Graphics Kexts folder (use the untouched AppleIntelHDGraphicsFB.kext) :
 

AppleIntelHDGraphics.kext

AppleIntelHDGraphicsFB.kext

AppleIntelHDGraphicsGA.plugin

AppleIntelHDGraphicsGLDriver.bundle

AppleIntelHDGraphicsVADriver.bundle

 

5. Now, you are ready to install Yosemite on the Acer Aspire 4740, follow Tonymacx86's Yosemite install guide http://www.tonymacx86.com/445-unibeast-install-os-x-yosemite-any-supported-intel-based-pc.html
6. To enable full Graphics QE/CI follow InsanelyMac's 1st Generation Intel HD Graphics QE/CI guide (Here is the Intel's video  Linux dump.zip)
7. Download and install Tonymac's UniBeast using DSDT mode (DSDT.zip)
8. To make Sound and Ethernet work, download MacPoison for Yosemite and install VoodooHDA and Broadcom kexts
9. To enable Card Reader download Realtek's OS X driver package here
10. To enable Brightness just download and install this kext here (This kext requires DSDT patching otherwise will not work, my DSDT is already patched icon_e_wink.gif )
11. Use Chameleon Wizard to inject SMBios MacBookPro6,2 info. 
12. To fix iCloud, FaceTime and AppStore login issues follow this steps :
 

  • 1. Add this to your org.chameleon.Boot.plist:

<key>EthernetBuiltIn</key>

<string>Yes</string>

  • 2. Remove all Network interfaces
    3. Remove /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
    4. Reboot
    5. Re-add your Ethernet Network Interface. This must be en0. (not en1, en2...)

Not working (yet, if you can help) :

- Sleep

- Sound Mic

- HDMI Video out

- Battery sensor

 

If anyone can help to improve this Hackintosh feel free to post, any help will be apreciated.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $62.51 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hello! I made my usb key with transmac but when I start OS X Sierra everything goes well, the installation too but the installation blocks at 100%, time remaining: less than a minute. with it worked but not anymore. can you help me? My PC : it is a laptop: ASUS X751LD the motherboard I do not know, the hard drive I do not know but it's a HDD of 500 gb I have two graphics cards: Intel HD 4400 and Nvidia 820m, (which blocked me for the installation of Yosemite and High Sierra) thank you in advance.   PS : Sorry for my bad english i'm french ^^.
    • Hello! Yesterday I successfully installed Yosemite (Yosemite Zone distro) on my laptop (Sony Vaio FIT 15E with an i3-3217U). The only thing that doesn't work is the wifi card (BCM43142). I found in my house another wireless card, AzureWave AW-NB047H. Is this wireless card compatible with macOS?   Sorry for my bad english and thanks in advance. ~IOStream
    • i have installed sierra on my acer aspire e14 e5 - 475G 59C7 with processor i5-7200u 2.5GHZ  nvidia geforce 940MXX 2GB  4GB DDR4  when i install i disabled "move nvidia.pkg" "ati.pkg" "intel.pkg" installed works, but when i type something it gone too far. for example i just type "a" in 0.5 seconds it shows "aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa" anyone know how to fix this?        
    • Hello,
      On High Sierra 10.13.1 under VMWare.
      I install Final Cut Pro 10.4 when running got this error:
      This graphics configuration does not support hardware acceleration, which is required to run Final Cut Pro.
      My GPU is: AMD Radeon R7 240 but show on Hachintosh About : Graphics: Display 128 MB. Thank you for help.
    • I got same error 4 years later. On High Sierra. What's the solution? What you suggested doesn't work. Why does this happen? Any ideas?
  • Download Statistics

    • Files
      848
    • Comments
      2,137
    • Reviews
      2,570

    Latest File
    By Vale1831

    15    0

×