Waiting for root device - Hackintosh Mountain Lion - Hackintosh Zone Jump to content
Sign in to follow this  

Waiting for root device

Recommended Posts

hey guys.Last time i tried installing osx i got an error thats says waithing for root device.The installation whent fine.. but when i tried lunching it the first time its gets stock on waiting for root deviceMy laptop specs are: asus g75wvIntel® Core™ i7 3630QM ProcessorIntel® HM77 Chipset16 gigs of ram750 hdd ( added a 1 tb hdd so all in all 1,750 tb )Gtx 660m 2gb ddr5 ramAny ideas what might help the issue ?? Mozzdk

Share this post

Link to post
Share on other sites

i Use to get That error and went thru same things You are goin now.i Fix This error With a Kext.ok here is what you do.after you Finish installing Your Osx For the First Time. You open KextUtility and install a kext calledIOAHCIBlockStorage.kext and that should fix your problem.

Share this post

Link to post
Share on other sites

here is something else You should read:Parallel ATA (PATA), is a standard interface for the connection of storage devices such as hard disks, solid-state drives, floppy drives, and optical disc drives in computers.Serial ATA (SATA), was designed to replace the older parallel ATA standard, offering several advantages over the older interface: reduced cable size and cost, native hot swapping, faster data transfer through higher signalling rates, and more efficient transfer through an I/O queuing protocol.The drivers that ship with OS X already support the Intel ICHx drive controllers, but sometimes we need to apply to them a little adjustment or some other tricks. For example Apple doesn't use ICH7R, ICH8R, ICH9R or ICH10R, these have a different device ID than their non-R versions, and the drivers don't know about these, but they are similar enough that the driver will work fine anyway. Most will work right away once set to AHCI mode in your PCs BIOS, though some, such as the ICH10R, will be seen by OS X as "Generic SATA controller". Others will throw the "Still waiting for root device" error and halt during boot, which is when you know that1) your BIOS settings need tweaking2) you need to use one of the injectors mentioned below, or AppleIntelPIIXATA.kext3) you need to experiment with drive jumpering/cabling and how you're combining PATA and SATA drives (it's better to not combine the two at all)4) 1), 2) and 3) all at once.The Injector kexts described below "injects" device ID code for a bunch of ICHx controllers into the IORegistry where it can be hooked into by OS X' own ATA drivers so that they will detect and drive your hardware. You can use these if your ICHx controller can't be set to AHCI mode, or if you just want it to show by its proper name in System Profiler/System Information.AppleIntelPIIXATA.kext is a proper driver, it can work with older ICHx such as the ICH5. More details below.For Parallel-ATA, or non-AHCI mode Serial-ATA drives on Intel ICHx drive controllers:If you must mix SATA and PATA drives on ICHx, then welcome to your worst computing nightmare. There is absolutely no guarantee that the following will work. Whatever happens it's probably your fault for not having enough patience.Your DVD drive must be jumpered as master, connected to the end of the cable, and it will not work if there's a slave device connected to the same cable: Disconnect any slave device on the cable.If your installation target is a PATA hard drive, jumper it as master and place it at the end of the cable, on the other channel.Do not attempt to use two devices on the same cable in master/slave configuration - it will most likely not work.Older ICHx drive controllers don't have "AHCI" listed in the BIOS, instead they have annoying and non-descript settings like "enhanced", "combined" and "native" mode. Each of these modes allow a different combination of PATA and SATA drives, only PATA drives, or only SATA drives to work.The necessary details on this can be found in your motherboard manual somewhere. Now is a good time to read it.Two of these modes will work correctly with OS X, one of them will work with AppleIntelPIIATA.kext, and another with ATAPortInjector.kext. Honestly.Lastly, If you're mixing PATA and SATA drives on an ICHx that has "AHCI" mode, do not enable it, otherwise the PATA drives probably won't work.*For the love of all that is holy in this world, just buy a SATA DVD drive and be happy!!And if you must use PATA drives, connect them to your motherboards off-chipset, secondary drive controller (JMicron, Marvell, etc) and leave your hard drives connected to the ICHx in AHCI or RAID mode. If you only have RAID mode but no AHCI mode, set it to RAID. RAID implies AHCI. You don't have to create a RAID array, and even if you did it wouldn't work anyway, OS X does not support ICHx hardware RAID.If your drives appear on the desktop and have screaming orange icons it's because they are seen as "external". With some legacy kexts, hotpluggable AHCI hard drives get these orange icons. There are fixes for this available but I've forgotten almost everything about them. Neither can I recall if there is a way to have hot-pluggable hard drives, yet have them detected as internal drives. I do remember this; the quick fix for this in the past was OrangeIconFix.kext, but the downside is that it only changes the icons and doesn't actually fix anything. I believe that AHCIPortInjector.kext sets all drives as "internal", which does get rid of the orange icons, but this means you lose hot-plugability.

Share this post

Link to post
Share on other sites

yes boot to the usb drive again and install the kext with KEXTUTILITY i think is here in the download area.after you install it remove the usb and restart normal and let me know if you didnt got the error

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!

    $40.92 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • @Niresh i forgot to say that that error was given because i have a Samsung M2 NVMe 960pro. I tried to remove it and it kinda worked but with a lot of bugs even during the installation. I can't remember everything clearly now cause it's been like 4 months ago
    • Thanks. I Have One Ethernet And One Wifi. Here Is The Terminal Log :  iMac:~ marcus$ lspci -nn 00:00.0 Class [0600]: Device [8086:190f] (rev 07) 00:01.0 Class [0604]: Device [8086:1901] (rev 07) 00:08.0 Class [0880]: Device [8086:1911] 00:14.0 Class [0c03]: Device [8086:a12f] (rev 31) 00:14.2 Class [1180]: Device [8086:a131] (rev 31) 00:16.0 Class [0780]: Device [8086:a13a] (rev 31) 00:17.0 Class [0106]: Device [8086:a102] (rev 31) 00:1c.0 Class [0604]: Device [8086:a110] (rev f1) 00:1c.2 Class [0604]: Device [8086:a112] (rev f1) 00:1d.0 Class [0604]: Device [8086:a118] (rev f1) 00:1d.2 Class [0604]: Device [8086:a11a] (rev f1) 00:1d.3 Class [0604]: Device [8086:a11b] (rev f1) 00:1f.0 Class [0601]: Device [8086:a145] (rev 31) 00:1f.2 Class [0580]: Device [8086:a121] (rev 31) 00:1f.3 Class [0403]: Device [8086:a170] (rev 31) 00:1f.4 Class [0c05]: Device [8086:a123] (rev 31) 01:00.0 Class [0300]: Device [10de:1c82] (rev a1) 01:00.1 Class [0403]: Device [10de:0fb9] (rev a1) 03:00.0 Class [0c03]: Device [1b21:1242] 05:00.0 Class [0604]: Device [1b21:1080] (rev 03) 07:00.0 Class [0200]: Device [10ec:8168] (rev 15)
    • How many network adapters do you have? Like WiFi or Ethernet? Post output of lspci -nn command
    • Unfortunately i dont have any Option to disable my Grahpic Adapter. Can i disable it in an other way? Like any Boot Flags?   EDIT: I did just an Update for my BIOS but it didn't add any Options to disable my Graphics Adapter
    • This issue is called Discrete Graphics issue of High Sierra, To bypass this you have to disable either Intel HD Graphics 630 or Nvidia GeForce GTX 1060 from BIOS, Check into your BIOS to see if you have any options to disable Graphics, Then try booting Keep me updated
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By 8osm3rka

    21    0