Intel HD4000/ Lenovo G500s - OS X Mountain Lion 10.8.5 - Hackintosh Zone Jump to content

Question

Hello, i have a problem with my Graphics Card.

I don't have full graphics support of my Intel HD4000.

I have a Lenovo G500s.

 

Everything is working fine except Wi-Fi and graphics.

Wi-Fi i don't care i always use cable :P

But my graphics i want to have it working correctly.

 

My specs are:

 

Lenovo G500s

 

Intel Core i7 3612QM 2.10GHz

8GB DDR3 1600Mhz RAM

1TB HDD

Nvidia GeForce GT 720M 2GB (i know this one is not gonna work... )

Intel HD Graphics 4000 resolution 1366x768x32

 

 

here is some information in my System information field:

 

Intel HD Graphics 4000:

 

  Chipsetmodel: Intel HD Graphics 4000

  Type: GPU

  Bus: Ingebouwd

  VRAM (total): 64 MB shared systemmemory

  Fabrikant: Intel (0x8086)

  Apparaatcode: 0x0166

  Revisiecode: 0x0009

  Info kernelextensie: Geen Kext geladen

  Monitors:

Monito:

  Resolution: 1366 x 768

  Pixeldiepte: 32-bits Color (ARGB8888)

  Hoofdbeeldscherm: Ja

  Synchrone weergave: Uit

  Online: Ja

 

and another one:

Beeldscherm:

 

  Type: GPU

  Bus: PCIe

  Breedte PCIe-baan: x8

  Fabrikant: NVIDIA (0x10de)

  Apparaatcode: 0x1140

  Revisiecode: 0x00a1

  Info kernelextensie: Geen Kext geladen

 

This is my org.chameleon.boot.plist configuration

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Credits</key>
<string>Niresh12495</string>
<key>EthernetBuiltIn</key>
<string>y</string>
<key>GUI</key>
<string>No</string>
<key>GraphicsEnabler</key>/Extra/org.chameleon.boot.plist
<string>y</string>
<key>Kernel Flags</key>
<string>npci=0x2000 dart=0</string>
<key>Timeout</key>
<string>3</string>
<key>UseKernelCache</key>
<string>y</string>
<key>Kernel Flags</key>
<string>"Graphics Mode"="1366x768x32"</string>
<key>Graphics Mode</key>
<string>1366x768x32</string>
 
</dict>
</plist>
 
 
 
 
If someone can help me!
Thanks!!

 

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
abbas    0

Hi alexxRSD, I have the same model of laptop Lenovo G500s but the specs are different, Core i3 3110m, Intel HD 4000 graphics, Intel Centrino wilreless-N 135, Lan qualcomm atheros ar8172/8176/8178, how did you mange the get the LAN working? and are you using vanilla install? or Niresh Distro?

 

plz let me know as I am also trying to install.

 

thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Saludos!   Tengo el mismo error (RAM a 667mhz), con una placa base ASUS (y mi cpu es el fx 6300).   Lograste solucionarlo?
    • Hi guys. Well, this is my second day of troubles, I touched everything, I installed max like 5 times in the same day, trying to figure out things and well. My Mac it display my graphic card on the #About this Mac tab With 2047MB ( So I guess all is right ) I installed the latest nvida drivers and on clover I activated the NvidaWeb. The problem is the resolution. Max resolution allowed is 1280 x 1024 and 800 x 600. I used to boot with nvd_drv 1 with nvd dry 0, I used to boot with all that things, and without them.  BUT No way to fix the resolution. Someone knows what-s going wrong and how can I fix it? Bdw im using iMac14,2 and OS X Sierra 10.12.3 Im connecting to the screen with DVI adapter. ( Maybe that causes the problem ) But it shows Im running 2047 MB so... idk why I can't change resolution. Thanks! ================================= SOLVED EDIT: Hi guys, in Display Resolution, I just set it in "Default for display" and after that pressing "THE WINDOWS BUTTON KEY, IN MY CASE, IDK WHAT KEY IS THAT IN MAC KEYBOARD, I THINK THE CONTROL ONE OR IDK" PRESSING that key I selected Scaled, and it appears more options and resolutions. There is a video on youtube about that called "Mac OS X Display Resolution" If someone has the same trouble.
    • Hello , i have a big problem , help me please, i have installed properly Mac OS Sierra , but now i can’t boot Windows 10, when i click on a image , which has written for example boot Windows from legacy hd3 , it blocks on an image with the Apple sign on an hard disk image, and when i enter the bios i can’t see tue hard disk in boot options, how can i add Images? Pleaseeeee
    • Im trying to install MacOSierra on Alienware 15 r2,  512ssd nvme 951 and 120gb intel sataIII samsung, i6820 hk 980m, intel 530. Ofter many attempts i solved a lot of erros during the installation, and finnaly i found out that macOs does not suport SSD. I created a patch for my ssds but now, i have this error: ACPI ERROR; and last: AppleNVMe Assert failed;  2 SSD: // Inject bogus class-code for NVMe SSD to prevent IONVMeFamily.kext from loading
      DefinitionBlock("", "SSDT", 2, "hack", "NVMe-Pcc", 0)
      {
          External(_SB.PCI0.PEG0, DeviceObj)
          Method(_SB.PCI0.PEG0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
          External(_SB.PCI0.SAT0, DeviceObj)
          Method(_SB.PCI0.SAT0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
      }
      //EOF   I did the patch in virtual machine as they instructed. but still nothing.
    • Hey!  I successfully installed macOS Sierra with the Version SierraAMD v3 on my AMD Pc.  But after setting up the PostInstall via Terminal, the OS stops booting at this line : ioconsoleusers: gioscreenlockstate 3, hs 0, bs 0, now 0, sm 0x0 Any solutions?    My System Specs: Mainboard: Asrock 970 Pro3 r2.0 Processor: AMD FX-6300 Graphics: Sapphire Radeon RX460 4GB   Thanks!
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,534

×