PE1950 - Hackintosh Mavericks - Hackintosh Zone Jump to content

Recommended Posts

Life is complicated.

I want to install OS X (>=10.8.5) on Dell PowerEdge 1950. This is  a nice machine with PERC 5i SAS controller and it was running 1.x.x. bios with 5.1.4 raid firmware. The controller is not recognized by the standard OS X distributions but there is one nice guy ( who wrote a driver for it. The dell booted very well right to the installation setup screen with 10.9 (AMD) and 10.10 Niresh usb distributions and I managed to inject the SAS kext. Unfortunatelly it could not initiate the controler and ended with the FW error so the obvious move was to upgrade the RAID FW to the latest version. I did it and dit it also for the bios as this is what was recommended by Dell. After this nothing was the same. The booting ends up for both .9 and .10 with the same k. panic: "can't perform kext scan" but here goes some observations:

- it is not instant, it clearly reads the /System/Library/Extension (at least for .10) so it looks like after a kext gets injected something gets *beep*

- .9 boots well to the installation screen if:

    i) it boots from optical usb drive

    ii) it boots from a thumbdrive but an optical drive with .9 is present (in this case the OD blinks 2 times only during the whole installation process)

I have to say, I am pretty OS X illiterate but it seems to me something interferes with the USB drive during the boot time. Now, I can live with 10.9 but I don't know how to inject the SAS kext. Take a note that this is not (u)efi system. For the 10.10 I intuitively placed the kext into the /System/Library/Extension and it was read. 10.9 has it as mkext and before I spend next few hours trying to put the SAS kext to this mkext I would like to ask you about your opinion on what's actually is going on after the bios/fw was upgraded, whether something can be done to overcome this usb "can't perform kext scan" problem and what is generally the best way to inject this SAS kext for non efi system if this had to be 10.9.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!

    $48.99 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • ya no documentation ..and iam so confused to ..can some one make tutorial
    • Desktop Specs 
      Mob-: MSI X99a Godlike Gaming (MS-7883) (supports Legacy+UEFI)
      CPU- Intel 5820k (Haswell E)
      Graphics- MSI 980ti
      Ram- Avexir ddr4 8x4gb also, i have attempted using: OsxAptioFix2Drv-free2000.efi At the moment i typically get stalled with: Only single RAM bank (128 bytes) and some times I am getting: Couldn't allocate runtime area.
      Any advice would be greatly appreciated as im scratching my head wondering what the problem is - currently going to reformat the usb and start a new.
    • getting error (iobluetoothhcicontroller) (searchfortransporteventtimeouthandler) (missing bluetooth controler) apple loading bar stuck in middle if i boot normally. So i tried these  boot flags npci=0x2000 -v npci=0x3000 -v  -x-v PCIRootUID=1 -v PCIRootUID=0 -v still same error ?? Stuck in loading bar any solution?? thanks Acer Aspire 5733 (pew71) 

      Core i5 m560 @ 2.67 Ghz
      Intel HD Graphics
      Atheros AR5B125 Wifi
      Broadcom Net Link
      Realtek HD Audio
    •   I have a notebook with an integrated inter 510 graphic card and an nvidia geforce 920MX graphic. The problem is that the intel only takes me 3 Mb and the nvidia directly does not let me. I do not know if there is kext for both or how to fix it. Thanks in advance
    • Hi Guys, I’m stuck with 3mb VRAM, and can’t get my screen resolution! I’ve tried to reinstall 18 times with different configurations but I can’t seem to get it right! PLEEEEASE HELP I really don’t know what to do now. I've tried Enoch but still no success!   MY COMPUTER SPEC: System Model: HP EliteBook 8570p Processor: i7-3520M CPU @ 2.90GHz, 2901 Mhz, 2 Cores GPU:  AMD Radeon HD 7570M RAM: 12GB  

  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By Vale1831

    1    0