Yosemite on AMD... Success ? - OS X Yosemite 10.10 - Hackintosh Zone Yosemite on AMD... Success ? Jump to content
  • 0
rainmaker3

Yosemite on AMD... Success ?

Question

OK, here's my hardware :

 

1. Mobo : Asus M5A97 r2.0

2. Graphics : AMD Sapphire HD 7850

3. CPU : AMD FX 8320 @ 3.5 GHz

 

How I installed Yosemite on my hackintosh :

 

Steps :

 

- I downloaded Yosemite-Zone.dmg from the downloads section and followed the guide to make a bootable USB

- I googled Bronya AMD Kernel and I found this : http://wiki.osx86project.org/wiki/index.php/Patched_Kernels

- I placed the kernels in their files in the bootable USB

- I booted through the USB using each of these kernels. Some additional flags were needed, like npci and GE=no

- I installed Yosemite on a drive

- I replaced the correct kernels in the yosemite drive. Chameleon didn't work correctly because Yosemite stores the kernel files in a different directory in the system. I booted through the install USB's own bootloader. I got way too many errors and some kernel panics.

- I booted with -v -f -x and everything went OK. It booted up perfectly and I was able to transfer my user from Mavericks to Yosemite.

 

Trying to get it to work on normal mode :

 

- I booted into mavericks and I ran myHack on the Yosemite installation to fix problematic kexts and run myFix

- I replaced some kexts with the mavericks ones (my Mavericks installation works 100%) :

 

AppleACPIPlatform.kext
corecrypto.kext
IOACPIFamily.kext
IONDRVSupport.kext
IOPCIFamily.kext
IOUSBFamily.kext
 
- I booted up using kext-dev-mode=1 (it gave me a kernel panic otherwise)
 
 
Where I am now :
 
It boots up perfectly, shows the home screen with the users etc. but the USB's are ALL not responding to anything. I have tried keyboards, mouse, trackpads and nothing works. They worked OK in safe mode. Somebody please help. I thought that it is because of the kexts dependencies so I thought I should give it some time for other, more experienced, users to try and then follow their instructions. So, I hope this helps! Try it our for yourself maybe and let me know how it went.
 
P.S. : I tried booting with USBBusFix=yes , still the same. Similar problems occured when I used Clover as a boot loader some time ago. Maybe this is the problem... I think the built in bootloader for Niresh is Clover...
 
Cheers

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

normaly AMD can´t use clover,.. most of users get a kernel panic or instant reboot,..

my yosemite came with chameleon...

 

install new with chameleon in setup , unselect clover and test it again.

 

please report ;)

Share this post


Link to post
Share on other sites
  • 0

normaly AMD can´t use clover,.. most of users get a kernel panic or instant reboot,..

my yosemite came with chameleon...

 

install new with chameleon in setup , unselect clover and test it again.

 

please report ;)

 

I have tried running the installation with niresh's Yosemite for AMD but it hangs on "No driver found for platform : ACPI". I will try replacing some kexts and I will report back!

 

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting May 2018

    Please donate to support the community.
    We appreciate all donations!

    Thanks



    $35.82 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • I've added every kext possible, Lilu, IntelGraphicsFixup, changed my config settings nothing so far has worked. I tried asking for help on the tony mac forums, but was banned the minute I sent the progress report they asked for, for software piracy. (which makes no sense because any hackintosh is software piracy anyway) but regardless of that, I still have very choppy graphics, and only 4 mb of VRAM, as shown in the about my mac screenshot I linked below. Can anyone help?
    • Hi, 
      I finally decided to install macOS high sierra on my laptop - Lenovo IdeaPad 720S 15IKB.
      It has:   i5-7300HQ, Intel HM175
      12GB DDR4 RAM
      A Samsung 256GB NVMe Drive
      GTX 1050 Ti With Max-Q   The first try did not boot so i had to use some args to get it to boot. The first problem arises due to the fact that all available usb slots are usb 3.1. The installer did not recognise my keyboard and trackpad and i had to install some kexts to get them working. Well, after i intalled the kexts, It was stuck in a boot loop. I was fed up and it was late so i decided to download hackintosh zone from niresh. I would install it later. Well, when i run hackintosh zone it gets stuck at the apple logo after loading. I ran it in verbose mode and it gets stuck in the following   [Date] localhost com.apple.xpc.launchd[1] <Error>: Host-level exception raised: pid = 541, thread = 0xbf1f, exception type = 0xd, codes = { 0 }, states = { 0 }
      busy timeout[0], (240s): 'AppleEFIRuntime'
      busy timeout[1], (240s): 'AppleEFIRuntime'
      busy timeout[2], (240s): 'AppleEFIRuntime'   Then the screen goes blank and it starts over. Any help is appreciated. Thanks!
    • ASUS laptop X550D can run hackintosk ? help me ! please!!!   thanks alot
    • Oh, thank you but in the meantime I thought again and have installed High Sierra instead. It works just fine, put a camera, bluetooth, wifi, all working OK. I only have to solve a little problem when doing restart it freezes but after shutdown it comes up good! I have also Win7 on same mbr disk and I start with the installation usb but I think go over to EasyBCD to make a smoother boot. If your experienced I would appreciate very much any hints for helping me in this direction. 
    • Hello people!😃   I am new to the hackintosh community. I have a old pc at my home running windows 10 pro. Its a Pentium Dual Core 1.6ghz Processor. A 250mb intel HD i-gpu. (No dedicated Graphics card). A 2gb DDR2 ram. 160gb HDD.   Can i install any mac distro on it ?   I don't want to edit videos on it. I just want to start hackintoshing from this, than my laptop & than my friends laptop. Untill i master this art ☺.   Thank you.
  • Download Statistics

    • Files
      852
    • Comments
      2,144
    • Reviews
      2,600

    Latest File
    By Niresh

    542    0

×