Acer Aspire 5920G Help Please! - Troubleshooting - Hackintosh Zone Jump to content
  • 0

Acer Aspire 5920G Help Please!


Hello! Im desperatly trying to install Lion/ML/Maverics on my Acer Aspire 5920G

I have Leopard 10.5.8 installed and running quite well. The instalation went fine using GraphicsEnabler=No  (I still cant make it detect my mobility radeon x1600)

I cant install Lion, Mountain Lion or Mavericks. I use niresh on a usb, but cant replace files on the usb because it tells me that there's no space left after restoration. 

On Lion and Mountain Lion I get to this stage and it hangs (see picture attached)

On Mavericks it just reboots after loading some kexts. I'm using -v -x -f -F GraphicsEnabler=0 in any order and combination.

What am I doing wrong? 

Please help me!


Operating System
MS Windows 7 Ultimate 64-bit
Intel Mobile Core 2 Duo T5750  @ 2.00GHz 44 °C
Merom 65nm Technology
4,00 GB Dual-Channel DDR2 @ 333MHz (5-5-5-15)
Acer, Inc. Chapala (U2E1) 44 °C
Monitor PnP genérico (1280x800@60Hz)
128MB ATI MOBILITY RADEON X1600 (Acer Incorporated [ALI])
Hard Drives
244GB Hitachi Hitachi HTS542525K9SA00 ATA Device (SATA) 40 °C
Optical Drives
Realtek High Definition Audio
Posted Image

Share this post

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

I've noticed on some videos that just after "PCI configuration end..." the "RTC: single RAM bank (128 bytes)" message should appear, but it just doesn't.

Could the problem be related with that?

Share this post

Link to post
Share on other sites
  • 0

i've been able to get mine running on 10.8 last year with iTakos ML2 but thats it now i want to upgrade and i have the same exact problem as you do. If you want ML get iTakos and boot flag -v -x it should boot fine after, btw Wireless didn't work at all for me had to get an atheros wifi card to fix it


hope i can help



Share this post

Link to post
Share on other sites
  • 0

I'm trying to install iAtkos ML2 into an Acer Aspire 5920G (with -v and -x flags) and the installer boots but when I install itit never boots again, it keep frozen with "Smart battery" message (booting with -v flag). Someone knows what installation options must I select to make a good installation for this model? Thanks in advance.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting March 2018

    Please donate to support the community.
    We appreciate all donations!


    $77.09 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • i would built a hackintosh with yosemite but i dont know if its work with my pc but if please give me the kexts which i need  is it possible to install yosemite on my pc? My Specs: Intel Core 2 Quad q6600 4Gb ram Asrock  g31m-gs Integrated gpu but i have a gtx 580 3gb
    • Hello. I just installed hackintosh high sierra on my PC. It's version is 10.13 so is there any way I can update to 10.13.3? And also my hackintosh freezes when opening few applications like logic pro x. Please help me.
    • Same problem here. Did you solve this?
    • I was having an issue with installing High Sierra because I was getting this error OsxAptioFix2Drv: starting overrides for /System\Library\CoreServices\boot.efi
      using reloc block: no, hibernate wake: no I tried all the fixes that everyone was telling me about replacing the file with a different one but nothing worked. Finally I came across a post from some person who had a laptop that was designed like mine. I have the Aspire A515-51. The weird thing is that it has 8gb of ram installed. There is 4gb that is soldered to the motherboard and one 4gb ram in the only ram slot. Well this person stated that if he removed the 4gb ram that was installed in the ram slot the install would move past the error and install. I tried it and WOW it worked. I was able to complete the install and everything worked just fine but the wifi. So I hope this helps someone, but I am also hoping that someone can help me with the issue of the ram. I can't add the ram back into the ram slot or the boot will stall at  OsxAptioFix2Drv: starting overrides for /System\Library\CoreServices\boot.efi
      using reloc block: no, hibernate wake: no
    • Im stuck in this screen, i can boot the clover bootloader but i cant select the high sierra option because it doesn't appear. Laptop MSI PL 62 Specs: i7 7700 HQ Nvidia MX 150 1 tb hardrive
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By Vale1831

    58    0