[Intel Graphics HD4000 / GeForce 670M] Need help on Yosemite :) [Intel Graphics HD4000 / GeForce 670M] Need help on Yosemite :) - Hackintosh Yosemite - Hackintosh Jump to content
Robin Rangé

[Intel Graphics HD4000 / GeForce 670M] Need help on Yosemite :)

Recommended Posts

Hi everybody !

I'm new to Hackintosh, please forgive my newbieness. ;-)

After one week, I've finally suceeded in booting my PC under Yosemite (with Yosemite-Zone.dmg before it has been reported as corrupted).

I also tried Unibeast with Chimera (using a legit "Install OS X Yosemite.app") with no luck (I read that Chimera's IGPEnabler is broken with Yosemite) and MacPwn Yosemite (Clover) with no luck either as it just gives me a black screen when I try to boot Yosemite (even with -v in /Boot/Arguments of config.plist) and freezes on editing boot flags (both mouse and keyboard don't respond).

So, with Yosemite-Zone (Chameleon), I used those boot flags (as described in this post http://www.tonymacx86.com/yosemite-laptop-support/145699-asus-ux51vza.html, guy switching from Chimera to Chameleon and uses this boot flags successfully) :

GraphicsEnabler=Yes IntelCapriFB=4 SkipNvidiaGfx=Yes dart=0 nv_disable=1 -v

It boots successfully but with very slow graphics and poor resolution (1024x768). Mac OS indicates ("About this Mac") that I use Intel Graphics HD 4000 with only 4MB of VRAM. I tried to change IntelCapriFB to 3, 8 or 9, same result. As far as I understand, I can't use my Nvidia graphic card without disabling Intel Graphics (in fact, my BIOS doesn't have such an option...).


First of all (before trying to install kext for ethernet and Audio), I'd like to have my graphics working in full native resolution (1920x1080) with a decent VRAM (boot flag GraphicsMode="1920x1080x32" doesn't have any effect). Unless it's possible to use Nvidia display?!

 

Any help would be greatly appreciated. I'm about to give up but I love challenge.  :)

Thank you all in advance. Long live Hackintosh! ^^

 

Config details below but I join a partial export of my PC's config made with Speecy : click here to download it on Mega or see attached file.

Laptop: MSI GT70 0NC-297FR
CPU: Intel Core i7 3610QM Ivy Bridge @ 2.30Ghz
Socket: 988B rPGA
Motherboard: MSI MS-1762 (SOCKET 0) Rev. 1.0
Motherboard Chipset: Intel Ivy Bridge Rev. 09, southbridge Mobile Intel HM77 Express Rev. 04
Graphic Card: NVIDIA GeForce GTX 670M / Intel HD 4000
WLan: Intel Centrino Wireless-N 2230
Ethernet: Killer e2200 Gigabit Ethernet Controller (NDIS 6.30)
Audio: Realtek Semiconductor Corp. Realtek High Definition Audio

MSI-TheNoodle974.txt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting April 2018

    Please donate to support the community.
    We appreciate all donations!

    Thanks



    $31.08 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • I have the same cpu, GPU, and SSD. Did you ever get full gfx support? I'm sick of the stuttering. 
    • Install is hanging at 11 minutes  Localhost osinstaller 403 can not connect to /var/run/systemkeychaincheck.socket no such file or directory 
    • So far installer is working with amd phenom ii x4 965 black edition and gtx 750ti. Installing on a Kingston 240 GB ssd. Mobo is  m4a88t -v evo/usb3 from asus. Used boot flags /amd64 nv_disable=1 dart=0 -x -v
    • I managed to install the niresh mav distro and then did the combo update without reinstalling the hackintosh stuff after the update, this ofc resulted in my pc not booting. Ive tried to use the installer to do a time machine backup of my system pre combo update to no avail, and now I cant even get the installer to boot again. any and all help is greatly appreciated. I'm using a asus m4a88t -v evo/usb3 mobo and amd phenom ii x4 965 Deneb edition. I previously booted the installer using -amd64 nv_disable=1 dart=0 and I think -x -v but I cant remember. I think my bios needs to be updated but I cant even find the board on the asus site so any help with that would also be appreciated. if anyone is familiar with the hp flyer red laptop my wife would like me to hackintosh that as well. I have a working windows 10 install and working Ubuntu install, sandisk cruzer 32gb flashdrive and a couple blank cds at my disposal. 
    • hello i have installed sierra on dell optiplex 780 sff everything works perfectly except that i have installed a wifi dongle BL-WN151 in usb but my hack does not recognize it. thank you for helping me if you can. OS X sierra .....
  • Download Statistics

    • Files
      849
    • Comments
      2,143
    • Reviews
      2,612

    Latest File
    By ka209

    34    0

×