Graphics issues on Yosemite - Hackintosh Yosemite - Hackintosh Zone Jump to content
  • 0
Arunim Choudhary

Graphics issues on Yosemite

Question

I am on gtx 650 and amd fx 8350. I did a clean install and i can't boot without nv_disable=1 . I installed the nvidia web driver but no help :( . I think its an nvda(openGL):exception error

Please help

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

I am on gtx 650 and amd fx 8350. I did a clean install and i can't boot without nv_disable=1 . I installed the nvidia web driver but no help :( . I think its an nvda(openGL):exception error

Please help

what is your bootflags? i think the simple way is like this:

for first boot (you install outside Chameleon screen)

 

        /amdfx GraphicsEnabler=Yes PCIRootUID=0 -v npci=0x3000

 

after reboot you login to boot inside Chameleon screen (if you using Gigabyte mobo you must use PCIRootUID=1)

 

        -amdfx GraphicsEnabler=Yes PCIRootUID=0 -v npci=0x3000

 

remember to download Chameleon Wizard  and install it with latest update after installing Yosemite

run Chameleon Wizard and klik org.Chameleon.Boot

and check an option like boot-flags you use before and Save

Now you can start your Yosemite only with hit Enter... ^_^

Share this post


Link to post
Share on other sites
  • 0

what is your bootflags? i think the simple way is like this:

for first boot (you install outside Chameleon screen)

 

        /amdfx GraphicsEnabler=Yes or No PCIRootUID=1 -v npci=0x2000

 

after reboot you login to boot inside Chameleon screen

 

        -amdfx GraphicsEnabler=Yes or No PCIRootUID=1 -v npci=0x2000

 

remember to download Chameleon Wizard  and install it with latest update after installing Yosemite

run Chameleon Wizard and klik org.Chameleon.Boot

and check an option like boot-flags you use before and Save

Now you can start your Yosemite only with hit Enter... ^_^

Share this post


Link to post
Share on other sites
  • 0

Already tried it, nothing :( nv_disable=1 makes my.computer very laggy but it only works that way, i think i need a driver that works perfectly with my gpu gtx 650

What is you motherboard? If you use Gigabyte i think this boot-flags will work :

 

   -amdfx GraphicsEnabler=Yes PCIRootUID=1 -v npci=0x3000

 

If your not using Gigabyte, it should be like this

 

   -amdfx GraphicsEnabler=Yes PCIRootUID=0 -v npci=0x3000

Share this post


Link to post
Share on other sites
  • 0

What is you motherboard? If you use Gigabyte i think this boot-flags will work :

 

   -amdfx GraphicsEnabler=Yes PCIRootUID=1 -v npci=0x3000

 

If your not using Gigabyte, it should be like this

 

   -amdfx GraphicsEnabler=Yes PCIRootUID=0 -v npci=0x3000

Asus m5a97 Le r2.0

Will try that later

Share this post


Link to post
Share on other sites
  • 0

Well, I think the problem is with your BIOS setting.

Use this to set up your BIOS

  • To access BIOS/UEFI Setup, press and hold Delete on a USB Keyboard while the system is booting up
  • Load Optimized Defaults
  • If your CPU supports VT-d, disable it
  • If your system has CFG-Lock, disable it
  • If your system has Secure Boot Mode, disable it
  • Set OS Type to Other OS
  • Save and exit.

Hope it will help.

Share this post


Link to post
Share on other sites
  • 0

Well, I think the problem is with your BIOS setting.

Use this to set up your BIOS

  • To access BIOS/UEFI Setup, press and hold Delete on a USB Keyboard while the system is booting up
  • Load Optimized Defaults
  • If your CPU supports VT-d, disable it
  • If your system has CFG-Lock, disable it
  • If your system has Secure Boot Mode, disable it
  • Set OS Type to Other OS
  • Save and exit.

Hope it will help.

does not work

Share this post


Link to post
Share on other sites
  • 0

Already tried it, nothing :( nv_disable=1 makes my.computer very laggy but it only works that way, i think i need a driver that works perfectly with my gpu gtx 650

if it work but your computer is laggy, i agree you must try to install the kext for gtx 650. try this link: http://www.insanelymac.com/forum/topic/290941-nvidia-geforce-gtx-650ti-on-1084-hackintosh/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $80.78 of $100.00 goal reached.
    Donate Now
×