Memory Allocation Error! - Hackintosh Mavericks - Hackintosh Zone Jump to content
  • 0

Memory Allocation Error!


hy everybody, hope you can all help me with this one!

so, I managed to install niresh on an amdfx machine, but i get this message everytyme i try to boot without GraphicsEnabler=No -x

memory allocation error! addr: 0xdeadbeef, size: 0x0, file: ati.c, Line: 1772 this is a non recoverable error! System halted!!!


what should i do? I don't know how to fix this!
thank you all!

Share this post

Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I have and


AMD-FX 4100 3,6ghz

4gb Ram

ATI Radeon hd 7700


anyhow I solved!

I managed to make it work by booting the pc with "KernelCache"=/amdfx GraphicsEnabler=Nosystem is stable, it recognize the 1gb of video ram and everything runs smooth :)

Share this post

Link to post
Share on other sites
  • 0

Hey Man,

I am getting the exactly same error with HD7850 and I am getting the screen resolution of only 1024x768

Share this post

Link to post
Share on other sites
  • 0

Leave it

I got it working ..

Deleted all ati/amd kexts and installed them agiain from Bakup and then installed the 2 kexts for AMD graphics provided in this website and rebooted and had the graphics working great

Share this post

Link to post
Share on other sites
  • 0

Hi.. i know its a few months later but this is the only relivent post i can find on the net.


basicly i have the same error.


my graphics card is a 

MSI Radeon HD 7770 

now, i would of taken my card out of my system and booted mac up to remove the files that one of you mentioned.

only i cant because my onboard graphics dont work because i dont have the required processor to do so.


so i think that only leaves me taking my drive out of my system, putting it into a caddy and removing them on another system.

only problem is, i can't do this as all my systems in my house are WINDOWS.


when i installed the mac os, i choose the 

Mac OS extended (JournaledFormat.

so obviously windows cant see this encryption.

i have tried several software to get around this problem, but none seem to work.


so before i go out and buy a brand new graphics card, i need to know is this definitely the problem ??



ps. i am a complete noob to apples mac os for now



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals


    Please donate to support the community.
    We appreciate all donations!

    $80.78 of $100.00 goal reached.
    Donate Now