How I installed OS X Yosemite 10.10 [AMD CPU] - Installation guides - Hackintosh Zone How I installed OS X Yosemite 10.10 [AMD CPU] Jump to content
  • 1

How I installed OS X Yosemite 10.10 [AMD CPU]


System Specs:

CPU: AMD FX-8350 (8 cores@4.2Ghz each)

Graphics Card: 2 x nVidia GTX 770

Motherboard: Sabertooth 990FX


My Guide for getting my system working with Yosemite 10.10


Ok, so it took me approximately 2 weeks start to finish to figure out what a hackintosh was, get something running, and then finally get to the working product at the end. If you have an AMD processor(cpu), then Multibeast/Unibeast will not work for you because they don't support it, so you will have to use Niresh's version. Also, if you are using an AMD processor, you have to use Chameleon bootloader in the installation.


Ok, so here are the steps in how I did it with my system (including all the tricks I had to do that still make no sense):


Prerequisites: 1)Have 2 partitions available, both 20 Gigs or more. 2)Have a working Mac OS X machine to make your USB stick. 3)Have a 8+ Gig USB stick (or maybe a 8 GB Dual Layer Disk, which you can buy online)


Step 1: You must be using a Mac/Hackintosh running OS X in order to run these. Download the "Restore" from Niresh's Yosemite Download page(you must be logged in), and also download the "Yosemite DMG", which you can use Utorrent or another torrent downloader to download the actual file you want. *Make sure both both of the files downloaded are in the same directory! This is very important!(keep them in Downloads probably)*


Step 2: Make sure you have your 8+ Gb USB in the computer, and that it is formatted as Mac OS X Extended (Journaled), if not, use the Disk Utility to do so.


Step 3: unzip the "Restore", and run it. (must be in same directory as the .dmg file)


Step 4: Select the usb you are going to install the image on(the formatted one) with "change install location", and continue through the installation. The Install took me about 20-30 minutes to complete, but *make sure your computer doesn't go to sleep in that time, especially if it's a hackintosh!*


Step 5: The image is now installed properly on your usb, if not then your files may not have been in the same directory. If it doesn't work the second time around then you should post in the forums about it. If installed correctly, restart your computer.


Step 6: Enter in BIOS, and make sure that you follow Niresh's BIOS section in his Yosemite Guide. Select your USB in the boot device menu, and you should be at a black screen with words and a prompt for you to type things.


Step 7: Now comes the part with the boot flags. These flags are what the installer is going to use to make the software work with your hardware. I went through about 20 different combinations of boot flags and installations to try to get things working right, but the one that worked for my install was "/amd64 -v cpus=1 npci=0x2000", but you may have to try others for your system. Check the guides in the forum.


Step 8: Once you get to the installation screen, you will have to go to Disk Utility at the top of the menu, and format both the partitions you made using the "Erase" tab, selecting "Mac OS X Extended (Journaled)", giving your partitions a name like "OSX Yosemite" or "Mac OSX Yosemite", and hitting the Erase button.


Special Note: Now you will arrive at the Hard Drive selection screen, and this is where things got weird for me. I'm going to skip ahead a little bit, but the hard drive I selected the first time was not the hard drive that the operating system was installed on. I selected the hard drive, under the "customize" screen I selected the boot flags I had used to get to the installer, cpus=1 and npci=0x2000, and then went through with the installation. It failed, and so I restarted and tried different things different times and got different errors at the end of the failed installation. *When your install fails the first time, on your second installation, select and install on the other partition you made! The first failed installation will be on the last partition you tried, and will be called disk2s or something like that, don't reformat that partition!* This worked for me 4 times totat, 3 times while installing OS X Maverick, and the 4th while Installing Yosemite.


Step 9: At the end of the installation it will say installation complete and will start a countdown until an automatic restart. Once the computer restarts, go back into your BIOS and select the usb again. Instead of selecting the OSX Yosemite at the top, select the new one further down the list, and hit enter, no boot flags are necessary for this part.


Step 10: Go through the install, you can skip the internet setup part by saying that your computer won't use internet(Niresh has an all in one ethernet fix you can transfer over with usb), and once your setup is complete you can access the operating system with the same usb at startup.


Closing note: I may(probably will) come back and edit this guide to make it more complete and easier to understand for those who need it. This process took me a couple weeks to fully understand the process, and it is all completely trial and error, along with a ton of Google(or Duck Duck Go) searches and searches on


Huge thanks to Niresh for him being so awesome, and providing this community with such a great tool. Good luck to all who are doing this, and don't give up!!!!

  • Like 3

Share this post

Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 2

Yours was the most helpful guide.  After so many failed attempts, using your guide, I was able to install Yosemite 10.10.1 and everything is working beautifully, except of course that elusive iCloud and Facetime fix.  I have FX8350 and Sabertooth 990FX r2.0.  Thank you very very much!

Share this post

Link to post
Share on other sites
  • 0

To my great surprise I've managed to install Yosemite by Niresh on my AMD machine (with /amd64 npci=0x3000 boot flags). After that I've installed Nvidia Web Driver and boot with nvda_drv=1. Everything works fine, but I do have some very weird transparent fonts lag and when I tryied to make a PrintScreen I got this weird pinky picture (the picture itself (as I see it) is fine)


How can I fix that? Thanks )


AMD Phenom II X4 955

12GB DDR3 (3x4GB)


Yosemite 10.10.1 by Niresh


Share this post

Link to post
Share on other sites
  • 0

I have amd fx-9370 and asus sabertooth 990fx r2.0 i was curious, you said after installation to choose usb again and choose the installed partition to boot but without any flags or kernel fixes first for your amd cpu? i seam to get kernel panic because it says kernel_mount failed (2) from my usb device. first off why is it necessary to use the usb installer to boot the complete installation? I also have to use npci=0x3000 because of my sabertooth motherboard, correct if i'm wrong or what I am doing wrong. this was all on my own installation method, didnt use flag npci=0x2000 and was using a partition formatted as mac osx extended not journaled  because i could't format it to be journaled with bootdisk utility cause my windows partition was on same hdd. Also was booting chameleon off the installed partition not usb when i was booting back into OSX. Dont know if these differences could of made a difference, but now am going to follow what you did exactly and on a fresh new hdd formatted through disk utility. Then see how to use my gtx 960 with web driver. Ill keep you guys updated. 

Share this post

Link to post
Share on other sites
  • 0

I wish I could say your method worked perfectly, because I'm very frustrated, and you have nearly the exact same system as I do. I'm on a Sabertooth 990FX R2.0 with an AMD FX-8350 CPU. You mentioned that I have to use Chameleon, but when I run Niresh's "Restore Yosemite" it automatically puts clover on my boot loader. So I tried to use it, hoping that it was actually chameleon, but it won't even get past the boot loader and restarts the computer. I've tried every possible boot flag option, to no avail. The only thing I can think is that its running clover and not chameleon, but I never had an option for chameleon, it automatically put clover on. So... I'm stuck again... and feeling like a failure.


Help Please... 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting May 2018

    Please donate to support the community.
    We appreciate all donations!


    $148.22 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By ka209

    120    0