Radeon mobility HD5430 - Hackintosh Yosemite - Hackintosh Zone Jump to content
tsunamy35

Radeon mobility HD5430

Recommended Posts

Hi,

 

First, i'm sorry if i do mistake! I'm french and so i don't speak english very well.

 

I've got a laptop HP G72-150EF

Intel core i3 330M

ATI Radeon mobility HD5430

SSD 80GB

6gb RAM

Yosemite 10.10.1 with clover boot loader 

 

My problem is with my graphic card. I know i've got an intel core I3 first generation with intel HD graphics but i'm sure HP has deactivate this card in BIOS. So my hackintosh see only my Radeon Mobility card.

 

I've find kexts for have a native resolution (1600*900), but in "about this mac" my graphic card is only 5MB.

So i'm not on full QE/CI.

 

Anyone can help me please?

 

Thanks a lot and sorry again for all mistakes.

Share this post


Link to post
Share on other sites

Same. I have the same graphic card as your but my laptop is different. I had no problem in mountain lion and mavericks by just editing the kext as well as using forcededid but in yosemite is a different story. I hope Niresh could chimp in and help us both.Mine is a:

Compaq CQ42

Intel i3-350M (2.26G, 3MB L3 Cache)

Intel HM55 chipset

ATI Mobility Radeon™ HD 5430 Graphics (512MB GDDR3 discrete memory)

Audio: ALC270

Wifi: RTL8191SE

LAN: RTL8102/8103

Share this post


Link to post
Share on other sites

With Mavericks you have a Full QE/CI with ATI Radeon mobility HD5430?

 

If i install mavericks can you help me for configure my laptop correctly for graphic card please?

  • Like 1

Share this post


Link to post
Share on other sites

With Mavericks you have a Full QE/CI with ATI Radeon mobility HD5430?

 

If i install mavericks can you help me for configure my laptop correctly for graphic card please?

Bonjour, i have success with the card in yosemite. I just figure it out. Its quite a long step, I typed by myself entirely, i hope I'm not too naggy :) I hope this will be a christmas present from me to you :) Merry christmas. But first thing first, you must have clover boot loader instead of chameleon or chimera. I had success using clover boot loader:

1. If you do not know how to install clover, follow this the setting i found somewhere. I have attached it at the bottom of this post. After installing clover don't restart, Then you need to download clover configurator. open it, mount your efi partition it will show enter your password, enter it, once done, click open efi partition. Then you are in clover configurator, on the top, click file>import configuration>config.plist. if it does not show the config.plist then you click efi(at the left hand side)>clover>config.plist. Because both of us is a hp laptop, and for some reasons we will get kernel panic if we don't have the cpus=1 kernel flag in the boot loader, so u need to go to Kernel and Kext Patches, and click the Kernel Lapic.After this go to file, export configurations as and save. (Don't change the name or so, just save).

2. First follow this guide for the laptop display to have fixed the scrambled, stretched and wrong resolution. For this we called it forcededid : http://www.insanelymac.com/forum/topic/208410-fixing-scrambledstretched-or-wrong-resolution-laptop-display-problems/ 

3. Are you able to boot into windows or so? If yes, go to Windows->DeviceManger->VideoCard.properties->compatibleIDs. In my case my compaq cq42 id was 0x68E11002.

4. After finding your device id, i need you to boot to OS X where you will need to use the terminal and type this: cp /System/Library/Extensions/AMDRadeonX3000.kext/Contents/Info.plist ~/Desktop . After typing that, you may discover that your desktop have a file called info.plist, i need you to open this using textedit, click find cedar, then under cedar there will be IOPCIMatch and as you can see there is a device id 0x68E01002. Simply replace that with the device id you found in windows. After replace, simply save it using the same plist extensions not txt extensions. After saving type this in terminal: sudo cp ~/Desktop/Info.plist /System/Library/Extensions/AMDRadeonX3000.kext/Contentsafter that, sudo rm -r -v /System/Library/Caches/com.apple.kext.caches/* Restart after you have done with this.

5. Go to system/library/extensions, look for the kext called AMD5000Controller.kext, right click show package contents, click in contents, and open the info.plist using textedit. Look for IOPCIMatch, there are a lot of device id, carefully look at those and see is there a device id that is the same as yours, if same then you do not need to change anything. Else, change one that is similar to yours.

6. Go to clover configurator that you have downloaded just now again, mount your efi partition it will show enter your password, enter it, once done, click open efi partition. Then you are in clover configurator, on the top, click file>import configuration>config.plist. if it does not show the config.plist then you click efi>clover>config.plist. Once you imported the config.plist, you go to Graphics, click on the injectati, injectedid, loadvbios. Then in the FBName, you typed in Langur. After this go to file, export configurations as and save. (Don't change the name or so, just save). Reboot and voila! You have QE/CI! 

*Also* If you want, i can upload my files, I'm not sure will it be the same a not for the displayproductid-717 as well as the device id but if you want you may give it a shot. :)

post-14507-0-63190400-1419428970_thumb.j

Share this post


Link to post
Share on other sites

Sorry i can't test this before.

First,

Tanks you very very much for all this time.

Second, do you speak french?

If yes it will be easiest lol

If no, can you help me step by step because i don't understund all your tuto.

Thanks

Share this post


Link to post
Share on other sites

Finally, i spend a lot of time but i understand all your tutorial.

 

But i've gt the same problem. Resolution stay 1024*768 and 3mb vram.

 

I try to install a fully functional hackintosh on my hp g72-50ef still 1 year and i dont want to stop now just because my graphics card don't want to be ok.

 

Please please please please please please help me  :rolleyes:  :rolleyes:

Share this post


Link to post
Share on other sites

Hi,

 

Wouahh i work hard for have a good hackintosh!!!

 

so, when i boot with my laptop's screen i've got  black screen,

 

I have put an HDMI cable my laptop and on an external screen!

 

Miracle, no black screen at boot but.... grrrrr but.... screen is very strange:

 

18205_IMG_0450.jpg

 

No, no it's not a bug of the forum lol :D  :D , i have this screen when i boot with n external screen. 

 

i have try to do a capture of the "screen" (not very clear so it was difficult to view correctly what i was doing)

 

57973_Sans_titre.png

 

and

 

88836_Sans_titre1.png

 

so, we can see on the first screenshot, my graphic card has 512mo ram (nice), don't look name of the graphic card, it's in my clover's config plist. on the second screenshot, we can see that i've got a native resolution (1600*900)

 

So, my graphic card is partial operational with an external screen (resolution and ram ok but "scramble")

 

can anyone help me to have a good splay on my laptop's screen please?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $49.70 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • @Niresh Thank you for making hackintosh installation easy and simple. I almost gave up with the other procedures. Glad I stumbled here. First try and it worked right away. You are the greatest. I installed also your high sierra zone and same, first attemp installing and it works right away. Just my nvidia gt730 ddr3 is not working due to lack of driver support.      
    • @CaelThunderwing  Your i5 6th generation can run Sierra & High Sierra Im not sure about the AMD CPUs but High Sierra is pretty good capable of running them (Im not an AMD Expert), but all your CPUs must support SSE4.1 instruction set to run Sierra or High Sierra, otherwise you will end up with a kernel panic. If you have dual graphics cards or chipset in same machine, try Sierra instead of High Sierra. High Sierra for Intel & High Sierra for AMD are separate releases.  but you can try the AMD version with Intel machines. Properly setup BIOS before booting your Hackintosh You have to boot from these and post picture of your problem, without a problem i can't debug
    • @X-troyer You are booting Yosemite Zone in Graphics Mode, You have to boot it in verbose mode to see what is the issue to boot in verbose mode, you have to type -v and press enter in Chameleon boot menu ( In Volume Selection Menu ) Then post a picture
    • Laptop acer v7 582pg, i54200u, 8gb ram, ssd 256gb, nvidia card Steps I have followed: +Create a bootable usb with transmac (windows), and restor niresh high sierra image. +bios: access to advanced bios ( in acer laptops pres fn+tab in bios to unlock menus )
      disable vt-d
      disable secure boot
      disable serial port
      set to uefi   Attempt 1 (uefi bios): +Clover boots from usb -it gets stuck as soon as I run high hackingtosh zone disk, the only info in the screen is ++++++++++++++++++++++++++++ I tried the following flags : -x nv_disable=Yes maxmem=4096 npci=0x3000   Attempt 2 (legacy bios): +boot to high sierra zone installer +erase disk -installation fails when it reaches the end ( error 0 )   Attempt 3 (legacy bios): +boot with flags -x npci=0x3000 ( this flags worked with yosemite zone ) -installation fails when it reaches the end ( error 0 ) -I remove the usb and restart the computer. Clover loads, i try to run from hdd but gets stuch inmediatly showing ++++++++++++++++++++++++++++   Any help would be much apreciated ( please consider I am a newbie, although I read the guides and I've been tinkering for a while I really dont understand what is happening under the hood )
  • Download Statistics

    • Files
      845
    • Comments
      2,132
    • Reviews
      2,556

    Latest File
    By 8osm3rka

    24    0

×