How can I update to 10.10.1 without losing data - Hackintosh Yosemite - Hackintosh Zone Jump to content
abangala23

How can I update to 10.10.1 without losing data

Recommended Posts

Well I heard about the new 10.10.1 update and its bug fixes but I looked everywhere and it doesn't say how to update correctly from 10.10 to 10.10.1 without losing nothing (Losing data, settings and apps). What method should I use since last time I tried to update using the distro installer, I lost all and it reinstalled using the latest version.

Share this post


Link to post
Share on other sites

I have never lost data while updating, but i have lost kexts in the S/L/E folder, but the solution to that is just to install the necessary kexts after installing the update, another solution is to use and EFI partition for the boot loader and necessary kexts (look it up in google) but this may possibly leave out kexts for the Audio. Buy to be sure then OS X has a wonderful backup software the Time Machine that is very easy to use and I urge all to use TM for security sake.

Share this post


Link to post
Share on other sites

Well is it ok if I reinstall the kexts using EasyBeast since I have a Core 2 processor on my laptop? Other then that, I always boot with -v no other settings that I can lose.

Share this post


Link to post
Share on other sites

The update is not processor sensitive, if you have been running OS X before then you only have to install the update. Only if you install a complete setup of the operating system and erase/format (clean install) the partition of the hard drive with the operating system will erase the content and files you have in that partition.

 

If you have a working OS X installed then it is in (almost all cases) easy to upgrade to newer version of OS X simply by installing over the existing install and preserve all software and data, but remember to have a backup of all data for security.

 

-v boot flag has no practical meaning other than watching the loading of the operation system and enable identification of possible problems while booting so if all is in good shape then you can leave out the -v boot flag.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $48.99 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • ya no documentation ..and iam so confused to ..can some one make tutorial
    • Desktop Specs 
      Mob-: MSI X99a Godlike Gaming (MS-7883) (supports Legacy+UEFI)
      CPU- Intel 5820k (Haswell E)
      Graphics- MSI 980ti
      Ram- Avexir ddr4 8x4gb also, i have attempted using: OsxAptioFix2Drv-free2000.efi At the moment i typically get stalled with: Only single RAM bank (128 bytes) and some times I am getting: Couldn't allocate runtime area.
      Any advice would be greatly appreciated as im scratching my head wondering what the problem is - currently going to reformat the usb and start a new.
    • getting error (iobluetoothhcicontroller) (searchfortransporteventtimeouthandler) (missing bluetooth controler) apple loading bar stuck in middle if i boot normally. So i tried these  boot flags npci=0x2000 -v npci=0x3000 -v  -x-v PCIRootUID=1 -v PCIRootUID=0 -v still same error ?? Stuck in loading bar any solution?? thanks Acer Aspire 5733 (pew71) 

      Core i5 m560 @ 2.67 Ghz
      Intel HD Graphics
      Atheros AR5B125 Wifi
      Broadcom Net Link
      Realtek HD Audio
    •   I have a notebook with an integrated inter 510 graphic card and an nvidia geforce 920MX graphic. The problem is that the intel only takes me 3 Mb and the nvidia directly does not let me. I do not know if there is kext for both or how to fix it. Thanks in advance
    • Hi Guys, I’m stuck with 3mb VRAM, and can’t get my screen resolution! I’ve tried to reinstall 18 times with different configurations but I can’t seem to get it right! PLEEEEASE HELP I really don’t know what to do now. I've tried Enoch but still no success!   MY COMPUTER SPEC: System Model: HP EliteBook 8570p Processor: i7-3520M CPU @ 2.90GHz, 2901 Mhz, 2 Cores GPU:  AMD Radeon HD 7570M RAM: 12GB  

  • Download Statistics

    • Files
      848
    • Comments
      2,135
    • Reviews
      2,568

    Latest File
    By Vale1831

    1    0

×