Bootloader help please... must use USB stick boot loader to boot. - Hackintosh Yosemite - Hackintosh Zone Jump to content
Sign in to follow this  

Bootloader help please... must use USB stick boot loader to boot.

Recommended Posts

I've got an old Dell Inspiron 1525 laptop. I installed Yosemite 10.10 via Yosemite Zone onto an AMD Gigabyte GA-MA785GM-US2H Rev.1.3 w/Phenom X4 CPU. This install was problematic, I didn't get much working yet, no WIFI (have Netgear WN3111B 802.11n Broadcom WIFI), no sound, no boot from HD boot loader, only USB Yosemite Zone boot loader. This was updated to 10.10.1, but it's a difficult situation.


I cloned this problematic AMD desktop installation onto a laptop internal HD and changed the kernel, DSDT.aml, SMBIOS.plist, and a few other minor things, and attempted to boot this installed Yosemite System on the old Dell Inspiron 1525 laptop w/Intel x3100 graphics. To my great surprise, it booted fine. I found a download for some 64-bit kexts for the old Intel x3100 graphics, which I assumed would never work or give acceleration, and during the verbose startup dialog, I always see the x3100 driver panic, but somehow it later seems to reload, and is shown loaded by kextstat, and better yet, every test I've done seems to indicate I have full graphics acceleration on an old x3100 under 10.10.1 which seems unbelievable and incredible to me. Before these 64-bit kexts the x3100 only recognized as 4mb, and there was no acceleration. Now it's perfect recognized at 144mb, with full acceleration seemingly.


AFAIK everything seems to work on this Inspiron 1525 with the exception of iMessage. The trackpad is slightly fidgety, but works. Sound is a little low volume, but not too quiet. Everything just works, probably the best of any version of OS X I've installed on this laptop, including 10.6.8, 10.7.5, and 10.8.5. I assumed 10.8.5 was "the end" because I used MLPostFactor for the 32-bit compatible x3100 acceleration, and assumed I'd NEVER see a working 64-bit driver for the x3100 under either Mavericks 10.9 or Yosemite 10.10. I am amazed.


PROBLEM: can't get a HD-installed boot loader to work. I've tried several combinations. Right now I've got one HD formatted MBR w/ Chameleon from Yosemite Zone 10.10 USB installer. This will load the Chameleon boot loader graphically, but the boot never completes, it stalls hard after the verbose leaves but before the desktop screen appears. If I use the Chameleon textual on the Yosemite Zone USB installer, which always shows as a textual rather than graphical, it will always boot fine without any problems or errors. The same Chameleon version from the HD stalls every time.


I've also got an identically cloned GUID HD with Clover installed. Almost same problem, only Clover never even loads, the HD is completely invisible to the laptop unless booted from the Yosemite Zone 10.10 USB stick w/Chameleon textual. Only then the HD is recognized, and will boot normally. Perhaps I need MBR w/Clover?


So the problem is: I can clone this WORKING System onto ANY HD, and I can format the drive any way (MBR or GUID), and I can install any boot loader (Chameleon Standard, Chameleon EFI, Clover Standard, Clover EFI), but I NEED to be able to boot without using the boot loader from the USB stick. What format should I use for the HD (MBR or GUID)? What boot loader, I'm leaning toward Clover because I want to fix the iMessages, and supposedly there's a Clover based fix for the iMessages login validation issue (yes, my board & serial match w/ real Mac serial). I've never used Clover, only Chameleon, but I need some working boot loader ASAP. Help would be appreciated...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!

    $62.51 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hello! I made my usb key with transmac but when I start OS X Sierra everything goes well, the installation too but the installation blocks at 100%, time remaining: less than a minute. with it worked but not anymore. can you help me? My PC : it is a laptop: ASUS X751LD the motherboard I do not know, the hard drive I do not know but it's a HDD of 500 gb I have two graphics cards: Intel HD 4400 and Nvidia 820m, (which blocked me for the installation of Yosemite and High Sierra) thank you in advance.   PS : Sorry for my bad english i'm french ^^.
    • Hello! Yesterday I successfully installed Yosemite (Yosemite Zone distro) on my laptop (Sony Vaio FIT 15E with an i3-3217U). The only thing that doesn't work is the wifi card (BCM43142). I found in my house another wireless card, AzureWave AW-NB047H. Is this wireless card compatible with macOS?   Sorry for my bad english and thanks in advance. ~IOStream
    • i have installed sierra on my acer aspire e14 e5 - 475G 59C7 with processor i5-7200u 2.5GHZ  nvidia geforce 940MXX 2GB  4GB DDR4  when i install i disabled "move nvidia.pkg" "ati.pkg" "intel.pkg" installed works, but when i type something it gone too far. for example i just type "a" in 0.5 seconds it shows "aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa" anyone know how to fix this?        
    • Hello,
      On High Sierra 10.13.1 under VMWare.
      I install Final Cut Pro 10.4 when running got this error:
      This graphics configuration does not support hardware acceleration, which is required to run Final Cut Pro.
      My GPU is: AMD Radeon R7 240 but show on Hachintosh About : Graphics: Display 128 MB. Thank you for help.
    • I got same error 4 years later. On High Sierra. What's the solution? What you suggested doesn't work. Why does this happen? Any ideas?
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By Vale1831

    15    0