Are imessage and icloud working? - Hackintosh Yosemite - Hackintosh Zone Jump to content
Sign in to follow this  
David Maša

Are imessage and icloud working?

Recommended Posts

yes it works, but with a fix that should have been included in your installation, incase this has not installed than you can find the fix in another post here in this forum, but you need to find out where to put the files that correct or enable Appstore, iMessages. 

 

You also need to have a valid serial number of the "fake" mac/hackintosh.

Share this post


Link to post
Share on other sites

I have now 10.10.1, appstore is working, i also installed all the fixess for that ) for example ethernet builtin, nvram, rename ethernet to en0..) Can I get somewhere valid serial number if I dont have original mac? 

When I had maverick, it was working. 

EDIT - oh, so I can just copz that from any mac serial on internet. I will try

 

EDIT2 - No. It's not working. I used valid serial from another mac pro, but it's not working. Can you help me somehow? 

Share this post


Link to post
Share on other sites

Edit, since the Appstore, iMessage is not working even using the Smbios.plist from the old installation, then the "Fix" is not fully applied or something else is wrong. If yo have downloaded the "fix files" (a link is in other thread here in this site) then you just copy the files to the following directories you will see which files go in each directory. 

 

The directories are /System/LibraryFrameworks and /System/Library/StagedFrameworks/Safari.

 

It is easy to get a valid serial number for the hackintosh pc, if you had a Smbios.plist in the old installation from Maverics, then you could have used that one, but if you don't have that one, then you can generate a new one with valid serial number with for instance the "Chameleon vizard" with Chameleon Vizard you can choose what mac computer your hackintosh should imply it is, "most often" it is best to chose mac model similar in specs to your hackintosh but the Mac Pro definition in Smbios.plist (Smbios.plist is in directory /Extra) most often works for most desktop systems but in some cases iMac definition gives somewhat better performance, and for laptops choose similar specced Macbook (Air,Pro) and for desktop using only graphics in the CPU then Mac Mini is most often similar, but this is a trial and error testing to find out what is best for each system.

Share this post


Link to post
Share on other sites

Thanks for fast reply. I tried both of them. I tried adding verified serial and random serial from chameleon wizzard. (I tried macpro 3,1 and iMac) But still nothing. No, I don´t have smbios from the old instalation.

BTW, I know, that I have to choose similiar system as macpro 3,1 or something like that. but I have AMD. So what do you prefer?

 

PROCESSOR: AMD Fx-8120, 8 CPUs -3.1Ghz
RAM- zeppelin 1333MHz, 8GB
MOTHERBOARD: ga-990-fxa-d3
GRAPHICS: nVidia geforce gtx 750 Ti 2 GB

Share this post


Link to post
Share on other sites

Hello SanduQi.

You should have a sound system, at least you have the serial OK. But as you know the serial is not all it takes to get the Appstore and the other Apple connections working.

The net fix worked for me, i.e. I had to place the files in their correct places my self (replace the originals) I downloaded the files from another thread in this web site and after that (note I had upgraded to 10.10.1 from Apple).

 

There might be one another possibility, although I am not sure but that is to place the file FileNVRAM.dylib in /Extra/modules, you should be able to google and download this file and try it out. In previous versions of OS X this worked to enable iMessages. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $40.92 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • @Niresh i forgot to say that that error was given because i have a Samsung M2 NVMe 960pro. I tried to remove it and it kinda worked but with a lot of bugs even during the installation. I can't remember everything clearly now cause it's been like 4 months ago
    • Thanks. I Have One Ethernet And One Wifi. Here Is The Terminal Log :  iMac:~ marcus$ lspci -nn 00:00.0 Class [0600]: Device [8086:190f] (rev 07) 00:01.0 Class [0604]: Device [8086:1901] (rev 07) 00:08.0 Class [0880]: Device [8086:1911] 00:14.0 Class [0c03]: Device [8086:a12f] (rev 31) 00:14.2 Class [1180]: Device [8086:a131] (rev 31) 00:16.0 Class [0780]: Device [8086:a13a] (rev 31) 00:17.0 Class [0106]: Device [8086:a102] (rev 31) 00:1c.0 Class [0604]: Device [8086:a110] (rev f1) 00:1c.2 Class [0604]: Device [8086:a112] (rev f1) 00:1d.0 Class [0604]: Device [8086:a118] (rev f1) 00:1d.2 Class [0604]: Device [8086:a11a] (rev f1) 00:1d.3 Class [0604]: Device [8086:a11b] (rev f1) 00:1f.0 Class [0601]: Device [8086:a145] (rev 31) 00:1f.2 Class [0580]: Device [8086:a121] (rev 31) 00:1f.3 Class [0403]: Device [8086:a170] (rev 31) 00:1f.4 Class [0c05]: Device [8086:a123] (rev 31) 01:00.0 Class [0300]: Device [10de:1c82] (rev a1) 01:00.1 Class [0403]: Device [10de:0fb9] (rev a1) 03:00.0 Class [0c03]: Device [1b21:1242] 05:00.0 Class [0604]: Device [1b21:1080] (rev 03) 07:00.0 Class [0200]: Device [10ec:8168] (rev 15)
    • How many network adapters do you have? Like WiFi or Ethernet? Post output of lspci -nn command
    • Unfortunately i dont have any Option to disable my Grahpic Adapter. Can i disable it in an other way? Like any Boot Flags?   EDIT: I did just an Update for my BIOS but it didn't add any Options to disable my Graphics Adapter
    • This issue is called Discrete Graphics issue of High Sierra, To bypass this you have to disable either Intel HD Graphics 630 or Nvidia GeForce GTX 1060 from BIOS, Check into your BIOS to see if you have any options to disable Graphics, Then try booting Keep me updated
  • Download Statistics

    • Files
      845
    • Comments
      2,130
    • Reviews
      2,555

    Latest File
    By 8osm3rka

    21    0

×