Installation Issues With AMD - Hackintosh Yosemite - Hackintosh Zone Jump to content

Recommended Posts

I tried to install Yosemite 10.10, the first release by Hackintosh Zone for AMD processors, and had no success as I was always stuck between the boot and login screen, the only way i would make it past was in safe mode which is almost useless.

Has anyone had any success on an FX-8xxx Series CPU with the latest version of Yosemite-Zone (10.10.1). If so, what boot-flags do you use? 

 

My build:
CPU: AMD FX-8320, 3.5ghz

Ram: 10Gb DDR3
Graphics: Sapphire Radeon HD 7770 1GB
MoBo: ASRock 990FX Extreme3 AM3+

Share this post


Link to post
Share on other sites

Hi,

 

i use for install boot flag /amd npci=0x2000 with Amd FX 8350.

In the Volume Selection menu Select the Volume and select Customize 

then select the npci=0x2000 for bootloader.

Try GraphicsEnabler=No for your video card.

  • Like 1

Share this post


Link to post
Share on other sites

tell me how many stable build ? 10.10.1 ?
 

10.10 I put everything works fine , safari and all the software . Nebylo problems with graphics commands after msibase = 0x90? It loads quickly on my SSD.
But do not work , many programs such as Russian does yandex.
and the most important thing is not working Steam. He does not give errors , it just does not run , jump and everything.
If you did not understand me , I Posnov . I translate through Google translator . Please test run if you have it .
http://browser.yandex.ru/future/

P:AMD FX8320
M:MSI Global 970A-G46
G:GTX650Ti

Share this post


Link to post
Share on other sites

Well I have an AMD processor myself and I faced many problems with Yosemite!
The solution for me was to choose as the host os "Windows" instead of "Mac".

However notice that if you use VMware, after choosing "Windows" as host os and before running your virtual machine, go to:

 C:UsersYOU_USER_NAMEDocumentsVirtual MachinesYOU_VIRTUAL_MACHINE_NAME 

find the .vmx file, edit it with notepad, find the line: firmware = "efi" and remove it.

Hope it helps!

 

EDIT: The "Windows" selection as host os only work in vmware! In virtualbox select mac 10.9

 

Also see this video:

Share this post


Link to post
Share on other sites

I have installed it on FX4100 with ATI Radeon HD 4350 and it works perfect with following bootflags for installation - /amd64 npci=0x2000 GraphicsEnabler=No USBBusFix=Yes -v

U need to set GraphicsEnabler=No - for Some ATI and Nvidia Gpus Try it .

Share this post


Link to post
Share on other sites

I've tried re-installing with 10.10.1 using /amd /amd1 /amd2 /amd64 all diffrent times using npci=0x2000 and GraphicsEnabler=No 
It installs fine but after the installation it gets hung on a grey screen with the beach ball of death. This is right before the logon screen, but right after it is done booting (when it gets out of verbose mode). 
The only way to be able to use it is with Safe Mode and that is still completely useless.

Share this post


Link to post
Share on other sites

You have to replace kernel, system kext, appleacpi kext and iopcifamily kext and install AMD webkit.
I followed this step:
I went on insanelymac.com
Downloaded kernel BSA_yos_r6b with system kext, 3 post after (Carlo_67 post) kext to replace....
Then logged in in windows (use macdrive to see, manage and move files in HFS partition) replace all kext and kernel.
Reboot and start a new installation, once in installation menu open terminal and type:
Diskutil repairpermissions "name of partition where you installed osx without quotes"
It will rebuild all permissions, it takes 5/10 minutes... Once finished type reboot..
boot in safe mode and install amd webkit.

Boot your osx with -v -f..... Then cross your fingers (i'll also cross mine)...

if it works fine then just add -f (ignore kernel cache)

It worked for me and for many others....

My specs:

Amd fx 8350

Asrock 990 extreme 4

16 gb ram corsair vengeance @ 1600

gtx 660 ti (also tryed with ati sapphire hd7xxx series both works)

 

I can play World of Warcraft with low graphics.... actually really works

 

Edit: also bsa_yos_r7d worked for me

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $48.99 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • hello all, i wonder if somebody did sucssesfuly installed ati drivers on one of polaris gpu on 10.9 10.10. or 10.11 mac? i find yesterday on some russian forum that they did some bios mods on polaris gpus on siera and high siera but i dont understand process. also no luck for kext emulator on phenom 2 cpu for siera and high siera i got rx560 sapphire 2gb and i tryed install mac but on gpu it said 8mb and graphic is awfull. everithing else works exept spdif output for audio and gpu. i cannot install siera or high siera because of unsupported cpu sse4.1 or sse4.2 my specs are asus m5a97 r2 evo phenom II 955 black edition x4 @3.2 g stock ram 3x4gb ddr3 @ 1333 underclocked because of cpu limitations rx560 sapphire 2gb 60gb adata sp900 2x500 gb wd blue (1x 2.5" , 1x 3.5") all your comments are welcome thanks
    • guys please help me .....................im stucked at apple logo while installing im using hp laptop core i5 7200u 6gb ram amd radeon R5 M430
    • I have working audio, graphics and network on this 10.13  Now store has sent me "security update" which I believe is 10.13.3.  Has anyone done this via store? What do I need to do before I install it? I have issues loading EFI so have to always manually mount it (Clover configurator and EFI mounter both fail) but using terminal and command "open /efi" I am able to mount and make changes to my config.plist too.   
    • Hi guys, I try to install Mac OS X Yosemite on my computer, but... i get stuck at the logo (when i boot it) + i see a bar, who won't charge. Can you give me a solution?   Processor: Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz (2 CPUs), ~2.0GHz Memory: 2048MB RAM    User DPI Setting: Using System DPI  System DPI Setting: 96 DPI (100 percent) Display Card name: NVIDIA GeForce 210  Manufacturer: NVIDIA Chip type: GeForce 210 DAC type: Integrated RAMDAC  
    • Just to Add I used My windows machine with TransMac to wipe and build the install (including USB). I only used the clover installer I forgot that it could switch to chameleon.
  • Download Statistics

    • Files
      848
    • Comments
      2,137
    • Reviews
      2,570

    Latest File
    By Vale1831

    13    0

×