:FIX/GUIDE: AMD Stuck At Grey/White Screen With Spinning Beachball :FIX/GUIDE: - OS X Yosemite 10.10 - Hackintosh Zone Jump to content
  • 0
Daniel J Straughair

:FIX/GUIDE: AMD Stuck At Grey/White Screen With Spinning Beachball :FIX/GUIDE:

Question

heres a list all the parts i have

PROCESSOR: AMD 8350 BOX PROCESSOR ------ AMD 8350 TRAY PROCESSOR

MOTHERBOARD: ASUS M5A97 EVO R2.0 ---- GIGABYTE 990FXA-UD3

GRAPHICS CARD: GIGABYTE 2GB ATI HD 7870 ----- 2x 1GB XFX HD 5770

RAM: 24gb CORSAIR VENGENCE 1816MHZ DDR3 ------ 32GB GSKILL ARIES 1600MHZ DDR3


THIS IS NOW SOLVED  :)  :)  :)  :)

first of all thanks everyone ( @Simone Rucci, @Niresh) who helped on this post i couldn't have made this happen without your help this will solve you beach ball spinning infinite grey/white screen crap ok i got this working the procedure is as follows on two different boards

asus m5a97 evo r2.0

gigabyte 990fxa-ud3

and two different graphics cards

gigabyte ati hd 79870 2gb

xfx hd5770

my processor is a amd fx 8350
32gb ddr3 gskill ram

I AM ALSO USING GPT

i can now easily play might and magic x legacy on full graphics settings

ok i used a certain kernel and the stock graphics drivers if you wish to change that it may or may not work

ok procedure you now need to have kext wizard handy

you need to head over to here for the AMD kernel

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=157955

inside that file is the kernel and the system.kext

now you need to go over to here to grab the other two kext IOPCIFamily.kext + AppleACPIPlatform.kext for yosemite

http://www.insanelymac.com/forum/files/file/354-amd-replace-kext-for-yosemite/


you will also need amd webkit patch

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=154087

now i want you to place all kext on the desktop
if you have backed up your graphics drivers during or after the install you should be able to boot with just

npci=0x2000 PCIRootUID=1 -v

if not you will also need to add

-f -x

now once you are at your desktop you need to move the kernel over to System/Library/Kernels
so rename your original kernel to kernel.backup1 then overwrite it with the new one

you will then open up kext wizard and use the install pane to install

system.kext
IOPCIFamily.kext
AppleACPIPlatform.kext
(also if you backed up your graphics drivers nows the time to reinstall them)

then i want you to keep kext wizard open and install the amd webkit patch after installation has finished go back to kext wizard and repair permissions (click both boxes on the bottom half)

then reboot some of you still may have to use -v and -f

i have mine booting with full acceleration
without -f -v

enjoy

 

http://www.vividtech.biz

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
7ENSEI    0

I will be attemping this method right now starting with a FRESH partiton & installation of yosemite 10.10.1 (hackintosh zone dmg).

Just for a heads up because I have a feeling I will be back with more errors (been at this for 2 1/2 days STRAIGHT; attempted EVERY boot flag...with nothing but a grey screen and a death wheel)

My PC specs are:

Processor: AMD FX -6300 3.50GHz

GPU: AMD Sapphire R7 270x 2GB

Board: Gigabyte 970A-UD3P (9 Series)

HDD: 1TB (WIN10) & 250GB (Mac OSX Yosemite 10.10.1; when finished installing)

RAM: 8GB DDR3

BIOS: UEFI DaulBIOS

Audio: Realtek High Def. Audio Ver. 6.0.1.7553

Bootloader: Chameleon (when finished installing yosemite 10.10.1)

Share this post


Link to post
Share on other sites
  • 0
DX6644    0

I have same setup except nvidia gtx650Ti. Is Yosemite running slow, and what kext did you use for sound?

Edited by DX6644

Share this post


Link to post
Share on other sites
  • 0
DX6644    0

heres a list all the parts i have

PROCESSOR: AMD 8350 BOX PROCESSOR ------ AMD 8350 TRAY PROCESSOR

MOTHERBOARD: ASUS M5A97 EVO R2.0 ---- GIGABYTE 990FXA-UD3

GRAPHICS CARD: GIGABYTE 2GB ATI HD 7870 ----- 2x 1GB XFX HD 5770

RAM: 24gb CORSAIR VENGENCE 1816MHZ DDR3 ------ 32GB GSKILL ARIES 1600MHZ DDR3


THIS IS NOW SOLVED  :)  :)  :)  :)

first of all thanks everyone ( @Simone Rucci, @Niresh) who helped on this post i couldn't have made this happen without your help this will solve you beach ball spinning infinite grey/white screen crap ok i got this working the procedure is as follows on two different boards

asus m5a97 evo r2.0

gigabyte 990fxa-ud3

and two different graphics cards

gigabyte ati hd 79870 2gb

xfx hd5770

my processor is a amd fx 8350
32gb ddr3 gskill ram

I AM ALSO USING GPT

i can now easily play might and magic x legacy on full graphics settings

ok i used a certain kernel and the stock graphics drivers if you wish to change that it may or may not work

ok procedure you now need to have kext wizard handy

you need to head over to here for the AMD kernel

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=157955

inside that file is the kernel and the system.kext

now you need to go over to here to grab the other two kext IOPCIFamily.kext + AppleACPIPlatform.kext for yosemite

http://www.insanelymac.com/forum/files/file/354-amd-replace-kext-for-yosemite/


you will also need amd webkit patch

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=154087

now i want you to place all kext on the desktop
if you have backed up your graphics drivers during or after the install you should be able to boot with just

npci=0x2000 PCIRootUID=1 -v

if not you will also need to add

-f -x

now once you are at your desktop you need to move the kernel over to System/Library/Kernels
so rename your original kernel to kernel.backup1 then overwrite it with the new one

you will then open up kext wizard and use the install pane to install

system.kext
IOPCIFamily.kext
AppleACPIPlatform.kext
(also if you backed up your graphics drivers nows the time to reinstall them)

then i want you to keep kext wizard open and install the amd webkit patch after installation has finished go back to kext wizard and repair permissions (click both boxes on the bottom half)

then reboot some of you still may have to use -v and -f

i have mine booting with full acceleration
without -f -v

enjoy

 

http://www.vividtech.biz

Thanks for the post. Got Yosemite working but switched to Mavericks. Now able to run W o D. I have Audio thru front jack only but no mic, still working on it. MB uses Realtek ALC892...  on GA-990FXA-UD3 GTX650T1 AMD FX6300  8GB ram  eth0  DVI -HDMI >46" samsung 1080p

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Hi guys, managed to make a hackintosh and everything is going great (Wifi, cpu ECT)   But it's pretty damn slow, i tried one of my favorite lightweight games to test (The Ultimate Doom) and it could barely run THAT! This is my first time and i have no idea how to get my 8570 to work.. Probably should have read a bit, eh? Lol.   And no I don't plan on using my hackintosh for gaming, but god so slow..   Thanks, help would be very appreciated. Edit: It's the dedicated version btw, and in about my mac I see "Graphics Display 3 MB" maybe the issue?  
    • Trying to boot to the installer but I get instant reboot after the following: I am using the following flag (I tried a variation - I need USBBusFix=Yes otherwise it fails even earlier): All my USB devices turn off just before it reboots, so I'm guessing it loses connection to the USB install media - but I can't work out why it's disabling all the USB's. My motherboard is an AsRock Killer Fatal1ty 990FX.
    • Saludos!   Tengo el mismo error (RAM a 667mhz), con una placa base ASUS (y mi cpu es el fx 6300).   Lograste solucionarlo?
    • Hi guys. Well, this is my second day of troubles, I touched everything, I installed max like 5 times in the same day, trying to figure out things and well. My Mac it display my graphic card on the #About this Mac tab With 2047MB ( So I guess all is right ) I installed the latest nvida drivers and on clover I activated the NvidaWeb. The problem is the resolution. Max resolution allowed is 1280 x 1024 and 800 x 600. I used to boot with nvd_drv 1 with nvd dry 0, I used to boot with all that things, and without them.  BUT No way to fix the resolution. Someone knows what-s going wrong and how can I fix it? Bdw im using iMac14,2 and OS X Sierra 10.12.3 Im connecting to the screen with DVI adapter. ( Maybe that causes the problem ) But it shows Im running 2047 MB so... idk why I can't change resolution. Thanks! ================================= SOLVED EDIT: Hi guys, in Display Resolution, I just set it in "Default for display" and after that pressing "THE WINDOWS BUTTON KEY, IN MY CASE, IDK WHAT KEY IS THAT IN MAC KEYBOARD, I THINK THE CONTROL ONE OR IDK" PRESSING that key I selected Scaled, and it appears more options and resolutions. There is a video on youtube about that called "Mac OS X Display Resolution" If someone has the same trouble.
    • Hello , i have a big problem , help me please, i have installed properly Mac OS Sierra , but now i can’t boot Windows 10, when i click on a image , which has written for example boot Windows from legacy hd3 , it blocks on an image with the Apple sign on an hard disk image, and when i enter the bios i can’t see tue hard disk in boot options, how can i add Images? Pleaseeeee
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,534

×