:FIX/GUIDE: AMD Stuck At Grey/White Screen With Spinning Beachball :FIX/GUIDE: - OS X Yosemite 10.10 - Hackintosh Zone Jump to content
  • 0
Daniel J Straughair

:FIX/GUIDE: AMD Stuck At Grey/White Screen With Spinning Beachball :FIX/GUIDE:

Question

heres a list all the parts i have

PROCESSOR: AMD 8350 BOX PROCESSOR ------ AMD 8350 TRAY PROCESSOR

MOTHERBOARD: ASUS M5A97 EVO R2.0 ---- GIGABYTE 990FXA-UD3

GRAPHICS CARD: GIGABYTE 2GB ATI HD 7870 ----- 2x 1GB XFX HD 5770

RAM: 24gb CORSAIR VENGENCE 1816MHZ DDR3 ------ 32GB GSKILL ARIES 1600MHZ DDR3


THIS IS NOW SOLVED  :)  :)  :)  :)

first of all thanks everyone ( @Simone Rucci, @Niresh) who helped on this post i couldn't have made this happen without your help this will solve you beach ball spinning infinite grey/white screen crap ok i got this working the procedure is as follows on two different boards

asus m5a97 evo r2.0

gigabyte 990fxa-ud3

and two different graphics cards

gigabyte ati hd 79870 2gb

xfx hd5770

my processor is a amd fx 8350
32gb ddr3 gskill ram

I AM ALSO USING GPT

i can now easily play might and magic x legacy on full graphics settings

ok i used a certain kernel and the stock graphics drivers if you wish to change that it may or may not work

ok procedure you now need to have kext wizard handy

you need to head over to here for the AMD kernel

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=157955

inside that file is the kernel and the system.kext

now you need to go over to here to grab the other two kext IOPCIFamily.kext + AppleACPIPlatform.kext for yosemite

http://www.insanelymac.com/forum/files/file/354-amd-replace-kext-for-yosemite/


you will also need amd webkit patch

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=154087

now i want you to place all kext on the desktop
if you have backed up your graphics drivers during or after the install you should be able to boot with just

npci=0x2000 PCIRootUID=1 -v

if not you will also need to add

-f -x

now once you are at your desktop you need to move the kernel over to System/Library/Kernels
so rename your original kernel to kernel.backup1 then overwrite it with the new one

you will then open up kext wizard and use the install pane to install

system.kext
IOPCIFamily.kext
AppleACPIPlatform.kext
(also if you backed up your graphics drivers nows the time to reinstall them)

then i want you to keep kext wizard open and install the amd webkit patch after installation has finished go back to kext wizard and repair permissions (click both boxes on the bottom half)

then reboot some of you still may have to use -v and -f

i have mine booting with full acceleration
without -f -v

enjoy

 

http://www.vividtech.biz

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I will be attemping this method right now starting with a FRESH partiton & installation of yosemite 10.10.1 (hackintosh zone dmg).

Just for a heads up because I have a feeling I will be back with more errors (been at this for 2 1/2 days STRAIGHT; attempted EVERY boot flag...with nothing but a grey screen and a death wheel)

My PC specs are:

Processor: AMD FX -6300 3.50GHz

GPU: AMD Sapphire R7 270x 2GB

Board: Gigabyte 970A-UD3P (9 Series)

HDD: 1TB (WIN10) & 250GB (Mac OSX Yosemite 10.10.1; when finished installing)

RAM: 8GB DDR3

BIOS: UEFI DaulBIOS

Audio: Realtek High Def. Audio Ver. 6.0.1.7553

Bootloader: Chameleon (when finished installing yosemite 10.10.1)

Share this post


Link to post
Share on other sites
  • 0

I have same setup except nvidia gtx650Ti. Is Yosemite running slow, and what kext did you use for sound?

Edited by DX6644

Share this post


Link to post
Share on other sites
  • 0

heres a list all the parts i have

PROCESSOR: AMD 8350 BOX PROCESSOR ------ AMD 8350 TRAY PROCESSOR

MOTHERBOARD: ASUS M5A97 EVO R2.0 ---- GIGABYTE 990FXA-UD3

GRAPHICS CARD: GIGABYTE 2GB ATI HD 7870 ----- 2x 1GB XFX HD 5770

RAM: 24gb CORSAIR VENGENCE 1816MHZ DDR3 ------ 32GB GSKILL ARIES 1600MHZ DDR3


THIS IS NOW SOLVED  :)  :)  :)  :)

first of all thanks everyone ( @Simone Rucci, @Niresh) who helped on this post i couldn't have made this happen without your help this will solve you beach ball spinning infinite grey/white screen crap ok i got this working the procedure is as follows on two different boards

asus m5a97 evo r2.0

gigabyte 990fxa-ud3

and two different graphics cards

gigabyte ati hd 79870 2gb

xfx hd5770

my processor is a amd fx 8350
32gb ddr3 gskill ram

I AM ALSO USING GPT

i can now easily play might and magic x legacy on full graphics settings

ok i used a certain kernel and the stock graphics drivers if you wish to change that it may or may not work

ok procedure you now need to have kext wizard handy

you need to head over to here for the AMD kernel

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=157955

inside that file is the kernel and the system.kext

now you need to go over to here to grab the other two kext IOPCIFamily.kext + AppleACPIPlatform.kext for yosemite

http://www.insanelymac.com/forum/files/file/354-amd-replace-kext-for-yosemite/


you will also need amd webkit patch

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=154087

now i want you to place all kext on the desktop
if you have backed up your graphics drivers during or after the install you should be able to boot with just

npci=0x2000 PCIRootUID=1 -v

if not you will also need to add

-f -x

now once you are at your desktop you need to move the kernel over to System/Library/Kernels
so rename your original kernel to kernel.backup1 then overwrite it with the new one

you will then open up kext wizard and use the install pane to install

system.kext
IOPCIFamily.kext
AppleACPIPlatform.kext
(also if you backed up your graphics drivers nows the time to reinstall them)

then i want you to keep kext wizard open and install the amd webkit patch after installation has finished go back to kext wizard and repair permissions (click both boxes on the bottom half)

then reboot some of you still may have to use -v and -f

i have mine booting with full acceleration
without -f -v

enjoy

 

http://www.vividtech.biz

Thanks for the post. Got Yosemite working but switched to Mavericks. Now able to run W o D. I have Audio thru front jack only but no mic, still working on it. MB uses Realtek ALC892...  on GA-990FXA-UD3 GTX650T1 AMD FX6300  8GB ram  eth0  DVI -HDMI >46" samsung 1080p

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $62.87 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • I am fairly new to the idea of creating hackintoshes but I would love to dual boot Windows 10 and Mac OS Sierra on this machine listed below, will it be possible? Thanks in advance   Case CORSAIR OBSIDIAN SERIES™ 750D FULL TOWER CASE Processor (CPU) Intel® Core™i7 Ten Core Processor Extreme i7-6950X (3.0GHz) 25MB Cache Motherboard ASUS® RAMPAGE V EDITION 10: E-ATX, USB 3.1, SATA 6 GB/s Memory (RAM) 32GB HyperX PREDATOR DDR4 3200MHz X.M.P (4 x 8GB) Graphics Card   Asus Republic Of Gamers Strix NVIDIA GTX 1080 1st Hard Disk 480GB BiWIN 2.5" SSD, SATA 6 Gb/s (upto 564MB/sR | 513MB/sW) 2nd Hard Disk 6TB SATA-III 3.5" HDD, 6GB/s, 7200RPM, 128MB CACHE DVD/BLU-RAY Drive 16x BLU-RAY WRITER DRIVE, 16x DVD ±R/±RW & SOFTWARE Power Supply CORSAIR 1000W RMx SERIES™ MODULAR 80 PLUS® GOLD, ULTRA QUIET Power Cable 1 x 1 Metre UK Power Cable (Kettle Lead) Processor Cooling Corsair H100i V2 Hydro Cooler w/ PCS Liquid Series Ultra Quiet Fans Thermal Paste ARCTIC MX-4 EXTREME THERMAL CONDUCTIVITY COMPOUND Extra Case Fans 2x 120mm Apache Black Quiet Fan (fitted to extract from rear/roof)     Sound Card ONBOARD 8 CHANNEL (7.1) HIGH DEF AUDIO (AS STANDARD) Wireless/Wired Networking 10/100/1000 GIGABIT LAN PORT (Wi-Fi NOT INCLUDED) USB Options MIN. 2 x USB 3.0 & 6 x USB 2.0 PORTS @ BACK PANEL + MIN. 2 FRONT PORTS Operating System Genuine Windows 10 Professional 64 Bit - inc DVD & Licence Operating System Language United Kingdom - English Language DVD Recovery Media Windows 10 (64-bit) Professional DVD with paper sleeve Office Software NO OFFICE SOFTWARE Anti-Virus NO ANTI-VIRUS SOFTWARE Browser Google Chrome™ Warranty 3 Year Silver Warranty (1 Year Collect & Return, 1 Year Parts, 3 Year Labour) Delivery STANDARD INSURED DELIVERY TO UK MAINLAND (MON-FRI) Build Time Standard Build - Approximately 7 to 9 working days
    • hii i am using samsung laptop intel i3   M370   2.40 Ghz  nvidia geforce  M315  graphics when i boot from usb,  firstly show some code and after this show a dialog box . in this box , showing a phone and laptop, one by one. on the top of the screen, showing apple logo and "Language Chooser". i am not able go next step.   plz help me.
    • Hi guys, I installed the Hackintosh Sierra Zone image and most things work except my graphics. It detects as AMD R9 290X when I use FakeID 0x67B01002 on boot, however I only get 7MB of VRAM with no QE. My screen also tears as well. Hope someone can help me - Intel Core i5 2500K - AMD R9 290X 4GB - ASUS P8Z77-V LX
    • Hey guys, I'm looking into dual booting OSX Sierra or High Sierra on my ASUS Zenbook Pro UX501V. I use a lot of mac only software like sketch at uni and it would make my life a lot easier to just be able to boot into it instead of going to campus to use one of their Mac's. I'm currently running windows 10 and would prefer to not have to lose all my files or reinstall windows 10, however if this is unavoidable I would consider it. Specs are Processor    Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz, 2592 Mhz, 4 Core(s), 8 Logical Processor(s)
      GPU    NVIDIA GeForce GTX 960m 4gb DDR5
      RAM    12GB DDR4
      BIOS Version/Date    American Megatrends Inc. N501VW.300, 9/05/2016
      BIOS Mode    UEFI Does anyone know of any guides? Or has done this before? Even a link to point me on my way. Looked into the clover bootloader and I'm under the impression that's the route I'll have to take. Thanks for any help you may have      
    • Hi everyone. Here are my specs MOBO :Gigabyte Z68 XP UD3 (1155) GPU : HD 6870 1gb CPU Intel i7 2600k (1155) 60gb SATA SSD   MOBO is using legacy Bios. This machine has served me well for years. I tripped a circuit breaker a few weeks ago and now it's stuck in a boot loop. I have setup a new bootable USB to reinstall but for some reason the boot loop is happening when I startup from this as well. I can manage to get to the desktop using the safe mode boot flag (-x) but after a few moments, the desktop freezes and the computer reboots. I used the 10.10.1 disc image to create the new USB stick I am not sure if this could be causing the boot problem in the USB. Should I have used the 10.10.0? At first I suspected a hardware issue but I left the computer on for two days at in the bios screen and it stayed on just fine. Hoping someone can give me a hand figuring out which boot flags can get me going again or how I can reinstall the OS. I really need to get past the freeze/reboot cycle I am in. I am almost ready to nuke this thing and install windows
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,538

    Latest File
    By rembrandt63

    330    0

×