:FIX/GUIDE: AMD Stuck At Grey/White Screen With Spinning Beachball :FIX/GUIDE: - OS X Yosemite Zone Hackintosh 10.10 - Hackintosh Zone Jump to content
  • 0
Daniel J Straughair

:FIX/GUIDE: AMD Stuck At Grey/White Screen With Spinning Beachball :FIX/GUIDE:

Question

heres a list all the parts i have

PROCESSOR: AMD 8350 BOX PROCESSOR ------ AMD 8350 TRAY PROCESSOR

MOTHERBOARD: ASUS M5A97 EVO R2.0 ---- GIGABYTE 990FXA-UD3

GRAPHICS CARD: GIGABYTE 2GB ATI HD 7870 ----- 2x 1GB XFX HD 5770

RAM: 24gb CORSAIR VENGENCE 1816MHZ DDR3 ------ 32GB GSKILL ARIES 1600MHZ DDR3


THIS IS NOW SOLVED   :)   :)   :)   :)

first of all thanks everyone ( @Simone Rucci, @Niresh) who helped on this post i couldn't have made this happen without your help this will solve you beach ball spinning infinite grey/white screen crap ok i got this working the procedure is as follows on two different boards

asus m5a97 evo r2.0

gigabyte 990fxa-ud3

and two different graphics cards

gigabyte ati hd 79870 2gb

xfx hd5770

my processor is a amd fx 8350
32gb ddr3 gskill ram

I AM ALSO USING GPT

i can now easily play might and magic x legacy on full graphics settings

ok i used a certain kernel and the stock graphics drivers if you wish to change that it may or may not work

ok procedure you now need to have kext wizard handy

you need to head over to here for the AMD kernel

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=157955

inside that file is the kernel and the system.kext

now you need to go over to here to grab the other two kext IOPCIFamily.kext + AppleACPIPlatform.kext for yosemite

http://www.insanelymac.com/forum/files/file/354-amd-replace-kext-for-yosemite/


you will also need amd webkit patch

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=154087

now i want you to place all kext on the desktop
if you have backed up your graphics drivers during or after the install you should be able to boot with just

npci=0x2000 PCIRootUID=1 -v

if not you will also need to add

-f -x

now once you are at your desktop you need to move the kernel over to System/Library/Kernels
so rename your original kernel to kernel.backup1 then overwrite it with the new one

you will then open up kext wizard and use the install pane to install

system.kext
IOPCIFamily.kext
AppleACPIPlatform.kext
(also if you backed up your graphics drivers nows the time to reinstall them)

then i want you to keep kext wizard open and install the amd webkit patch after installation has finished go back to kext wizard and repair permissions (click both boxes on the bottom half)

then reboot some of you still may have to use -v and -f

i have mine booting with full acceleration
without -f -v

enjoy

 

http://www.vividtech.biz

  • Like 1

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Saludos!   Tengo el mismo error (RAM a 667mhz), con una placa base ASUS (y mi cpu es el fx 6300).   Lograste solucionarlo?
    • Hi guys. Well, this is my second day of troubles, I touched everything, I installed max like 5 times in the same day, trying to figure out things and well. My Mac it display my graphic card on the #About this Mac tab With 2047MB ( So I guess all is right ) I installed the latest nvida drivers and on clover I activated the NvidaWeb. The problem is the resolution. Max resolution allowed is 1280 x 1024 and 800 x 600. I used to boot with nvd_drv 1 with nvd dry 0, I used to boot with all that things, and without them.  BUT No way to fix the resolution. Someone knows what-s going wrong and how can I fix it? Bdw im using iMac14,2 and OS X Sierra 10.12.3 Im connecting to the screen with DVI adapter. ( Maybe that causes the problem ) But it shows Im running 2047 MB so... idk why I can't change resolution. Thanks! ================================= SOLVED EDIT: Hi guys, in Display Resolution, I just set it in "Default for display" and after that pressing "THE WINDOWS BUTTON KEY, IN MY CASE, IDK WHAT KEY IS THAT IN MAC KEYBOARD, I THINK THE CONTROL ONE OR IDK" PRESSING that key I selected Scaled, and it appears more options and resolutions. There is a video on youtube about that called "Mac OS X Display Resolution" If someone has the same trouble.
    • Hello , i have a big problem , help me please, i have installed properly Mac OS Sierra , but now i can’t boot Windows 10, when i click on a image , which has written for example boot Windows from legacy hd3 , it blocks on an image with the Apple sign on an hard disk image, and when i enter the bios i can’t see tue hard disk in boot options, how can i add Images? Pleaseeeee
    • Im trying to install MacOSierra on Alienware 15 r2,  512ssd nvme 951 and 120gb intel sataIII samsung, i6820 hk 980m, intel 530. Ofter many attempts i solved a lot of erros during the installation, and finnaly i found out that macOs does not suport SSD. I created a patch for my ssds but now, i have this error: ACPI ERROR; and last: AppleNVMe Assert failed;  2 SSD: // Inject bogus class-code for NVMe SSD to prevent IONVMeFamily.kext from loading
      DefinitionBlock("", "SSDT", 2, "hack", "NVMe-Pcc", 0)
      {
          External(_SB.PCI0.PEG0, DeviceObj)
          Method(_SB.PCI0.PEG0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
          External(_SB.PCI0.SAT0, DeviceObj)
          Method(_SB.PCI0.SAT0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
      }
      //EOF   I did the patch in virtual machine as they instructed. but still nothing.
    • Hey!  I successfully installed macOS Sierra with the Version SierraAMD v3 on my AMD Pc.  But after setting up the PostInstall via Terminal, the OS stops booting at this line : ioconsoleusers: gioscreenlockstate 3, hs 0, bs 0, now 0, sm 0x0 Any solutions?    My System Specs: Mainboard: Asrock 970 Pro3 r2.0 Processor: AMD FX-6300 Graphics: Sapphire Radeon RX460 4GB   Thanks!
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,534

×