:FIX/GUIDE: AMD Stuck At Grey/White Screen With Spinning Beachball :FIX/GUIDE: - Hackintosh Yosemite - Hackintosh Zone Jump to content
  • 0
Daniel J Straughair

:FIX/GUIDE: AMD Stuck At Grey/White Screen With Spinning Beachball :FIX/GUIDE:

Question

heres a list all the parts i have

PROCESSOR: AMD 8350 BOX PROCESSOR ------ AMD 8350 TRAY PROCESSOR

MOTHERBOARD: ASUS M5A97 EVO R2.0 ---- GIGABYTE 990FXA-UD3

GRAPHICS CARD: GIGABYTE 2GB ATI HD 7870 ----- 2x 1GB XFX HD 5770

RAM: 24gb CORSAIR VENGENCE 1816MHZ DDR3 ------ 32GB GSKILL ARIES 1600MHZ DDR3


THIS IS NOW SOLVED   :)   :)   :)   :)

first of all thanks everyone ( @Simone Rucci, @Niresh) who helped on this post i couldn't have made this happen without your help this will solve you beach ball spinning infinite grey/white screen crap ok i got this working the procedure is as follows on two different boards

asus m5a97 evo r2.0

gigabyte 990fxa-ud3

and two different graphics cards

gigabyte ati hd 79870 2gb

xfx hd5770

my processor is a amd fx 8350
32gb ddr3 gskill ram

I AM ALSO USING GPT

i can now easily play might and magic x legacy on full graphics settings

ok i used a certain kernel and the stock graphics drivers if you wish to change that it may or may not work

ok procedure you now need to have kext wizard handy

you need to head over to here for the AMD kernel

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=157955

inside that file is the kernel and the system.kext

now you need to go over to here to grab the other two kext IOPCIFamily.kext + AppleACPIPlatform.kext for yosemite

http://www.insanelymac.com/forum/files/file/354-amd-replace-kext-for-yosemite/


you will also need amd webkit patch

http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=154087

now i want you to place all kext on the desktop
if you have backed up your graphics drivers during or after the install you should be able to boot with just

npci=0x2000 PCIRootUID=1 -v

if not you will also need to add

-f -x

now once you are at your desktop you need to move the kernel over to System/Library/Kernels
so rename your original kernel to kernel.backup1 then overwrite it with the new one

you will then open up kext wizard and use the install pane to install

system.kext
IOPCIFamily.kext
AppleACPIPlatform.kext
(also if you backed up your graphics drivers nows the time to reinstall them)

then i want you to keep kext wizard open and install the amd webkit patch after installation has finished go back to kext wizard and repair permissions (click both boxes on the bottom half)

then reboot some of you still may have to use -v and -f

i have mine booting with full acceleration
without -f -v

enjoy

 

http://www.vividtech.biz

  • Like 1

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $85.17 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hi, everyone, thanks for your time.
      I'm trying to fresh install macOS 10.13.1 (Build 17B48). I'm trying to do this by free myself from multibeast and by put kexts in EFI/CLOVER/kexts/10.3 and set a good config.plist.

      I have this famous issue in verbose mode and can't boot.
      IOConsoleUsers: time(0) 0->0, lin 0, llk 1,
      IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0
        It's looks like your own issue.

      Every time, i can boot the first time. I start my post-install by install the web drivers automatically served by Nvidia. And never be able to boot again…
      I didn't found any plist option that permit to boot over this issue…
      help… !

      My list of kexts and my config.plist is joined.
      Thanks for your time…


      Here are my list of used kexts kexts/10.13 folder : NvidiaGraphicsFixup.kext    v 1.1.3 AppleALC.kext
      AtherosE2200Ethernet.kext    v 1.2.0
      FakePCIID_XHCIMux.kext        v 2.2.1
      FakePCIID.kext            v 1.3.9
      FakeSMC_ACPISensors.kext    v 6.25-333-g05e0f4be.1759
      FakeSMC_CPUSensors.kext        v 6.25-333-g05e0f4be.1759
      FakeSMC_GPUSensors.kext        v 6.25-333-g05e0f4be.1759
      FakeSMC_LPCSensors.kext        v 6.25-333-g05e0f4be.1759
      FakeSMC.kext            v 6.25-333-g05e0f4be.1759
      HDMIAudio.kext            v 1.0
      IntelMausiEthernet.kext        v 2.3.0
      Lilu.kext            v 1.2.0
      Shiki.kext            v 2.0.5
      USBInjectAll.kext        0.6.2 Driver64UEFI folder apfs.efi
      AppleImageCodec-64.efi
      AppleKeyAggregator-64.efi
      AppleUITheme-64.efi
      DataHubDxe-64.efi
      EmuVariableUefi-64.efi
      FirmwareVolume-64.efi
      FSInject-64.efi
      HFSPlus.efi
      NTFS.efi
      OsxAptioFix2Drv-64.efi
      OsxFatBinaryDrv-64.efi
      SMCHelper-64.efi
      VBoxHfs-64.efi

      Gigabyte GA-Z170X-Gaming 5 | i7-6700(not K) | GTX980ti - OS on SSD.
    • Hi everyone, i got acer Aspire Icore 3 Laptop, and i've trie many installs, however, none of those worked on this laptop, even typing -x -v, never get the install menu, some of the run until the screen flash and reboot's again and again,, Anyone can give me a tip, i would try Yosemite, cause i got MacBook 5.1 can't upgrade to sierra/High Sierra ( well i can with a patch, but can't get the sierra installer ) i've put all the laptop specs on the screenshot.  i think all is components are compatible with mac,, above. Thanks in advance.file:///Users/Memphis/Downloads/Acer specs.png  
    • i am trying to install yosemite on a asus m2n sli deluxe chipset NVIDIA amd Athlon 64 X2 5600+ ATI Radeon HD 4800   and still i am stuck at pci configuration begin or console error. i tried several kernels and graphic cards with no results   i found some kext (no pci ea) now i come to the screen with language. and then it freezes   I’ve tried several thing but i am stuck is there anyone that can help
    • I've created install media with MacPawn as well as with Unibeast from High Sierra AppStore DMG ; The USB disk creation went smoothly, but when I try to boot from these disks all I get is a blinking cursor on top left of the screen, nothing else ... My Mac / Hackintosh : Asus P5Q Intel Core 2 Quad CPU Q8300 @ 2.50 GHz 8,00 GB RAM AMD Radeon HD 6450 Legacy IDE / ATA : 200 GB SATA : 320GB SSD : Kingston 120GB
    • Please install Niresh Yosemite now, at the first boot after installation i have full resolution with the intel hd 3000. after repairing permissions etc etc, i do not have any more acceleration at the new reboot. Sometimes by booting pennete I have acceleration graphic, starting from hard disk n. Ah, I got the Chameleon bootloader
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,539

    Latest File
    By rembrandt63

    421    0

×