Still waiting for root device - Hackintosh Yosemite - Hackintosh Zone Jump to content

Question

Hi! I'm new on this forum. I want to install Yosemite with USB pendrive. When I try to boot it with "/amd64 GraphicsEnabler=No npci=0x3000" I have to boot with "GraphicsEnabler=No npci=0x3000" because I had "PCI configuration begin" message. In few seconds there's a crossed circle. I tried to boot it in verbose. The last line is "Still waiting for root device". I tried to fix it by placing GenericUSBXHCI.kext or Niresh's Still Waiting for Root Device Fix, but nothing changed. I have to boot with "GraphicsEnabler=No npci=0x3000" because I had "PCI configuration begin" message.

 

My specs:

CPU: AMD FX-4300BE

GPU: Gigabyte HD 7770 OC

MOBO: ASRock N68C-GS FX

RAM: 1x4GB DDR3

Ethernet: Realtek RTL8211CL

Audio: Roland UA-1EX

 

I hope someone will help me :)

Thanks

Share this post


Link to post
Share on other sites

26 answers to this question

Recommended Posts

  • 1

@siralex90 Can you attach a verbose picture with

"/amd64  npci=0x3000 -v" at the point where you get stuck with still waiting for root device

Share this post


Link to post
Share on other sites
  • 0

Yes, I tried "USBBusFix=Yes" and others boot flags many times, and when I disable USB Legacy my USB pendrive isn't recognized.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $80.78 of $100.00 goal reached.
    Donate Now
×