msi radeon hd6450 issues - Hackintosh Mavericks - Hackintosh Zone msi radeon hd6450 issues Jump to content
Sign in to follow this  

msi radeon hd6450 issues

Recommended Posts

Im having issues with this particular graphics card...I bought this card for my father as on my mackintosh it worked out of the box....On his however after installation and restart I make it past the apple logo then go straight to a white screen where it stays with no cursor....However if I boot into safe mode and remove amd6000controller.kext then restart I can get to the desktop with very laggy graphics that are horrible.........Ive tried copying amdcontroller6000.kext to the desktop,deleting it from S/L/E and reinstalling it-that actually worked one time but every icon in launchpad was red...After that one successful restart it immediately started freezing at the white screen again....I am a noob to the mackintosh world so if anyone could please help me with instructions on as to how to fix this I d greatly appreciate it so much ,,as I also have to fix the ethernet afterwards....thank you.....Another thing-I am using the dvi connection




EDIT:today I noticed that it was a hit and miss-Sometimes if I booted with"GraphicsEnabler=no" I could boot into the desktop and my graphics were excellent no issues whatsoever....However it was hit and miss because other times when I used that bootflag I d still freeze at a white screen.....At one point I used "-s" bootflag then typed in "graphicsenabler=no" I noticed an error with cpu powermanagement-that was one of the times graphicsenabler=no didnt work........I didnt have the pinkish icons in launchpad on successful boots though.....can anyone help me


Ive been reading something about patching with "Pithecia"'''.....could this work in my situation?could someone tell me step by step how to do it?


UPDATE:the card Im running is msi radeon hd6450 which has 2gigs of dedicated memory...I spent all night once again trying to make the graphics work then I noticed something-when I first install using hdmi I have perfect graphics and acceleration but right after the niresh permissions fixes go through my screen turns grey for a second and comes back-when it does my icons in Launchpad are pink and as well when I restart the system I get the white screen again...I googled this and there was something about the amd6000controller.kext having permission issues?how do I fix this as to when I repair permissions or nireshs permissions don't break my graphics?Ive been going 3 weeks on this graphics issue and once its fixed I have the joys of making internet work




UPDATE:I VE tried several things including khatphats  hd6450 kexts-nothing works...When I reboot I get a blank white screen...any ideas? I did fix the Ethernet by purchasing an Ethernet card to disable onboard.I know this graphics card works because ive managed to get to the desktop a couple times with awesome graphics



UPDATE:After a long struggle with the 6450 on and AMD machine I decided to give up and started to read reviews over the radeon hd5450.Everywhere I looked I read bad reviews about the 5450 not working well with mavericks,major issues...So I went out on a limb and purchased the 5450 installed the 5450 and reinstalled Mavericks-LO and behold the 5450 worked  for me....In my intel machine the 6450 worked oob with mavericks but on an AMD not so lucky.However I m not so sure it isnt because the 6450 requires a 450 watt psu and my fathers machine can only use a 220 unless I run the new psu outside the pc due to it being a slimline..The moral of the story here folks is quit reading what works for someone else in the hackintosh world..However Id like to thank KHATPHAT for his 5450 kexts.Very much appreciated

Share this post

Link to post
Share on other sites


I have just found out the cause. this is not a problem of the graphics card which is to problem with amd kernel. This problem is called "Pink launchpad icon" that a lot of people have this error and I also was one of them I don't have time to test yet but you can find in here.

Share this post

Link to post
Share on other sites

i have amd radeon hd 6450 kexts for mavericks.Graphics works Perfect.let me know if you want it.

Share this post

Link to post
Share on other sites

@ I would greatly appreciate the amd hd 6450 kexts for mavericks.Thank you

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Donation Goals

    Hosting May 2018

    Please donate to support the community.
    We appreciate all donations!


    $35.82 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • I !ve got the problem after post install highsierra . when restart computer ,It can!t boot to keep going install account and hang the computer.   My laptop is ASUS X550D  with amd CPU A6 5350M 2.9 GHZ                        graphic RADEON HD 8670M    RAM  4gb  help me how to fix it thanks alot         
    •     Getting problem with installing macos Sierra on a dell latitude E5520, I tried the usb boot on a hp computer and there it worked. But on the dell i get the error as in the picture. What's can i do for fix this?
    • I've added every kext possible, Lilu, IntelGraphicsFixup, changed my config settings nothing so far has worked. I tried asking for help on the tony mac forums, but was banned the minute I sent the progress report they asked for, for software piracy. (which makes no sense because any hackintosh is software piracy anyway) but regardless of that, I still have very choppy graphics, and only 4 mb of VRAM, as shown in the about my mac screenshot I linked below. Can anyone help?
    • Hi, 
      I finally decided to install macOS high sierra on my laptop - Lenovo IdeaPad 720S 15IKB.
      It has:   i5-7300HQ, Intel HM175
      12GB DDR4 RAM
      A Samsung 256GB NVMe Drive
      GTX 1050 Ti With Max-Q   The first try did not boot so i had to use some args to get it to boot. The first problem arises due to the fact that all available usb slots are usb 3.1. The installer did not recognise my keyboard and trackpad and i had to install some kexts to get them working. Well, after i intalled the kexts, It was stuck in a boot loop. I was fed up and it was late so i decided to download hackintosh zone from niresh. I would install it later. Well, when i run hackintosh zone it gets stuck at the apple logo after loading. I ran it in verbose mode and it gets stuck in the following   [Date] localhost[1] <Error>: Host-level exception raised: pid = 541, thread = 0xbf1f, exception type = 0xd, codes = { 0 }, states = { 0 }
      busy timeout[0], (240s): 'AppleEFIRuntime'
      busy timeout[1], (240s): 'AppleEFIRuntime'
      busy timeout[2], (240s): 'AppleEFIRuntime'   Then the screen goes blank and it starts over. Any help is appreciated. Thanks!
    • ASUS laptop X550D can run hackintosk ? help me ! please!!!   thanks alot
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By Niresh

    548    0