Yosemite Zone only booting in safe mode with a bunch of parameters Yosemite Zone only booting in safe mode with a bunch of parameters - Hackintosh Yosemite - Hackintosh Jump to content

Yosemite Zone only booting in safe mode with a bunch of parameters

Recommended Posts



just installed Yosemite Zone 10.10 from Niresh USB image. The installation failed with "Undefined Error 0", yet still the OS is booting and working, but only if I boot with the following parameters:


IGPEnabler=N GraphicsEnabler=N -x -v dart=0 UseKernelCache=N -f


I assume that this is not how it is supposed to be. If I leave any of the options out, it will either result in an immediate kernel panic or a loading screen with the HackintoshZone logo and a progress bar loading extremely slow and stopping at ca. 50%.


Here is my config:


- CPU: Intel Core i5 4570 (4x3,2 GHz)


- Board: Gigagbyte H87-HD3



BIOS Options:


- VT-d disabled

- xHCI auto

- xHCI Hand-off enabled

- EHCI Hand-off enabled



What can I do to omit the parameters or at least apply them automatically without having to type them every time?



Share this post

Link to post
Share on other sites

i need the log of the installation because i cant be sure if the os x installation has copied required files

try to install nvidia web drivers

if possible boot with just -v and attach a screenshot

Share this post

Link to post
Share on other sites



I did not change any settings in the image, so I assume it is still the default one in the Yosemite Zone DMG Image (Chameleon).


UPDATE: I have formatted my USB drive and re-copied the image and double-checked some BIOS settings. For some reason, I could perform the installation without any boot flags now and installation succeeded without the "Undefined Error 0". Nevertheless I still can't boot the OS in normal mode because I'm stuck at the HZ loading screen and after 20-30 min the screen signal turns off.


In verbose mode, this is where it stops: https://i.imgur.com/bJjR4WP.jpg


I also tried with dart=0 -f which results in a kernel panic.

Share this post

Link to post
Share on other sites

UPDATE 2: I have managed to make it work with GraphicsEnabler=N -f by unplugging my USB wifi antenna (but that is no problem as it is not compatible with OSX anyway) but booting is very slow (takes about 2 minutes). What can I do to speed things up?


EDIT: Now it takes 40 seconds from pressing Enter on the boot screen until login screen appears, can this be optimized further or is this a normal boot time (without SSD)? I read something about deleting unnecessary kexts but am not completely sure what I can delete without breaking my system.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting April 2018

    Please donate to support the community.
    We appreciate all donations!


    $31.08 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • @moriel5 Installing windows on a pc is the easiest thing ever, reset BIOS insert bootable USB or DVD, partition hard disk install windows.
    • I tried installing High Sierra as well as Sierra on my Acer Laptop and Mac Os is not booting(unable to install)....I followed all the steps mentioned. In some videos which I saw on Youtube they dont Face any problems....they plug USB and PC boots into Clover but mine is not booting...please help... My Laptop is Acer F15 series Laptop and Model No is F5-573G-59V4 Thank You.
    • Hi, i tried to install high sierra on my hp computer, i created the partition on windows, i copied the sata-100-unssuported.kext to /EFI/CLOVER/kexts/Other but my intel SSD does not show up at the disk utility at all, my bios does not have options to change sata to ahci or any other option, and i read something about mbr patch which i dowloaded but there is no guide on what to do with it, any help would be really appreciated. Thanks
    • i tried this in last hours, but nothing. i tried to boot on an acer aspire (specs are almost the same) and it boots (stuck on logo but boot), i guess that problem is mine laptop?
    • Hi!
      As a first try with hackintosh I succesuffy installed High Sierra on a Dell PowerEdge T20. It works fine, but as I start scrolling in a web-browser the screen starts flickering. It only recognises my screen as a secondary projector, and can't change resolution from 1920x1080.
      How do I fix this?
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By ka209

    34    0