How to fix "Waiting for DSMOS" or "DSMOS has arrived" - Troubleshooting - Hackintosh Zone Jump to content
  • 0
HackintoshMumbai

How to fix "Waiting for DSMOS" or "DSMOS has arrived"

Question

Here is an updated article

 

"Waiting for DSMOS" or "DSMOS has arrived" this is caused most of the time by FakeSMC.kext  

and it is a Graphics issue too 

 

Solution 1:-

Download the latest FakeSMC.kext and replace with the old one.You can do it by mac drive or From USB installer and Boot with Following flag "GraphicsEnaber=No" 

If that doesn't fix your problem, boot your mac drive with single-user mode(-s) and type:

 

/sbin/mount -uw

mkdir ~/backup

cd /System/Library/Extensions

 

If you have NVIDIA graphics then type:

 

mv -R NVD*.kext ~/backup

 

If you have AMD/ATI Graphics then type:

 

mv -R ATI*.kext ~/backup

 

If you have IntelGraphics then type:

mv -R AppleIntelGMA* ~/backup

mv -R AppleIntelHD* ~/backup

mv -R AppleIntelSNB* ~/backup

mv -R AppleIntelIntegratedFramebuffer.kext ~/backup

 

Solution 2:-

Boot your mac drive using this flags " -V -S " and you go to single mode

 

fsck -fy

mount -uw /

mkdir /backup

cd /System/Library/Extensions

mv AppleIntelHD* AppleIntelSNB* AMDRadeon* ATI* GeForce* NVDA* /backup

rm ../Caches/com.apple.kext.caches/Startup/kernelcache

 

reboot

 

Note:- If your system have AppleIntelCPUPowerManagement then save it in backup 

 
  • Like 2

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I hv same problem on my pc 10.9.0

config is Gigabyte Mb B75M D3H  i5 3330 4GB Ram

 

system starts with -x flag  but not boot in normal mode.

please guide me or help me to build a hackintosh

Share this post


Link to post
Share on other sites
  • 0

I hv same problem on my pc 10.9.0

config is Gigabyte Mb B75M D3H  i5 3330 4GB Ram

 

system starts with -x flag  but not boot in normal mode.

please guide me or help me to build a hackintosh

Its a GPU issue what kind a GPU u have ?

Update your signature like mine

10464346_775554689150758_288666343938870

 

guys does anyone have intel DH61WW motherboard? my problem is im stucked at dsmos has arrived and bluetooth something i dont remember clearly.

Delete all kext of AMD/NVIDIA/INTEL and try

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $62.87 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • I previously installed yosemite on my pc. It worked well. But I can only boot the yosemite by cliking F10 advanced boot option and have to select my Hard drive. It didn/t boot automatically. So I just mounted the EFI folder and replaced the files from the original EFI I got from a link. Probelm started. So I planned to install Yosemite again. Keyboard not worked. So I boot back windows 10 and replace everything. But when I try to install yosemite again, sill I'm facing the probelm. Keyboard not working at selecting Yosemite zone screen. Keyboard is well functioning at BIOS screen, advanced boot option screen, even in my windows 10. But it freeze at the below screen. I tried everything, changed my Boot mode to UEFI and Legacy, reset CMOS by removing CMOS battery, restarted minimum 50 times, Changed my keyboard from USB to PS2, changed my USB keyboard port to every port. Please help me to solve this.   My System Config :   Intet i3-2120 CPU@3.30GHz 1 TB Hard drive 8 GB Ram 2GB GT610 graphic card Keyboard freeze at this screen.
    • Yes , I'm Jeff and I'm new around here. I was wondering what it takes to get a ISO file around here?  By the way I love your web site.  Hope to hear from you soon. Thanks.
    • I am fairly new to the idea of creating hackintoshes but I would love to dual boot Windows 10 and Mac OS Sierra on this machine listed below, will it be possible? Thanks in advance   Case CORSAIR OBSIDIAN SERIES™ 750D FULL TOWER CASE Processor (CPU) Intel® Core™i7 Ten Core Processor Extreme i7-6950X (3.0GHz) 25MB Cache Motherboard ASUS® RAMPAGE V EDITION 10: E-ATX, USB 3.1, SATA 6 GB/s Memory (RAM) 32GB HyperX PREDATOR DDR4 3200MHz X.M.P (4 x 8GB) Graphics Card   Asus Republic Of Gamers Strix NVIDIA GTX 1080 1st Hard Disk 480GB BiWIN 2.5" SSD, SATA 6 Gb/s (upto 564MB/sR | 513MB/sW) 2nd Hard Disk 6TB SATA-III 3.5" HDD, 6GB/s, 7200RPM, 128MB CACHE DVD/BLU-RAY Drive 16x BLU-RAY WRITER DRIVE, 16x DVD ±R/±RW & SOFTWARE Power Supply CORSAIR 1000W RMx SERIES™ MODULAR 80 PLUS® GOLD, ULTRA QUIET Power Cable 1 x 1 Metre UK Power Cable (Kettle Lead) Processor Cooling Corsair H100i V2 Hydro Cooler w/ PCS Liquid Series Ultra Quiet Fans Thermal Paste ARCTIC MX-4 EXTREME THERMAL CONDUCTIVITY COMPOUND Extra Case Fans 2x 120mm Apache Black Quiet Fan (fitted to extract from rear/roof)     Sound Card ONBOARD 8 CHANNEL (7.1) HIGH DEF AUDIO (AS STANDARD) Wireless/Wired Networking 10/100/1000 GIGABIT LAN PORT (Wi-Fi NOT INCLUDED) USB Options MIN. 2 x USB 3.0 & 6 x USB 2.0 PORTS @ BACK PANEL + MIN. 2 FRONT PORTS Operating System Genuine Windows 10 Professional 64 Bit - inc DVD & Licence Operating System Language United Kingdom - English Language DVD Recovery Media Windows 10 (64-bit) Professional DVD with paper sleeve Office Software NO OFFICE SOFTWARE Anti-Virus NO ANTI-VIRUS SOFTWARE Browser Google Chrome™ Warranty 3 Year Silver Warranty (1 Year Collect & Return, 1 Year Parts, 3 Year Labour) Delivery STANDARD INSURED DELIVERY TO UK MAINLAND (MON-FRI) Build Time Standard Build - Approximately 7 to 9 working days
    • hii i am using samsung laptop intel i3   M370   2.40 Ghz  nvidia geforce  M315  graphics when i boot from usb,  firstly show some code and after this show a dialog box . in this box , showing a phone and laptop, one by one. on the top of the screen, showing apple logo and "Language Chooser". i am not able go next step.   plz help me.
    • Hi guys, I installed the Hackintosh Sierra Zone image and most things work except my graphics. It detects as AMD R9 290X when I use FakeID 0x67B01002 on boot, however I only get 7MB of VRAM with no QE. My screen also tears as well. Hope someone can help me - Intel Core i5 2500K - AMD R9 290X 4GB - ASUS P8Z77-V LX
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,538

    Latest File
    By rembrandt63

    343    0

×