How to fix "Waiting for DSMOS" or "DSMOS has arrived" - Troubleshooting - Hackintosh Zone Jump to content
  • 0
HackintoshMumbai

How to fix "Waiting for DSMOS" or "DSMOS has arrived"

Question

Here is an updated article

 

"Waiting for DSMOS" or "DSMOS has arrived" this is caused most of the time by FakeSMC.kext  

and it is a Graphics issue too 

 

Solution 1:-

Download the latest FakeSMC.kext and replace with the old one.You can do it by mac drive or From USB installer and Boot with Following flag "GraphicsEnaber=No" 

If that doesn't fix your problem, boot your mac drive with single-user mode(-s) and type:

 

/sbin/mount -uw

mkdir ~/backup

cd /System/Library/Extensions

 

If you have NVIDIA graphics then type:

 

mv -R NVD*.kext ~/backup

 

If you have AMD/ATI Graphics then type:

 

mv -R ATI*.kext ~/backup

 

If you have IntelGraphics then type:

mv -R AppleIntelGMA* ~/backup

mv -R AppleIntelHD* ~/backup

mv -R AppleIntelSNB* ~/backup

mv -R AppleIntelIntegratedFramebuffer.kext ~/backup

 

Solution 2:-

Boot your mac drive using this flags " -V -S " and you go to single mode

 

fsck -fy

mount -uw /

mkdir /backup

cd /System/Library/Extensions

mv AppleIntelHD* AppleIntelSNB* AMDRadeon* ATI* GeForce* NVDA* /backup

rm ../Caches/com.apple.kext.caches/Startup/kernelcache

 

reboot

 

Note:- If your system have AppleIntelCPUPowerManagement then save it in backup 

 
  • Like 2

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
hemantu    0

I hv same problem on my pc 10.9.0

config is Gigabyte Mb B75M D3H  i5 3330 4GB Ram

 

system starts with -x flag  but not boot in normal mode.

please guide me or help me to build a hackintosh

Share this post


Link to post
Share on other sites
  • 0

I hv same problem on my pc 10.9.0

config is Gigabyte Mb B75M D3H  i5 3330 4GB Ram

 

system starts with -x flag  but not boot in normal mode.

please guide me or help me to build a hackintosh

Its a GPU issue what kind a GPU u have ?

Update your signature like mine

10464346_775554689150758_288666343938870

 

guys does anyone have intel DH61WW motherboard? my problem is im stucked at dsmos has arrived and bluetooth something i dont remember clearly.

Delete all kext of AMD/NVIDIA/INTEL and try

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×