Unable to boot into Yosemite after successful install - Hackintosh Yosemite - Hackintosh Zone Jump to content
tomincognito

Unable to boot into Yosemite after successful install

Recommended Posts

Hi all,

 

So near to a breakthrough but I need some help...

 

AMD FX 6300

AMD Radeon R7 260x

Gigabyte GA-970-UD3P

Existing Windows 7 on local HD

 

Using Yosemite 10.10.1 distro via a USB key, it seemed to install successfully to a seperate HDD but after restarting it just boots into Windows, and I can see in the UEFI/BIOS that boot priority has been altered so that my Yosemite HD is at the top.

 

I have booted into the USB and tried to select the Yosemite HD, and this looks right but when I enter the same bootflags as before:

 

amd64 -v npci=0x3000

 

...it says can't find systemlibrarykernelsamd64  and using HFSExplorer, I can see it's there! amd64 is there! If I can find it, why can't it?!

 

I did have the same error when trying to install, BUT I moved the 'amd64' file from the root of the USB and into systemlibrarykernels because that's where it was looking for it. Is that normal? I haven't found anyone else who had to do that but it worked for the install, annoying now it doesn't work to boot.

 

Can anyone please help?

 

 

Many thanks!

 

Tom

Share this post


Link to post
Share on other sites

Hi Tom;

 

My name is Tom as well. What are the chances? lol.

 

If you used /amd to boot the installer, then you do not need the kernel boot flag to boot Yosemite when finished. I have amd fx 8350. my boot flags for the installer were:

 

/amd GraphicsEnabler=No npci=0x3000 cpus=1 -f -v

 

Once installed my boot flags for Yosemite installation (and I use clover)

 

ahcidisk=1 debug=8 dmar=0 -force64 GraphicsInjector=No npci=0x3000 -v

 

I have 2 EVGA GTX 660s thus the GraphicsInjector=No, which is the same as GraphicsEnabler=No in chameleon. You may or may not need it depending on your graphics card. And you probably won't need the -force64. I have it for fun.

 

I had Windows 8.1 installed first, made hfs partition and installed yosemite on that. Used Bootdiskutility to install clover to usb. (Edit: I have both Windows 8.1 and Yosemite on same HDD)

And then copy the clover files and folders from that to the EFI partition on my Windows drive. Gives me the option to select Windows or Yosemite. Works well for me.

 

Note: When you use the flag amd64 OS X defaults to looking for the kernel in /System/Library/Kernels/

 

When you add a slash in front (/amd64) it will look for it in the root of the installer/installation

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $49.70 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Well, the pkg is beginning to install High Sierra on my SSD, but then stops with the error code "could not be installed on this computer" 
    • I followed your tutorials which seems to be 1000% easy as its usually around the same as TonyMac, except your installs requires less to do and youve done most of the work too the package which makes it installing for us very easy. Now, the pic below shows a whole bunch of errors and I dont know why. Ive searched these forums and just like the title here, there is none which is odd, because from your tutorials, this shouldnt happen and it seems no one else is running into this problem, HOWEVER, if they did post something like this, Im 1, looking for the fix on high sierra, not sierra or tammy or roger or lutherin, 2 they need to check their titles again because its not helping anyone. I will say I did try installing Sierra Hackintish Zone version and it works all the way up to right after it installs, it tells me "it cannot be installed on this computer", SO....sigh, idk       So, to conclude, I do appreciate the devs here and much respect. Thanks for doing this. But guys, please help a bruh out and tell me how to fix this. Im using windows 10 as my main so do not tell me to go to do nothing on a mac, its the whole point of me coming here is to hackintosh. I do follow instructions fairly           well consider I teach Programming to the Military. My god bless this post and.....my soul too tbh <3       
    • Hello, I want to know what I have to do to install Kexts, use clover configurator, install bootloader, change resolution and how to use multibeast according to my hardware. I'm new to this mac configuration process. For now my hackintosh is pure, with no driver installed wifi, ethernet, graphics etc .. Sometimes when I start hackinstosh gives the Kernel Panic and stops loading on the apple screen, but I reboot and load normally. And also after a few minutes using the macOS it freezes the screen. I used the Hackintosh Zone Niresh Sierra because it was the only one that successfully installed on my notebook. My hardware is: Notebook Samsung Expert x23 Intel HD Graphics 5500 I5-5200U Processor Nvidia Geforce 910M 2GB 8 GB RAM HDD 1TB Bluetooth
    • @Niresh Now i have another Problem! How do i get HDMI Video to work? I'm only getting a Black Screen when i try to connect a Monitor
  • Download Statistics

    • Files
      844
    • Comments
      2,012
    • Reviews
      2,512

    Latest File
    By 8osm3rka

    26    0

×