Nvidia GeForce GT 420M problem - Hackintosh Yosemite - Hackintosh Zone Jump to content
JanBures12

Nvidia GeForce GT 420M problem

Recommended Posts

Hi guys, I tried installing OS X 10.10.0 on my laptop Acer Aspire 5742ZG and while 10.9.0 worked perfectly fine (I'm a complete noob, I only first ever heard of osx86 on Friday, but thankfully I figured out how to get network - BCM57780 to work).

However in Yosemite I have a problem with graphics - first i couldn't even boot into the system after install - the screen turned off after 'DSMOS has arrived', i solved this by booting with /s and then using grafix backup all. When I got the system to work, the resolution was 1024x768 and animations were incredibly laggy. Is there a way to fix this? I tried installing Nvidia web drivers and nothing happened, also tried extracting GPU rom, putting it into /Extra and booting with UseNvidiaROM=Yes, didn't do the trick either (I boot using chimera). I also tried various other boot parameters I found, but nothing changed at all.

My configuration:

Nvidia Geforce GT 420M 1024 MB

Intel Pentium Dual Core P6200 2.13 GHz

4 GB RAM

Yosemite Zone Mac OS X 10.10.0 (Chimera bootloader)

Share this post


Link to post
Share on other sites

Hi, I have exactly the same configuration Acer Aspire 5742ZG. I installed niresh yosemite and went through the same installation process, used /s and grafix backup all to move the graphics kexts out, succeeded to boot into 1024x768.

 

As for drivers, I only managed to install nvidia CUDA drivers, but the CUDA interface in system preferences shows that nvidia gpu drivers are not installed. However, i couldn't get any of the current nvidia geforce mac web drivers to install (presumably because they aren't meant for a card as old as the gt 420m).

 

I also tried various bootflags but nothing has worked so far. Also set Graphics to 1366x768 in chameleon wizard, but nothing.

 

Finally, I tried to extract the GPU rom, for putting into the /Extra folder and boot with LoadVBios=YES (chameleon bootloader) but I couldn't get any version of GPU-Z (I have dual boot Windows 7 on another partition, and I run GPU-Z as administrator) to work. All GPU-Zs say that "BIOS reading is unsupported on this device".

 

I even tried dos booting with a usb stick to run various versions of nvflash --save xxxx_xxxx.rom but not even that worked. nvflash also said that everything was unsupported.

 

How did you manage to download the rom of this GPU? Did you finally manage to get the computer working in 1366x768 on Yosemite?

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $48.99 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Well thanks guys for help or say no help any way i fix everything by installing  High sierra everything works including hdmi audio also. So admin/moderator can you close/move this post?
    • hello all, i wonder if somebody did sucssesfuly installed ati drivers on one of polaris gpu on 10.9 10.10. or 10.11 mac? i find yesterday on some russian forum that they did some bios mods on polaris gpus on siera and high siera but i dont understand process. also no luck for kext emulator on phenom 2 cpu for siera and high siera i got rx560 sapphire 2gb and i tryed install mac but on gpu it said 8mb and graphic is awfull. everithing else works exept spdif output for audio and gpu. i cannot install siera or high siera because of unsupported cpu sse4.1 or sse4.2 my specs are asus m5a97 r2 evo phenom II 955 black edition x4 @3.2 g stock ram 3x4gb ddr3 @ 1333 underclocked because of cpu limitations rx560 sapphire 2gb 60gb adata sp900 2x500 gb wd blue (1x 2.5" , 1x 3.5") all your comments are welcome thanks
    • guys please help me .....................im stucked at apple logo while installing im using hp laptop core i5 7200u 6gb ram amd radeon R5 M430
    • I have working audio, graphics and network on this 10.13  Now store has sent me "security update" which I believe is 10.13.3.  Has anyone done this via store? What do I need to do before I install it? I have issues loading EFI so have to always manually mount it (Clover configurator and EFI mounter both fail) but using terminal and command "open /efi" I am able to mount and make changes to my config.plist too.   
    • Hi guys, I try to install Mac OS X Yosemite on my computer, but... i get stuck at the logo (when i boot it) + i see a bar, who won't charge. Can you give me a solution?   Processor: Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz (2 CPUs), ~2.0GHz Memory: 2048MB RAM    User DPI Setting: Using System DPI  System DPI Setting: 96 DPI (100 percent) Display Card name: NVIDIA GeForce 210  Manufacturer: NVIDIA Chip type: GeForce 210 DAC type: Integrated RAMDAC  
  • Download Statistics

    • Files
      848
    • Comments
      2,137
    • Reviews
      2,570

    Latest File
    By Vale1831

    13    0

×