Basic boot flags for the Macintosh System or Hackintosh Systems - Troubleshooting - Hackintosh Zone Jump to content
  • 1
HackintoshMumbai

Basic boot flags for the Macintosh System or Hackintosh Systems

Question

"GraphicsEnabler=Yes" This is needed for Intel HD 4000 installation.

 

"cpus=1" This may be needed for some 2011 socket

 motherboards and some laptop

 computers. TSC Sync should be selected for those 2011

 socket motherboards during install.

 

"UseKernelCache=No" This command is needed for 

 computers that freeze at any point

 (including "PCI Configuration Begin" line) 

 or computers that act weird this can be a CMOS reset

 or ignoring other SATA ports issue.

 

By entering this command, ElliottRTC.kext and modified IOPCIFamily.kext will be loaded during install.

 

"-v" Verbose mode. (Basically tells you wants happening  

 during boot up.)

 

"-x" Safe mode (Basically boots your system with the bare

  minimum kexts.)

 

 

"-s" = Single user mode. Command line only mode. Allows  

 you to run commands as root to fix system.

 

"-F" = Ignore boot setting in Boot.plist

 

"USBBusFix=Yes" This option is to fix USB related issues of

 some motherboards that can cause

 freeze or USB ports to fail.

 

"npci=0x3000" Computers that freeze on "[ PCI 

 Configuration Begin ]" line may try this command.

 

"ATIConfig=xx" "xx" is the ATI framebuffer name for target  

 model (search it on google). 

 This may be needed for some Intel HD 4000 + ATI gpu  

 computers to boot with "GraphicsEnabler=Yes" command.

 

Source 

http://hackintoshmumbai.blogspot.com/2013/02/basic-boot-flags-for-macintosh-system.html

Edited by HackintoshMumbai
  • Like 2

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
Hello friend I hope you can help me
 
my laptop is a compaq CQ 57_AMD
 
-I downloaded the 10.8.5 USB Niresh
-start with the intalation (amd64) is what could crank or start
intalation-after (- x) intalacion multibeash and other
* The empeso Problem with ethernet network not detected by testing my kexts
I were my alluda given me this error
mustro photos so you can see, and if you can help me
I have tried many flags (-v,-x,-F,-f, NPCI = 0x2000 and other more, always
hangs here
 
 

Share this post


Link to post
Share on other sites
  • 0

Hello, i tryed to install  OS X mavericks and an error ocurred 

"This version of Mac OS X is not suported in this platform"

"Reason ms-46gf "

I have and MSI GE60 Apache with intel i7, what i should do?

Regards

Edited by putoverde

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $49.70 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hi, Succesfully installed High Sierra. First time login with succes. After a restart the same login credentials were not accepted, so login failed. Login credentials were not changed! How to proceed? Thnx! H.    
    • Ok i tried right now. It started the installer. I did tools>disks and i tried to format one of my hdds in macos format and it gave me error. Then the hdd vanished. I went on win10 to format the hdd and have it back. When i went back to the bootable usb it gave me error. Here's everything https://drive.google.com/folderview?id=1JYkmjHA4AOaCnBa_aqkXZTyste9MVd2S   Edit: ok i tried to boot first the other partition of the usb (the not EFI one) and it got stuck like it did before. Now i booted the efi one and it's booting fine like before. I'm gonna check if i can initiate the hdd. Allright it booted and started some kind of configuration. I waited for it to end and I did a reboot. The problem is that the resolution is too low and i can't see properly Clover's window. What can I do?
    • @Niresh    it says  uhci controller  ehci controller setting legacy usb off on controller legacy USB off done   my motherboard is gigabyte EP43-UD3L can you help to set up bios as it is different from the pics posted    i am using the chameleon bootloader enoch r2839 could this be a problem?
    • I changed the config.plist but still I don't reach the installation menu. It freezes at Apple screen at 60% of progress. In chameleon way (the cmd like) it still says "host-level exception" trying to change values but don't go furthermore. What I can do?  
    •  there was a solution back in the day with mavericks. Well... unlucky. i'll fix the rest (Wifi, Sound and webcam(?) ) then update the main thread for others ^^' Thanks.
  • Download Statistics

    • Files
      845
    • Comments
      2,131
    • Reviews
      2,556

    Latest File
    By 8osm3rka

    21    0

×