Successful install OSX Niresh Mavericks 10.9.0 Dell Studio XPS 9000 /w Radeon HD 7870 Graphics - Installation guides - Hackintosh Zone Successful install OSX Niresh Mavericks 10.9.0 Dell Studio XPS 9000 /w Radeon HD 7870 Graphics Jump to content
Sign in to follow this  
Justin Aeon

Successful install OSX Niresh Mavericks 10.9.0 Dell Studio XPS 9000 /w Radeon HD 7870 Graphics

Recommended Posts

So I have been waiting for a while to get a working hackintosh together, I have been using AMD most of my adult life and had no success with my AMD FX in regaurds to building a hackintosh.  I just got got my hands on a Dell Studio XPS with i7 920 processor. 

 

I have been following Niresh on facebook, and one day I decided to try again, now with intel hardware to see if I could get things working.

 

I found out my Radeon HD 7870 has been supported since 10.8.3

.

So last night I started my first attempt with this machine, the install worked fine with no flags, but I had a deadbeef error (probably some sort of graphics memory error) on boot, decided to just go to bed and use my laptop for the night, followed by waking up and doing some research. 

 

I will skip what failed, and explain what worked for me.

 

I decided to reinstall when i woke up, this time disabling anything graphics related in the customize instalation menu.

 

The machine succesfully booted into OSX 10.9, but 30 seconds after boot, the system would freeze.

 

First thing was to update my bios to the newest version, I had no idea what my computer model was, but shortly figured it out and after two attemps found the correct bios firmware upgrade.

 

Still froze with current install and updated bios, did some more research. 

 

I decided to try installing again but with flags

 

I tried with flags "-x -v -f cpus=1"

 

not sure whats the flags mean as of yet

 

and made sure to disable all graphics options in the customize installation menu.

 

I am not 100% sure if the bios upgrade had an effect, but much to my amazement, the install finished, system booted.

 

It has been all day now, and I have what appears to be, full graphics "though i have not tested with gaming, i have no reslution issues with my Radeon HD 7870" and sound, "I am a musician and use a focusrite scarlette usb sound card".

 

So yes I am pretty happy, it has been all day, i have done multiple restarts, and so far I have had zero stability issues as of yet.

Share this post


Link to post
Share on other sites

Just tried to play a game, uhhh.  Lots of missing textures, I will definantely be dual booting windows for games, mac for art. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Donation Goals

    Hosting May 2018

    Please donate to support the community.
    We appreciate all donations!

    Thanks



    $35.82 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • I've added every kext possible, Lilu, IntelGraphicsFixup, changed my config settings nothing so far has worked. I tried asking for help on the tony mac forums, but was banned the minute I sent the progress report they asked for, for software piracy. (which makes no sense because any hackintosh is software piracy anyway) but regardless of that, I still have very choppy graphics, and only 4 mb of VRAM, as shown in the about my mac screenshot I linked below. Can anyone help?
    • Hi, 
      I finally decided to install macOS high sierra on my laptop - Lenovo IdeaPad 720S 15IKB.
      It has:   i5-7300HQ, Intel HM175
      12GB DDR4 RAM
      A Samsung 256GB NVMe Drive
      GTX 1050 Ti With Max-Q   The first try did not boot so i had to use some args to get it to boot. The first problem arises due to the fact that all available usb slots are usb 3.1. The installer did not recognise my keyboard and trackpad and i had to install some kexts to get them working. Well, after i intalled the kexts, It was stuck in a boot loop. I was fed up and it was late so i decided to download hackintosh zone from niresh. I would install it later. Well, when i run hackintosh zone it gets stuck at the apple logo after loading. I ran it in verbose mode and it gets stuck in the following   [Date] localhost com.apple.xpc.launchd[1] <Error>: Host-level exception raised: pid = 541, thread = 0xbf1f, exception type = 0xd, codes = { 0 }, states = { 0 }
      busy timeout[0], (240s): 'AppleEFIRuntime'
      busy timeout[1], (240s): 'AppleEFIRuntime'
      busy timeout[2], (240s): 'AppleEFIRuntime'   Then the screen goes blank and it starts over. Any help is appreciated. Thanks!
    • ASUS laptop X550D can run hackintosk ? help me ! please!!!   thanks alot
    • Oh, thank you but in the meantime I thought again and have installed High Sierra instead. It works just fine, put a camera, bluetooth, wifi, all working OK. I only have to solve a little problem when doing restart it freezes but after shutdown it comes up good! I have also Win7 on same mbr disk and I start with the installation usb but I think go over to EasyBCD to make a smoother boot. If your experienced I would appreciate very much any hints for helping me in this direction. 
    • Hello people!😃   I am new to the hackintosh community. I have a old pc at my home running windows 10 pro. Its a Pentium Dual Core 1.6ghz Processor. A 250mb intel HD i-gpu. (No dedicated Graphics card). A 2gb DDR2 ram. 160gb HDD.   Can i install any mac distro on it ?   I don't want to edit videos on it. I just want to start hackintoshing from this, than my laptop & than my friends laptop. Untill i master this art ☺.   Thank you.
  • Download Statistics

    • Files
      852
    • Comments
      2,144
    • Reviews
      2,600

    Latest File
    By Niresh

    542    0

×