Hackintosh Installation Ended up with errors like running scripts from the package, Undefined error: 0, - Hackintosh Yosemite - Hackintosh Zone Jump to content
RohanKailthya

Hackintosh Installation Ended up with errors like running scripts from the package, Undefined error: 0,

Recommended Posts

Hello! Firstly I want to thanks Niresh for his brilliant work to make the installation of Hackintosh so easy for the beginners. 

 

Now, as a beginner I am facing some damn problems and after trying for a week I was unable to solve the problem and hence I am posting here for a solution or suggestion...

 

I am trying to install OS X Yosemite 10.10.1 (niresh distro) and due to some restarting problem at PCI Config Begin, I had to use 'npci=0x2000' or 'npci=0x3000' additional bootflags in my amd processor. Then the installation runs fine but at the very end it showed 'OS X couldn't be installed on your machine' with an error of “running scripts from the package ‘GraphicsEnabler.pkg’ ”, so I unselect the graphics kext from the customization area and the error was changed to “running scripts from the package ‘something_else.pkg’ ”…

 

Hence, I unselect many unnecessary kexts in the customization screen like graphics, sound, network etc and then the installation was ended up with something like "Unable to build boot cache", after that I did some more experiments on the customization tab and then the installation finally ended up with "Undefined error: 0", Now seriously, WTF? 

 

Niresh, any ideas? This seems to be a consistent and reproducible problem, Please give me some suggestion about that problem, any type of advice will be highly recommended. Thanking you. 

 

Here is my Config (I know poor):

 

Processor: AMD FX-4100 Quad core

Graphics Card: AMD Radeon HD 5450

Motherboard: Asus M5A78L-M LX V2

Ethernet: Realtek® 8111E , 1 x Gigabit LAN Controller(s)

Audio: Realtek® ALC887 8-Channel High Definition Audio CODEC *2

 

**Installer Log and screenshot attached. 

 

 

post-202001-0-42123600-1428604700_thumb.

Installer Log 04-09-15.txt

Share this post


Link to post
Share on other sites

Same thing happened to me, try and reboot with -x -v -f. If it boots then your good, if not try running NPCI=0x3000 or NPCI=0x2000 with those other flags.

  • Like 1

Share this post


Link to post
Share on other sites

./postinstall: Partition Scheme is MBR
./postinstall: Partition Scheme is MBR

./postinstall: Volume Mac OS X on disk0s7 force-unmounted
./postinstall: ** The volume could not be verified completely.
./postinstall: Volume on disk0s7 failed to mount
./postinstall: If the volume is damaged, try the "readOnly" option

 

Is there any reason why you're using the MBR partition scheme? Otherwise I'd advice to format the harddrive as GUID ('options' in the disk utility, when creating a partition).

  • Like 1

Share this post


Link to post
Share on other sites

The problem was solved by formatting the whole drive.... the problem was not with the MBR/GUID style, actually I tried to install OSX to a Logical drive :P and for that reason I was getting the error. 

 

BTW after fixing the graphics problem with some weeks of research, now I am facing another issue, ie the Ethernet problem and booting and shutdown problem. 

 

The Ethernet (Realtalk 8111E) is not recognized at all, I installed some kexts for that and also tried the all in one Ethernet solution but nothing seem to be worked for me, Is there something else to do about that? 

 

The booting process is damn slow, It takes about 1 minute and 12 secs to boot up (every time) to the login screen and the shut down process is not also correct, the hackintosh is shutting down almost instantly without any shut down screen... How to solve these disgusting problem??? 
 

PS: I use npci=0x3000 as the boot flag, tried KernalCache=Yes but not worked. 

 

Any suggestion will be highly appreciated.  

 

@ @

 

Update: The Ethernet problem was solved by using ViaRhine-64Bit kext (My card was not really realtek, actually it was replaced by some Dlink card) but I am still stucking at the boot issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $62.51 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hello! I made my usb key with transmac but when I start OS X Sierra everything goes well, the installation too but the installation blocks at 100%, time remaining: less than a minute. with it worked but not anymore. can you help me? My PC : it is a laptop: ASUS X751LD the motherboard I do not know, the hard drive I do not know but it's a HDD of 500 gb I have two graphics cards: Intel HD 4400 and Nvidia 820m, (which blocked me for the installation of Yosemite and High Sierra) thank you in advance.   PS : Sorry for my bad english i'm french ^^.
    • Hello! Yesterday I successfully installed Yosemite (Yosemite Zone distro) on my laptop (Sony Vaio FIT 15E with an i3-3217U). The only thing that doesn't work is the wifi card (BCM43142). I found in my house another wireless card, AzureWave AW-NB047H. Is this wireless card compatible with macOS?   Sorry for my bad english and thanks in advance. ~IOStream
    • i have installed sierra on my acer aspire e14 e5 - 475G 59C7 with processor i5-7200u 2.5GHZ  nvidia geforce 940MXX 2GB  4GB DDR4  when i install i disabled "move nvidia.pkg" "ati.pkg" "intel.pkg" installed works, but when i type something it gone too far. for example i just type "a" in 0.5 seconds it shows "aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa" anyone know how to fix this?        
    • Hello,
      On High Sierra 10.13.1 under VMWare.
      I install Final Cut Pro 10.4 when running got this error:
      This graphics configuration does not support hardware acceleration, which is required to run Final Cut Pro.
      My GPU is: AMD Radeon R7 240 but show on Hachintosh About : Graphics: Display 128 MB. Thank you for help.
    • I got same error 4 years later. On High Sierra. What's the solution? What you suggested doesn't work. Why does this happen? Any ideas?
  • Download Statistics

    • Files
      848
    • Comments
      2,137
    • Reviews
      2,570

    Latest File
    By Vale1831

    15    0

×