Missing Bluetooth Controller Transport, Resolution, Lag, Ethernet (Solved) Graphics Glitches (Unsolved) - OS X Yosemite Zone Hackintosh 10.10 - Hackintosh Zone Jump to content
  • 0

Missing Bluetooth Controller Transport, Resolution, Lag, Ethernet (Solved) Graphics Glitches (Unsolved)


MacZone    1

Hello, I'm currently having issues with Yosemite Zone. At this point I've tried just about every solution I could find for days. The installation seems to have gone smoothly multiple times, even with customized options. My issue occurs when trying to boot after the installation, it gets stuck on missing bluetooth controller transport. From everything I've searched it's a graphics card issue.


Like I said before, I've tried just about everything I could find especially countless bootflag combinations. I also tried using the kextload command to load FakeSMC.kext per a suggestion I found, also tried the following:


"mount -uw /

cd /System/Library/Extensions
mkdir intel_back
mv AppleIntelHD* AppleIntelF* intel_back/
touch ../ExtensionsReboot -v"
AppleIntelHD* and AppleIntelF* couldn't be renamed because they aren't in that location.
At this point I don't know what to do anymore and I could use some solutions I've yet to try. Thanks in advance.
CPU: AMD FX-8320
GPU: XFX AMD Radeon 6750 (DDR3 version)
MOBO: Gigabyte GA-990-FXA-UD3
LAN: Realtek RTL8111E chip
Audio: Realtek ALC889
Did some more searching and took it one step at a time solving any errors that came up.
Re-installed with /amd1 npci=0x3000 debug=8
Got it to boot with: -F -v npci=0x3000 debug=8 PCIRootUID=1 dart=0
-F (bypass any bootflags included with installation)
npci=0x3000 (fix stall at [PCI Configuration])
debug=8 (fix stall at debugger error)
PCIRootUID=1 (fix stall at Missing Bluetooth Controller Transport)
dart=0 (fix stall at Yosemite login screen)
Now on to the fun stuff... If anybody can link me to instructions on further setting up Yosemite I'd really appreciate it. It took long enough to get this far.

Share this post

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
MacZone    1

I've solved my main issues so far. I've also successfully installed my M-Audio FireWire 410 Audio interface without an issue, and I also have dual monitors running on HDMI and DVI.


Right now my problem is with the low resolution of 1152x864. I'm trying to figure out how to set it to the resolution of my two monitors 1600x900. I've went into org.chameleon.Boot.plist and changed the Graphics Mode value to 1600x900x32, but it didn't change anything. I don't know if this is related but Yosemite is running very laggy, and I'm getting slight graphic glitches here and there.


*UPDATE*: My GPU is now working at a 1600x900 resolution with proper dual monitor functionality. In order to get the XFX Radeon HD 6750 (DDR3 version) working I used the Radeon 5750 drivers provided right here on Hackintosh Zone: 


First, make a copy of the "AMD5000Controller.kext" and navigate to AMD5000Controller.kext > Contents > info.plist. Now locate: <key>IOPCIMatch</key>, and add your Device ID along with the last four digits of the vendor in the string. To find your Device ID and vendor number go to About This Mac > System Report > Hardware > Graphics. Add the last four digits in vendor to the Device ID, in my case it was "0x68bf" and "1002" so I put them together for "0x68bf1002". Now use Kext Utility to install the edited AMD5000Controller.kext along with the other 5 uninstalled kext files included in the download.**


Another issue I'm having is getting ethernet working. I've installed the drivers for the RealtekRTL81xx and RealtekRTL8111 but it seems those don't work for my RealtekRTL8111E chip.


*UPDATE* My ethernet is now working, to get RealtekRTL8111E working I used MultiBeast. You'll find the working driver in Multibeast under Drivers > Realtek > AppleTRL8169Ethernet 2.0.6.**

Share this post

Link to post
Share on other sites
  • 0
MacZone    1

At this point my Hackintosh is running pretty well. I've solved most of my issues and provided information for anyone who needs it.


My only problem is white graphic glitches. I get flashing white lines across my screen, videos, and some websites. This issue is especially present in Chrome and during the login screen. I'll probably figure it out before I get help, but if you want to chime in and help me out I'd appreciate it.

  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Hi guys, managed to make a hackintosh and everything is going great (Wifi, cpu ECT)   But it's pretty damn slow, i tried one of my favorite lightweight games to test (The Ultimate Doom) and it could barely run THAT! This is my first time and i have no idea how to get my 8570 to work.. Probably should have read a bit, eh? Lol.   And no I don't plan on using my hackintosh for gaming, but god so slow..   Thanks, help would be very appreciated. Edit: It's the dedicated version btw, and in about my mac I see "Graphics Display 3 MB" maybe the issue?  
    • Trying to boot to the installer but I get instant reboot after the following: I am using the following flag (I tried a variation - I need USBBusFix=Yes otherwise it fails even earlier): All my USB devices turn off just before it reboots, so I'm guessing it loses connection to the USB install media - but I can't work out why it's disabling all the USB's. My motherboard is an AsRock Killer Fatal1ty 990FX.
    • Saludos!   Tengo el mismo error (RAM a 667mhz), con una placa base ASUS (y mi cpu es el fx 6300).   Lograste solucionarlo?
    • Hi guys. Well, this is my second day of troubles, I touched everything, I installed max like 5 times in the same day, trying to figure out things and well. My Mac it display my graphic card on the #About this Mac tab With 2047MB ( So I guess all is right ) I installed the latest nvida drivers and on clover I activated the NvidaWeb. The problem is the resolution. Max resolution allowed is 1280 x 1024 and 800 x 600. I used to boot with nvd_drv 1 with nvd dry 0, I used to boot with all that things, and without them.  BUT No way to fix the resolution. Someone knows what-s going wrong and how can I fix it? Bdw im using iMac14,2 and OS X Sierra 10.12.3 Im connecting to the screen with DVI adapter. ( Maybe that causes the problem ) But it shows Im running 2047 MB so... idk why I can't change resolution. Thanks! ================================= SOLVED EDIT: Hi guys, in Display Resolution, I just set it in "Default for display" and after that pressing "THE WINDOWS BUTTON KEY, IN MY CASE, IDK WHAT KEY IS THAT IN MAC KEYBOARD, I THINK THE CONTROL ONE OR IDK" PRESSING that key I selected Scaled, and it appears more options and resolutions. There is a video on youtube about that called "Mac OS X Display Resolution" If someone has the same trouble.
    • Hello , i have a big problem , help me please, i have installed properly Mac OS Sierra , but now i can’t boot Windows 10, when i click on a image , which has written for example boot Windows from legacy hd3 , it blocks on an image with the Apple sign on an hard disk image, and when i enter the bios i can’t see tue hard disk in boot options, how can i add Images? Pleaseeeee
  • Download Statistics

    • Files
    • Comments
    • Reviews