Gfx cards not working (GTX 650 and 960) - Hackintosh Yosemite - Hackintosh Zone Gfx cards not working (GTX 650 and 960) Jump to content
emaxxx4

Gfx cards not working (GTX 650 and 960)

Recommended Posts

Hello. I successfully got Niresh's Yosemite build on an AMD for the first time (yay!) using an Asus M5A97 LE 2.0 and an AMD Athlon II X4 630. At the same time I'm also trying to get a new video card working on my main system, a Gigabyte Z68AP-D3 w/ intel i5-2400. The current system uses an EVGA GTX 650 2 GB card and runs TonymacX86's software successfully (both Mavericks and Yosemite install - Yosemite shutdown issues). I recently purchased a Gigabye GTX 960 G1 gaming video card and am running into issues with it on both boards.

 

Issue 1 - I was using the GTX650 to install Niresh on the AMD board (Asus M5A97), but eventually wanted to use the GTX960 (since I'm having issues on my main board, but at least want to see if the issue is because the card is too new or some incompatibilities with the niresh installer). I was able to install it successfully, but has to use the flag "npci=0x3000" to get past the PCI Configuration begin saga. When I do, graphics are very slow, and the profiler only shows a 7 MB card instead of 2 GB.

I looked at many threads and know to use the nVidia updaters for the current graphics systems, and that the 10.10.3 update should fix a lot of issues. I was able to upgrade to 10.10.3, but at the boot disk selection screen and selecting my hard drive, it would look like it would boot, then it would shutdown. No flag I tried would fix it. I also read in a few places that I should set my machine as a MacPro5,1 which I did.

 

Issue 2 - I was able to reinstall Niresh's Yosemite again to the same drive while the brand new GTX 960 was in the Asus M5A97. I was able to get Yosemite reinstalled, but am leaving it at 10.10.1 for now. I also see I have very bad graphics, and this time at only 3 MB (with the GTX 960, what-what-whaaat?). I know there are other flags like nv_disable=1, nvda_drv=1, and dart=0. They have worked, but no matter what I still can't seem to get full graphics. because of the issues the first time I'm hesitant to try the 10.10.3 update.

 

Issue 3 - I have Mavericks installed on my main machine (Z68AP-D3) but was using an external USB hard drive (WD My Passport) to hold Yosemite using UniBeast and MultiBeast (Im using a UEFI, so I don't need a DSDT). With the GTX 960 graphics card, I would have to enter "nv_disable=1 -x" when booting to either drive. Using trial and error, sweat and tears, I was also able to get the external Yosemite drive updated to 10.10.3 along with the latest graphics, but I still have to use the ""nv_disable=1 -x"" flags which result in slow graphics and only shows 7 MB rather than 2 GB. What can I do to get the graphics cards working to their full potential?

 

I'd rather have the GTX 960 in my main machine, and have no preference as to using Niresh's or tonymacx86s install methods, but really whatever is more stable. I lean toward Niresh's because I put it on another drive earlier to test and was able to get a complete shutdown, whereas using the tonymacx86 method, the hardware would motion that it was shutting off, but the lights and fans remained on. I would want to use the GTX 650 on the AMD board where my current Niresh Yosemite is at, but also have the same issues with the graphics slowdowns.

 

PS. Also, where does one get the NVidia installer (shown in the screenshot below)? I came to the conclusion that it was only available on Mac Pros, which is why I changed my system definition on both the my Passport Yosemite and AMD board hard drives, but neither system shows the control panel to enable this. My i5 does not have on board graphics, and I don't know if my AMD Athlon has on board graphics or not. I prefer to use video cards instead. Thanks for your help!

 

post-208922-0-10432900-1429745819_thumb.

Share this post


Link to post
Share on other sites

Thanks for this info man. I've actually tried using a GTX 650, and currently trying GTX 960. Unlucky huh! This will really help me out to getting it installed. I'll post when I get it working on the 960 (I will.). Hopefully it'll help you out!

Share this post


Link to post
Share on other sites

I too have a msi gtx 960 i want to get working as soon as i can even get my post to boot first lol, but do you have the unofficial web driver installed from nvidia? Thats what i plan on doing. For 10.10.3 here, 10.10.1 here, I don't believe there's GTX 960 support for the 10.10.1 version but 10.10.3 and up there  apparently is. If your unsure go here. So an update might be required in order for you to get full/more hardware acceleration of the gtx 960. Just make sure flags are still as appropriately used when needed, such as the nvda_drv=1 and maybe also try GraphicsEnabler=yes. Im gonna test this myself and post back results. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting May 2018

    Please donate to support the community.
    We appreciate all donations!

    Thanks



    $148.22 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • Affter install High Sierra Zone in: Gigabyte H110m / i3 7100 In first reboot working the graphics but no USB drivers / External USB disks i cant mount clover In the secod reboot have problem, the solution -disiablegfxfirmware ane boot whit config, but hace the same problems, dont see the usb drivers and can not mount uefi partition In other reboot see diferentes config, i try diferents, boot with config_uefi without flags, but when run the graphics dont works but i see the usb drivers and external disk and mount the uefi driver. how repair this? boot with config and fix everting or boot with config_uefi and fix graphics?   sorry my inglis is not god
    • Dear Guys,
      Im trying to install mac os x sierra in my dell laptop and ihave followed all the details and reached the installation part. But im getting error saying "An error occurred installing macOS.To use apple diagnostics to check your mac hardware"
      Guys please please help me with it.ithink im almost 90% close to installing mac os. my lap config as follows.the person who help me resolve will be my hero  Motherboard: INTEL i3 370M 2.40GHZ,0KRP5X CPU: DELL N4030 MODEL. Graphics: ATI Mobility Radeopn HD 5430 Motherboard:  
    • i did one but no hdmi or display port sound even if they are detected processor neither no wifi   and install a multiboot ? i triyed clover but didnt work    
    • Hey can some one help me with a problem https://ibb.co/jv8TRT this is my problem I hope you can help me guys
    • Hi
      I followed Nirav's High Sierra installation guide.
      My problem is that I am getting the below error at the install boot screen (osxAptioFix2Drv:Starting overrides for System\Library\CoreServices\boot.efi
      Using reloc block: no hibernate wake: no)


      what I should to do?

      my specs:
      Asus Rampage VI Extreme 
      intel Core i7 7800x
      Samsung 960 EVO SSD 250 
      Gigabyte GEFORCE GTX 1080 TI Gaming OC
      GSkill TridentZ DDR4 8x2 GB
  • Download Statistics

    • Files
      849
    • Comments
      2,144
    • Reviews
      2,627

    Latest File
    By ka209

    122    0

×