Hackintosh on Virtualbox (Linux host) - Hackintosh Yosemite - Hackintosh Zone Jump to content
fernan82

Hackintosh on Virtualbox (Linux host)

Recommended Posts

I'm trying to install on VirtualBox using the Yosemite iso from this site. I followed this howto: http://www.macbreaker.com/2015/01/virtualbox-yosemite-zone.html. The VM crashes as soon as the grey splash screen comes up. Here's the virtualbox log: https://bpaste.net/show/353728833a6a. I also tried the mavericks iso and I get the same error. I tried on VMware and I get an error about the CPU being disabled by the guest. On QEMU I don't get any errors but it hangs right after the splash is shown. I also downloaded a Mountain Lion vmware image from somewhere else and it gives me the same result. I tried different VM settings and boot options and at one point it seemed to boot but it never loaded a GUI, just a terminal that showed syslogd messages.

 

My virtualbox version is 4.3.26.

QEMU: Tried 2.2.0 and 2.3.0

VMware Workstation version 10.0.3.1895310

Linux kernel version: 4.0.1 on Gentoo

CPU: AMD A4-1250 APU with Radeon HD Graphics

Video: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8210]

RAM: 4GB (2 for the VM)

Network: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter

Share this post


Link to post
Share on other sites

Hello,

I have inform at some threads about success with VirtualBox Yosemite.

I am using VirtualBox Yosemite up to 10.10.2.  For installation I follow: http://www.macbreaker.com/2014/05/os-x-mavericks-in-virtualbox-with-niresh.html

Some details is impotent from:https://www.hackintosh.zone/forums/topic/5064-virtualbox-yosemite-install-stuck-at-2-minutes-left/page-12

For me only stuck at shotdown is a problem.

Good luck
 
 

Share this post


Link to post
Share on other sites

Thanks for the reply. That's pretty much the same as the howto I was following, it has more stuff but I never got that far.

 

I saw another post where somebody mentioned problems with virtualbox 4.3.x so I decided to try 4.2.x but I had to downgrade my kernel to 3.18.13 in order to compile the virtualbox 4.2.x modules. After booting the new kernel I decided to try once more with virtualbox 4.3.26 and to my surprise it booted without problem.

 

I suspect it's not related to the new kernel but since I remember seeing a bluetooth message just before it crashed a few times it may be that I misconfigured the new kernel and the bluetooth driver is not working. I'm supposed to compile the bluetooth driver as a kernel module but I compiled it built-in and since I don't have the firmware for it on my initrd the driver fails to load. It's installing right now. After it's done I will rebuild my kernel with bluetooth support to confirm if that was the problem. Thanks.

Share this post


Link to post
Share on other sites

Hello

Only inform that I updated my VirtualBox Hackintosh to 10.10.4 without any problem.

Best regards to all

Share this post


Link to post
Share on other sites

Hello

Only inform that I updated my VirtualBox Hackintosh to 10.10.5 without any problem.

Best regards to all

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $62.51 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • bought 3 laptops costs about 2000$ more to just install this hackintosh and 3 of em is unsupported.  i think i am done with hackintosh
    • Hi, I have a HP G61-415ES with this configuration:
      Intel Pentium T4300 Dual Core 4GB RAM NVIDIA GeForce G 103M My Wifi card is AR5B95 (aka. 9285), and yes: works well with Windows, isn't broken. The thing is, I succesfully installed Niresh 10.8.5 and works perfect, but I tried and tried to get WiFi conection (no Wifi icon on status bar, no Wifi on Network settings)
      I tried installing io80211family.kext, RehabMan-Atheros, toledaARPT.kext and nothing. No icon, no settings... Also I read something about patch DSDT but I don't get nothing clear about how to use or how to patch, all guides are too complex for a person that don't have knowledge of that things. Also a lot of files fo download are missing and a lot of links to get reference are broken, and that increase the complexity of the problem.
      I have a PowerMac G5 MOD working very well, but obviosly I made with the ¨Buyer's Guide¨ and I didn't got any major trouble, but with this laptop it's guiving me headache
      I don't know what to do now, I'm reinstalling again 10.8.5 but I don't have more ideas.
    • hi,JacoboBlandonPineda                 I HAVE SOME IDEA TO HACK A PC WITH THESE KIND OF PROCESSOR .VIEW THIS VIDEO      Twitter    
    • I tried to install mac os on new ssd drive from usb. It boot up from usb , but i wasn't able to select the installation destination. It was only showing external devices.  Even in terminal it was only showing external usb drive's partitions only. Please Help me! i'm using  intel core i7-7700 HQ @ 2.8GHz 16gb Ram toshiba 512gb ssd and samsung 960 EVO ssd intel hd graphics 630  nvidia geforce gtx 1070 max-q  
  • Download Statistics

    • Files
      848
    • Comments
      2,137
    • Reviews
      2,570

    Latest File
    By Vale1831

    18    0

×