HP Envy dv4 Intel HD 4000 Ivy i3 - Can't get the display to work after install - Hackintosh Mavericks - Hackintosh Zone Jump to content
Justin Thiel

HP Envy dv4 Intel HD 4000 Ivy i3 - Can't get the display to work after install

Recommended Posts

Hey guys, I'm pretty new to the Hackintosh world and loving it so far! I had 10.8.2 working almost flawlessly.. But I want the new Mavericks. I can boot the installer perfectly with just the "HP -v " boot flag, but after it installs I can't get my laptop's display to work unless I use the -x boot flag and go into safety mode. That's a problem for me because in safety mode my USB ports don't work and my wifi adapter won't work…..or Audio of a voice telling me about os x and voice assistance...

Share this post


Link to post
Share on other sites

I didn't install any extra graphics kexts in either... On 10.8.2 all I had to do was go into Champslist and change the resolution. After that everything looked great. On 10.9 I can't even get the display to work unless I boot into safety mode... Is there a kext that will fix this issue?

Share this post


Link to post
Share on other sites

[NEW] 10.9 Intel HD 3000 & HD 4000 Driver

 

How To Install & Your Need Packages:

 

1- Install & Boot OS X 10.9.

2- Download & extract this files.

3- Download & install lastest chameleon from www.osx86.net orwww.insanelymac.com or www.onehalfkiller.com minimum chameleon 2.2 r2265+ (or newer) )

4- Download lastest kext utility from www.osx86.net

5-1- Extracted kexts copy and paste to /System/Library/Extensions and click change, okay (enter password) and open kext utility.app and enter password and click okay than see enjoy and click quit button and restart.

5-2- Or Extracted kexts drag and drop to kext utility.app and enter password and click okay than see enjoy and click quit button and restart.

 

Important:

 

Working on: HD 3000 graphics on 7-series motherboards & HD 4000 on 6-series motherboards:

 

7-series motherboard (B75/Z75/H77/Z77) + 2nd gen Core-i "Sandy Bridge" CPU using HD 3000 graphics

 

6-series motherboard (H61/H67/P67/Z68) + 3rd gen Core-i "Ivy Bridge" CPU using HD 4000 graphics

 

This driver only Intel HD 3000 & HD 4000 GPU Models - Lastest chameleon bootloaderauto detect your gpu no need enabler."

 

Note 1 : Resolution & refresh rate change perfectly work and glass menubar = %100 working your Intel HD 3000 & HD 4000 card.

10.9_Intel_HD_3000_&_HD_4000_Driver_by_KemalALKIN.zip

Share this post


Link to post
Share on other sites

Well, I put the file on a USB but I can't get the USB to work in safe mode..Quick question that maybe you could answer for me.. The way I can get it to boot is with the flags -v -x GraphicsEnabler=NoIs there some reason why my display will work in safe mode, but not outside of safe mode? It seems that maybe I just have to delete a kext or something, because my display looks perfect in safe mode so somewhere in the system it must already have the file it needs to display correctly.. No?

Share this post


Link to post
Share on other sites

Well, I put the file on a USB but I can't get the USB to work in safe mode..Quick question that maybe you could answer for me.. The way I can get it to boot is with the flags -v -x GraphicsEnabler=NoIs there some reason why my display will work in safe mode, but not outside of safe mode? It seems that maybe I just have to delete a kext or something, because my display looks perfect in safe mode so somewhere in the system it must already have the file it needs to display correctly.. No?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $49.70 of $120.00 goal reached.
    Donate Now
×