Get iCloud, App Store and iMessage working on Mac OS X 10.9 Mavericks! - Installation guides - Hackintosh Zone Jump to content
  • 0
Berto Delacruz

Get iCloud, App Store and iMessage working on Mac OS X 10.9 Mavericks!

Question

iCloud & App Store fix:
 
Download this file: http://cl.ly/2s3Y0K1n0d2g2s222V1P
 
 
1. Go to system preferences, network, click on the Ethernet network adapter, click the minus button at the bottom, hit apply. 

 
2. Go to /Library/Preferences/System Configuration/NetworkInterfaces.Plist and delete it or move it somewhere else. (just in case)
 
3. Open up EFI studio, change device to Ethernet, then click add device.
 
4. Copy this: 
 
<key>device-properties</key>
<string></string> 
 
5. Paste that in your org.Chameleon.boot.plist file which is located in /extra/org.chameleon.boot.plist. The key and the string match up with the others. Go back to the EFI  Studio editor.
 
6. Copy the long number at the bottom and paste it in between the two strings in your chameleon boot plist file.
 
7. Save & Restart 
 
8. Go in to system preferences, then network, then click the plus button at the bottom. 
 
9. Click add in the window that pops up. It should say "Ethernet". If it has "en1" or "en0" after it, then repeat the above steps.
 
10. After adding that hit apply and restart one last time. 
 
11. Go to Safari to check that you're getting internet connectivity, then continue signing into iCloud and/or the App Store!
 
iMessage fix:
 
1. Install Chameleon
 
2. Install the: http://www.mediafire.com/?5grtpcmih94qnkz
 
 

    •  
    • Go to your /Extra folder --> Create a "Modules" folder without the quotes if you haven't already got one
    • Drag and drop the FileNVRAM.dylib to the Modules folder
    • Reboot and sign in to iMessage!


     
     

  • Like 2

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Done it 1000 times, "Unable to sign in because of a problem communicating with iCloud. Try signing in again."

also messed up, my working iMessage  :tongueout: .

Any help to why this is happening?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $49.70 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hello, First of all, I'm starting with my pc configuration,    Processor: Core i3-6100 Motherboard: G1 Sniper B7 with 8GB Ram. GPU: AMD Radeon R7 370 So, I want to make my PC in Hackintosh. Is it meet Hackintosh compatibility? And which version should I go with like( Sierra, High Sierra etc.) with Process? I need your help. Thanks in Advance                                                                                                                                                                             
    • I wasn't being lazy, I looked through my whole bios and I couldn't find all the setting you are telling me to change, but I still found some of them. Once I change the settings, what should I do?
    • When I unzip Restore High Sierra I just get the .pkg. I'm not about to install the pkg on my main HD unless I know what it's going to do. 
    • Niresh, first of all, thank you for your help. I can't disable the NVIDIA GPU, even on the BIOS settings, there is no such option. I have even looked on the manufacturer help fórum, there is nothing in that regard. Is there a way to make these DSDT patches on your release? Could you make a guide or a video of it? I tried looking at some guides on tonymacx86.com, but it's too complicated for me (and also, I don't have a running version of MacOS on my computer). https://www.tonymacx86.com/threads/fix-window-server-service-only-ran-for-0-seconds-with-dual-gpu.233092/ https://www.tonymacx86.com/threads/guide-dell-inspiron-14-7460-series-7000-uefi-hotpatch.236039/ 
    • And about the SMBIOS, can you tell me about it?  cause, i dont know what is that for. and where can i find that thing? And the /haswell boot-arg, do i have to enter it everytime that i want to boot in Mac OS X? (Also thanks for the help about the graphics again.) (tries again) I tried t install but kernel panic. i ut the haswell boot flag and verbose mode. 
  • Download Statistics

    • Files
      845
    • Comments
      2,132
    • Reviews
      2,557

    Latest File
    By 8osm3rka

    24    0

×