EXC_BAD_ACCESS (SIGSEGV) with iTunes and Safari, also Graphical errors in pictures - OS X Yosemite Zone Hackintosh 10.10 - Hackintosh Zone Jump to content
  • 0
Sign in to follow this  
EdHardwood

EXC_BAD_ACCESS (SIGSEGV) with iTunes and Safari, also Graphical errors in pictures

Question

EdHardwood    0

Hi there, 

I'm fairly new to the OS X scene, and brand new to the hackintosh scene, having managed to install Niresh's 10.10.1 Distro for the first time on Sunday, and have been playing about with it since. I've got a few problems that I've encountered, and have tried many different ways of fixing them, but I am still struggling, and I'd appreciate any assistance, or pointers in the right direction!

Specs:

AMD Phenon II X4 945

MSI 785G-E53

Nvidia GTX 460

2x 4GB 1333 DDR3 ram.

 

The first problem I encountered was iTunes crashing after I updated it to the latest version. Thinking it may have been a bug with that version (it worked on fresh install), I tried the previous two versions as well, yet I received the exact same error.

Error Log Paste Bin

  1. Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
  2. Exception Codes:       EXC_I386_GPFLT

Which is the common error I receive for most app crashes, including Safari sometimes, but it's running stable now (no idea why), so I cannot produce an error log for that. I could easily re-produce a safari crash by highlighting text, and extending over the "border", and it'd crash 100% of the time.

EDIT: Managed to get Safari to crash
Link to Error Log

Another problem I've got is strange graphical artefacts on some images, and only when using default OS X apps, so an image that'd have a problem in preview/Skype, would work in VLC.

Phone photos of screen as screenshots were not working.

I also have strange text errors in Chrome, where the fonts do not display correctly, and most web pages crash.

LINK

Sadly, I could not get a better pic than that as all the web pages I tried to load would crash.

 

Steps I have tried to fix the problem:

  • Reinstall OS X with /amd /amd1 /amd2 /amd64 boot flags, where I get the least issues when I used the /amd bootflag.
  • Install Nvidia Web Drivers, multiple versions
  • Arny Cutez's forum "guide" on patching OS X after install (P.S. That was before I found out about the /amd1 and /amd2 bootflags, but I have gotten the best result out of the /amd bootflag with his guide)
  • Swapping RAM in and out, trying different combos of chained and unchained etc.
  • Trying a different HDD (was not a step in my trouble shooting, but I feel it should be mentioned that it's been done)
  • Fiddled around in BIOS a bit, but had no luck
  • + a few other minor things that I can't think of off of the top of my head

 

Thanks so much for reading my wall-o-text, and I hope it's a simple solution where my google-fu has failed me!

 

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Download Hackintosh

  • Files

  • Posts

    • Saludos!   Tengo el mismo error (RAM a 667mhz), con una placa base ASUS (y mi cpu es el fx 6300).   Lograste solucionarlo?
    • Hi guys. Well, this is my second day of troubles, I touched everything, I installed max like 5 times in the same day, trying to figure out things and well. My Mac it display my graphic card on the #About this Mac tab With 2047MB ( So I guess all is right ) I installed the latest nvida drivers and on clover I activated the NvidaWeb. The problem is the resolution. Max resolution allowed is 1280 x 1024 and 800 x 600. I used to boot with nvd_drv 1 with nvd dry 0, I used to boot with all that things, and without them.  BUT No way to fix the resolution. Someone knows what-s going wrong and how can I fix it? Bdw im using iMac14,2 and OS X Sierra 10.12.3 Im connecting to the screen with DVI adapter. ( Maybe that causes the problem ) But it shows Im running 2047 MB so... idk why I can't change resolution. Thanks! ================================= SOLVED EDIT: Hi guys, in Display Resolution, I just set it in "Default for display" and after that pressing "THE WINDOWS BUTTON KEY, IN MY CASE, IDK WHAT KEY IS THAT IN MAC KEYBOARD, I THINK THE CONTROL ONE OR IDK" PRESSING that key I selected Scaled, and it appears more options and resolutions. There is a video on youtube about that called "Mac OS X Display Resolution" If someone has the same trouble.
    • Hello , i have a big problem , help me please, i have installed properly Mac OS Sierra , but now i can’t boot Windows 10, when i click on a image , which has written for example boot Windows from legacy hd3 , it blocks on an image with the Apple sign on an hard disk image, and when i enter the bios i can’t see tue hard disk in boot options, how can i add Images? Pleaseeeee
    • Im trying to install MacOSierra on Alienware 15 r2,  512ssd nvme 951 and 120gb intel sataIII samsung, i6820 hk 980m, intel 530. Ofter many attempts i solved a lot of erros during the installation, and finnaly i found out that macOs does not suport SSD. I created a patch for my ssds but now, i have this error: ACPI ERROR; and last: AppleNVMe Assert failed;  2 SSD: // Inject bogus class-code for NVMe SSD to prevent IONVMeFamily.kext from loading
      DefinitionBlock("", "SSDT", 2, "hack", "NVMe-Pcc", 0)
      {
          External(_SB.PCI0.PEG0, DeviceObj)
          Method(_SB.PCI0.PEG0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
          External(_SB.PCI0.SAT0, DeviceObj)
          Method(_SB.PCI0.SAT0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
      }
      //EOF   I did the patch in virtual machine as they instructed. but still nothing.
    • Hey!  I successfully installed macOS Sierra with the Version SierraAMD v3 on my AMD Pc.  But after setting up the PostInstall via Terminal, the OS stops booting at this line : ioconsoleusers: gioscreenlockstate 3, hs 0, bs 0, now 0, sm 0x0 Any solutions?    My System Specs: Mainboard: Asrock 970 Pro3 r2.0 Processor: AMD FX-6300 Graphics: Sapphire Radeon RX460 4GB   Thanks!
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,534

×