bootloaders and OSX version upgrades - Troubleshooting - Hackintosh Zone Jump to content
  • 0
AnyBodyElse

bootloaders and OSX version upgrades

Question

bootloaders and OSX version upgrades

Let us see if I understand this correctly. I understand the general purpose of a bootloader is to be recognized by the BIOS and then to initiate the OS. The bootloader has to be therefore specific for the OS.

What we are doing when be build a Hackintosh is to create some sort of bridge bootloader or is it a complete stealth interceptor that replaces the OS’s native bootloader?

I ask this because when I first created a Snow Leopard Hackintosh, I could download and install the updates like normal but when I install the version upgrades Lion and Mountain Lion, I cannot do it from within the OS like a real Mac. I think this is because of the hand-off between the bootloader and the OS and the fact that Apple likes to reboot and do the entire upgrade from a fresh boot prior to entering the OS and is probably unable to enter into its perceived bootloader (unlike a Windows machine that starts the install from within Windows and then reboots and installs the remainder that it cannot do from within Windows).

So does this mean that for the foreseeable life of my Hackintosh each version upgrade will by necessity be a clean install?

I did at one time install Snow Leopard merely by using the Mod CD and switching discs but then the Apple Store would not recognize me as a Mac and I could not even download my already paid for Mountain Lion. So for me it was never a viable install, as many times as I tried to tweak it after the install and re-installs. I could never straighten that out.

So I ended up at various times trying several different ways of installing the Mac OS - the TonyMac way, some other one that I forget (it was my first attempt and was a Clover bootloader and then one with a Chameleon, even a Chimera variant). Each time re-installing and tweaking to get the best I could. My current install is an iATKOS Lion (I had previously tried their Snow Leopard). I haven’t tried to ferret out the sound issue but at least it lets me install my driver from Nvidia and install it and all the rest of the hardware seems to be cool; and it lets me download my purchases from the Apple Store.

But to be a truly viable OS for me, I have to be able to do an OS version upgrade and not a clean install and all of that re-tweaking and re-importing of my stuff. So, do I ascertain the situation correctly? And is my goal unattainable?

I would like to thank all of the efforts of all of the OS86 communities and their install kits, advice and tools. It is a truly fantastic world. Coming of age in the 1960s, I value my personal space and privacy and so I need something to replace Windows as the Win 10 evil intentions are filtering into my beloved Win 7 build and so I am so cautious with updates that I am probably letting my computer become vulnerable. This foray into the Hackintosh world was my way of evaluating the Mac OS – trying to gain an understanding by using and following the evolution of the OS. I love the pursuit of understanding this OS and its inspiration the Mac OS.

 

 

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $85.17 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hi, everyone, thanks for your time.
      I'm trying to fresh install macOS 10.13.1 (Build 17B48). I'm trying to do this by free myself from multibeast and by put kexts in EFI/CLOVER/kexts/10.3 and set a good config.plist.

      I have this famous issue in verbose mode and can't boot.
      IOConsoleUsers: time(0) 0->0, lin 0, llk 1,
      IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0
        It's looks like your own issue.

      Every time, i can boot the first time. I start my post-install by install the web drivers automatically served by Nvidia. And never be able to boot again…
      I didn't found any plist option that permit to boot over this issue…
      help… !

      My list of kexts and my config.plist is joined.
      Thanks for your time…


      Here are my list of used kexts kexts/10.13 folder : NvidiaGraphicsFixup.kext    v 1.1.3 AppleALC.kext
      AtherosE2200Ethernet.kext    v 1.2.0
      FakePCIID_XHCIMux.kext        v 2.2.1
      FakePCIID.kext            v 1.3.9
      FakeSMC_ACPISensors.kext    v 6.25-333-g05e0f4be.1759
      FakeSMC_CPUSensors.kext        v 6.25-333-g05e0f4be.1759
      FakeSMC_GPUSensors.kext        v 6.25-333-g05e0f4be.1759
      FakeSMC_LPCSensors.kext        v 6.25-333-g05e0f4be.1759
      FakeSMC.kext            v 6.25-333-g05e0f4be.1759
      HDMIAudio.kext            v 1.0
      IntelMausiEthernet.kext        v 2.3.0
      Lilu.kext            v 1.2.0
      Shiki.kext            v 2.0.5
      USBInjectAll.kext        0.6.2 Driver64UEFI folder apfs.efi
      AppleImageCodec-64.efi
      AppleKeyAggregator-64.efi
      AppleUITheme-64.efi
      DataHubDxe-64.efi
      EmuVariableUefi-64.efi
      FirmwareVolume-64.efi
      FSInject-64.efi
      HFSPlus.efi
      NTFS.efi
      OsxAptioFix2Drv-64.efi
      OsxFatBinaryDrv-64.efi
      SMCHelper-64.efi
      VBoxHfs-64.efi

      Gigabyte GA-Z170X-Gaming 5 | i7-6700(not K) | GTX980ti - OS on SSD.
    • Hi everyone, i got acer Aspire Icore 3 Laptop, and i've trie many installs, however, none of those worked on this laptop, even typing -x -v, never get the install menu, some of the run until the screen flash and reboot's again and again,, Anyone can give me a tip, i would try Yosemite, cause i got MacBook 5.1 can't upgrade to sierra/High Sierra ( well i can with a patch, but can't get the sierra installer ) i've put all the laptop specs on the screenshot.  i think all is components are compatible with mac,, above. Thanks in advance.file:///Users/Memphis/Downloads/Acer specs.png  
    • i am trying to install yosemite on a asus m2n sli deluxe chipset NVIDIA amd Athlon 64 X2 5600+ ATI Radeon HD 4800   and still i am stuck at pci configuration begin or console error. i tried several kernels and graphic cards with no results   i found some kext (no pci ea) now i come to the screen with language. and then it freezes   I’ve tried several thing but i am stuck is there anyone that can help
    • I've created install media with MacPawn as well as with Unibeast from High Sierra AppStore DMG ; The USB disk creation went smoothly, but when I try to boot from these disks all I get is a blinking cursor on top left of the screen, nothing else ... My Mac / Hackintosh : Asus P5Q Intel Core 2 Quad CPU Q8300 @ 2.50 GHz 8,00 GB RAM AMD Radeon HD 6450 Legacy IDE / ATA : 200 GB SATA : 320GB SSD : Kingston 120GB
    • Please install Niresh Yosemite now, at the first boot after installation i have full resolution with the intel hd 3000. after repairing permissions etc etc, i do not have any more acceleration at the new reboot. Sometimes by booting pennete I have acceleration graphic, starting from hard disk n. Ah, I got the Chameleon bootloader
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,539

    Latest File
    By rembrandt63

    421    0

×