Can't get kextd port, AppleACPICPU timed out, waiting for DSMOS - Troubleshooting - Hackintosh Zone Jump to content
  • 0
Rico Cremer

Can't get kextd port, AppleACPICPU timed out, waiting for DSMOS

Question

Can't get kextd port, AppleACPICPU timed out, waiting for DSMOS

Hi,

I am running into a weird problem. I am currently running macOS Sierra 10.12.3. At the time of installing it was 10.12.2, which I eventually updated to 10.12.3 without problems. I installed it vanilla. I will describe the process:

(I was on El Capitan at this time)

  1. I downloaded Sierra 10.12.2 from the App Store
  2. I restored the Sierra Installer to my 16GB USB 2.0 stick using the following method:
    1. I mounted the InstallESD.dmg image, found inside the Sierra installer app package
    2. I restored the BaseSystem.dmg image, found inside the InstallESD.dmg image, to my usb using Disk Utility
    3. I copied over the packages folder inside the InstallESD.dmg image, to the /system/installation folder on my USB stick
    4. I copied over "BaseSystem.dmg", "AppleDiagnostics.dmg", "BaseSystem.chunklist" and "AppleDiagnostics.chunklist" files from the InstallESD.dmg to the root of my USB stick
  3. I used Pacifist to extract the kernel, and placed it in the /System/Library/Kernels folder on my USB Stick
  4. Installed Enoch rev.2839 to my USB stick
  5. Installed Sierra just fine

Now, I replaced my harddrive with an 120GB SSD and wanted to do a clean install of macOS on it. So I downloaded Sierra 10.12.3 from the AppStore and followed the same procedure as described above, booted my system from the usb installer and.... Nothing. I am getting a weird error:

Can't get kextd port.
busy timeout[0]. (240s), kextd wait(0); 'AppleACPICPU', 'display', 'pci1002,aa98', 'AZAL', 'IOUSBHostInterface', 'IOUSBHostInterface', 'IOUSBHostInterface', 'PX43', 'UAR1', 'UAR2', 'IOResources'
Waiting for DSMOS...

And there it freezes.

Like I said, I've installed Sierra 10.12.2 before and did not have any issues so I don't understand completely why it won't let me do a clean install of Sierra 10.12.3. Other than the harddrive, nothing else changed, so I thought it might be because of the SSD. Though, booting up the installer with the old harddrive in gives me the same result.

Any ideas?

Thanks in advance

Motherboard: NEC VL280U, Intel G33/P35 chipset
CPU: Intel Core2Quad Q9450, 2,66Ghz
RAM: 4GB (2x2GB) DDR2 667Mhz
GFX: Sapphire Radeon HD 6450, 1GB Low-Profile

DSC_0026.jpg

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Nevermind, I fixed it already. I think something went wrong with copying fakesmc.kext to /extra/extensions. I copied it again and now the installer boots without problems.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $48.99 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hello, friends, I need your help. I am using  Motherboard: Asus H81M-CS Processor:  Intel Core i3-4130 Graphics: Intel HD Graphics 4400 I connected monitor via VGA port.   Everything is working great. Only issue right now I am having is graphics with VGA Port. Can any one suggest me to solve this issue?
    • It's because when you update, the kernel is replaced & so are the kexts. You need to either know how to use Terminal to copy the files after booting into your USB OR hook up your Start Disk Hard Drive to another Hack or Mac & copy over the proper kernel to System/Library/Kernels/ & also use kextwizard to install the kexts required as well & then repair cache. It's not that complicated if you have another Mac or Hack(intosh) to connect your drive to. There are some tutorials online. I'm by no means a pro at this at all, but I couldn't believe no one had replied to anyone here. I'm actually in the exact same situation, just finished updating my Yosemite Zone 10.10 to 10.10.5 through AppStore & it won't boot back in, then I remembered when I did this last time I had to connect my HD to another mac & copy over files, but I can't remember exact files so I came here to look for them & found this thread. I have been successful in getting an old MSI Platinum35 mobo with the 771/775 mod & Xeon x5460 with AMD 6850 running Sierra. I have been successful getting a newer MSI A88XM Gaming Mobo with x4 760k & AMD 6670 running Mavericks, then Yosemite, then High Sierra, and recently tested Sierra & it worked too. One thing though is that with Sierra & High Sierra the screen flickered different colors & I needed to download a thing called SwitchResZ & change the setting from "Billions of Colors" to "Millions of Colors" & it fixed it both times, even after I uninstalled it, the screen flickering was gone,.. So I have been through a few different processes (not including the updates like 10.10 to 10.10.5) But I am the farthest thing from a pro. Just followed tutorials, googled  & used distros, I think DeeKay was first one for Mavericks, then Yosemite Zone, Sierra Zone, & finally High Sierra Zone. But my digi 002r worked on all with the AVID 003 family 11.1.3 driver, except when it came to high sierra. For some reason it has sync issues with Midi/audio. Says something about not recognizing clock speed of 43,121Khz or something (cuz it should be 44.1Khz, or 48Khz etc) But it only happens on High Sierra. On Yosemite I had to do a trick cuz the play bar's timing was off, to fix it I went into bios & changed my multiplier from 100 to 103 so instead of my cpu running at 3.6Ghz, it was like 3.9Ghz. But for some reason that fixed it & Yosemite was stable, rarely (if ever) did it crash. But Sierra crashes all the time so I can't make music on it anymore, for some reason I don't think it was like this at first...maybe something I installed. Only reason why I changed was to keep up with Logic X updates. My Sierra build is up to date with Logic X 10.4 & Digi 002r runs great (11.1.3 driver) but like I said it crashes alot & I don't know why. So my thought was to return to Yosemite 10.10 & update to 10.10.5 like I did b4 & downgrade Logic X to 10.3 or 10.2.4(can't remember). So I got to find those files & instructions again to put the proper kernel & texts back that the update erased. That's what ya'll need to do as well. When I find it I will come back & edit my post or just post a new one.
    • Hai,

      Is there a way to increase video memory of a 

      AMD A4-6210 APU

      AMD Radeon R3 Graphics 1.8 Ghz

      it is not for gaming, but only to seen movies ect
    • So I tried to install Mac OS X Sierra on my computer with the following specs :   - Intel Core i5 650 3.20GHZ - 12GB RAM DDR3 - 2 HDD (.1TB , 250GB ) - Nvidia Geforce 210 1GB VRAM DDR3   Everything was cool at first the installation went smoothly with no problems, after setting up everything I noticed that the graphics card has been detected by the systems but there is no acceleration and the resolution is 1024x768, I couldn’t change it   I tried a lot of kext drivers from multiple websites but no success, last kext crashes my os, I start getting black screen after the login page, and the computer restart it self immediately, so I decided to mess with the clover options to find if I can enable the graphics card from there, and WALLAA, the magic happened, I went to clover options then > Graphics Injector Menu > I checked : InjectNvidia option, and I checked : Use NVIDIA WEB Drivers   Note : I already installed Nvidia web drivers previously so you do that too before trying this method   After the restart it took longer then the usual to boot up, but once it got to the login page I noticed that the acceleration is working perfectly and the graphics has no bugs like before.   So until now everything is working fine and I’m enjoying my experience with Mac Sierra  
    • HI, I have the same issue. I have integrated Intel HD4000 and nVidia 620m. I tried with IGPEnabler, GraphicsEnabler and nv_disabled bootflags but none of them helped, it just got me additional kernel panic "AppleUSBHostPort: :disconnect: persistant enumeration failures". I also don't have option to turn off any of my graphic cards in BIOS.  Is there any solution to this issue?
  • Download Statistics

    • Files
      848
    • Comments
      2,135
    • Reviews
      2,568

    Latest File
    By Vale1831

    5    0

×