How install El capitan or sierra for Hp pavilion 15n209tx - OS X EL Capitan 10.11 - Hackintosh Zone Jump to content
  • 0
rahulroxx

How install El capitan or sierra for Hp pavilion 15n209tx

Question

How install El capitan or sierra for Hp pavilion 15n209tx

Please if anyone can guide me to install sierra or el capitan on hp pavilion 15n 209tx it would be really great 

Thanks, 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I am not familiar with your hardware, so I will give you the basics of how to make an USB Installer to start with. If you're able to boot the installer, but it won't let you install macOS, then please report back with more information such as your system specifications and the errors you get.

If you are already on macOS, download El Capitan or Sierra from the App Store. 

Then there are two ways to make an USB installer:

  1. By using macpwn (easiest way)
    For El Capitan: download link
    For Sierra: download link
    You can find a full guide of how to do it for El Capitan here and for Sierra here
  2. By making it yourself 
    1. Open Terminal
    2. write "defaults write com.apple.finder AppleShowAllFiles YES killall Finder" without the quotation marks and press enter
    3. Go to Finder > Applications
    4. Right-click on the macOS installer app > Show Contents
    5. Navigate to Contents > SharedSupport and mount InstallESD.dmg
    6. Inside the mounted InstallESD, mount BaseSystem.dmg
    7. If you haven't already, plug your USB stick in
    8. Open Disk Utility and restore BaseSystem.dmg to your USB stick
      click on your USB partition, choose 'restore' and choose 'OS X Base System' as source
    9. Open your USB in Finder and navigate to System > Installation and delete the 'Packages' symlink
    10. Go back to your mounted InstallESD.dmg and copy the Packages folder to the System > Installation directory on your USB stick
    11. Again, go back to your mounted InstallESD.dmg and copy "BaseSystem.dmg", "BaseSystem.chunklist", "AppleDiagnostics.dmg" and "AppleDiagnostics.chunklist” to the root directory of your USB installer
    12. Extract the kernel (in case you get a kernel not found error upon boot)
      1. Download Pacifist
      2. Navigate to your Packages folder, right click on 'Essentials.pkg' and chose 'Open with > Pacifist'
      3. Within Pacifist, navigate to System > Library > Kernels
      4. Highlight The 'Kernels' Folder and extract it to Your USB > System > Library
    13. Download your preferred bootloader (I am using Enoch rev2839, which is based on Chameleon)
      Note: If you are using Chameleon/Enoch, make sure that you enable Kernel Patch KernelBooter_Kexts
    14. Install the bootloader to your USB stick
    15. Disable SIP (System Integrity Protection)
      1. Chameleon/Enoch
        Open your /Extra/org.chameleon.Boot.plist and add this entry:
        <key>CsrActiveConfig</key>
        <string>3</string>
      2. Clover
        Open your Clover config.plist and add this entry:
        <key>RtVariables</key>
        <dict>
            <key>CsrActiveConfig</key>
            <string>0x3</string>
           <key>BooterConfig</key>
           <string>0x28</string>
        </dict>

        note: you can use any of these values: 0x3 (SIP partially disabled, Loads unsigned kexts), 0x67 (SIP completely disabled)
    16. Download fakeSMC and  NullCPUPowerManagement kexts and put them on your USB > Library > Extensions
    17. Reboot your laptop, enter your BIOS and if available, turn off vt-d and set HPET to 64-bit
    18. Boot from your USB stick, and use bootflags -v -f

With El Capitan, the installer gave me an error, saying that it was already installed on my system, which obviously was not the case. I fixed that by putting my smbios.plist (imac10,1) in the /Extra/ folder on my USB.

If you are not on an Mac/Hackintosh already, things get a little more difficult. If you could get yourself a copy of El Capitan / Sierra, you can however do it from Windows too, using TransMac.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $40.92 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Do you have an AMD or Intel processor?
    • sorry to bother you guys    specs:   xeon x3230 gigabyte ep43-UD3l motherboard 6gb ddr2 ram radeon 5450 1gb   i load clover and select boot drive and it shows me    ++++++++++++++++++++++++++   then restarts   what am i doing wrong? 
    • I have the updated Lilu.kext loaded and now tried loading the Nvidia GraphicsFixup.kext too. With the GT 610 installed, there is no difference (no difference with the HD4600 either). I posted a photo where it repeats over and over (3rd item in this Photos album) https://www.icloud.com/sharedalbum/#B0f5M7GFPGEAfHW Should I try re-installing HS with your new AMD release? Try a different video card? Any help is appreciated Niresh! Martin
    • @Niresh i forgot to say that that error was given because i have a Samsung M2 NVMe 960pro. I tried to remove it and it kinda worked but with a lot of bugs even during the installation. I can't remember everything clearly now cause it's been like 4 months ago
    • Thanks. I Have One Ethernet And One Wifi. Here Is The Terminal Log :  iMac:~ marcus$ lspci -nn 00:00.0 Class [0600]: Device [8086:190f] (rev 07) 00:01.0 Class [0604]: Device [8086:1901] (rev 07) 00:08.0 Class [0880]: Device [8086:1911] 00:14.0 Class [0c03]: Device [8086:a12f] (rev 31) 00:14.2 Class [1180]: Device [8086:a131] (rev 31) 00:16.0 Class [0780]: Device [8086:a13a] (rev 31) 00:17.0 Class [0106]: Device [8086:a102] (rev 31) 00:1c.0 Class [0604]: Device [8086:a110] (rev f1) 00:1c.2 Class [0604]: Device [8086:a112] (rev f1) 00:1d.0 Class [0604]: Device [8086:a118] (rev f1) 00:1d.2 Class [0604]: Device [8086:a11a] (rev f1) 00:1d.3 Class [0604]: Device [8086:a11b] (rev f1) 00:1f.0 Class [0601]: Device [8086:a145] (rev 31) 00:1f.2 Class [0580]: Device [8086:a121] (rev 31) 00:1f.3 Class [0403]: Device [8086:a170] (rev 31) 00:1f.4 Class [0c05]: Device [8086:a123] (rev 31) 01:00.0 Class [0300]: Device [10de:1c82] (rev a1) 01:00.1 Class [0403]: Device [10de:0fb9] (rev a1) 03:00.0 Class [0c03]: Device [1b21:1242] 05:00.0 Class [0604]: Device [1b21:1080] (rev 03) 07:00.0 Class [0200]: Device [10ec:8168] (rev 15)
  • Download Statistics

    • Files
      845
    • Comments
      2,130
    • Reviews
      2,555

    Latest File
    By 8osm3rka

    21    0

×