Old (but cheap) Intel Xeon E5450 Sierra build - Yosemite - Hackintosh Zone Jump to content
Rico Cremer

Old (but cheap) Intel Xeon E5450 Sierra build

Recommended Posts

Rico Cremer    8

Old (but cheap) Intel Core2Quad Xeon 5450 Sierra build

nec-refurbished-computer-vl_1.jpg

I got hands on a cheap (old!) NEC PowerMate VL280 SFF system (I bought it for €25 -> around $27), based on an Intel dual core E2200 processor.

The current specifications are:

CPU: Intel Core2Quad Q9450, 266Ghz  Xeon 5450 (Quad Core), 3Ghz
RAM: 4GB DDR2 800MHz
GFX: Sapphire Radeon HD 6450 1GB GDDR3 Gigabyte GT 710 2GB GDDR3, Low Profile 
2 x SanDisk SDSSDA120G 120GB SSD
1TB Seagate Barracuda 7200rpm HDD
With a cheap Bluetooth 4.0 USB dongle

The motherboard is a mBTX model, produced by Foxxconn especially for NEC (Foxconn VL280u).
It uses the G31/ICH7 chipsets
It has HDA Azalia audio, Realtek RTL8111C Ethernet and intel GMA3100 integrated graphics

I am currently running macOS Sierra 10.12.3 on it (Updated from Yosemite -> El Capitan -> Sierra).
Eventhough it's a very old setup, the machine is working really well. No hiccups, no lags. I run Adobe Photoshop CC 2017 without problems and I am also able to play games through steam (for as far as my graphics card will let me, of course)

The kexts I'm using:

iMac-van-Rico:~ rico$ kextstat | grep -v com.apple

Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>

   13    0 0xffffff7f80b52000 0x2000     0x2000     org.tgwbd.driver.NullCPUPowerManagement (1.0.0d2) 93D39664-55FB-9220-39AD-A436B33DB160 <7 4 3>

   22    4 0xffffff7f80c91000 0x19000    0x19000    org.netkas.driver.FakeSMC (1421) 8252BBE6-2A73-35AC-919C-10AF2BE3909B <10 7 5 4 3 1>

   26    0 0xffffff7f80ced000 0x5000     0x5000     org.hwsensors.driver.CPUSensors (1421) B55A2F0E-B46D-37C8-A97B-7AE135B31C79 <22 7 5 4 3>

   37    0 0xffffff7f80dba000 0x8000     0x8000     org.hwsensors.driver.ACPISensors (1421) 155F9C59-516A-3F60-AF5F-A88AF5A50C73 <22 10 7 5 4 3>

   44    0 0xffffff7f80e58000 0x13000    0x13000    org.hwsensors.driver.LPCSensors (1421) 4330388E-D0CE-3F11-8FEA-B59093997949 <22 11 10 7 5 4 3>

   47    0 0xffffff7f80ea5000 0x67000    0x67000    com.insanelymac.RealtekRTL8111 (2.2.1) FDD47F63-B851-312E-AC10-047DCBD6708F <46 11 5 4 3 1>

   49    0 0xffffff7f80f19000 0x15000    0x15000    org.hwsensors.driver.GPUSensors (1421) FB18C477-DB7C-3FEB-9213-021111B225FC <22 11 10 7 5 4 3>

Other than sleep, everything works. Or well, the system goes to sleep correctly, but when it wakes up my ethernet, mouse, keyboard and monitor are not functioning. It's not bothering me, though. In energy settings I disabled my computer from going into sleep, except for my monitor.

Also, even though my graphics card worked OOB, it was using the default radeon framebuffer so I patched the Ipomoea framebuffer to match with my graphicscard.

Schermafbeelding 2017-02-19 om 19.31.54.png

Schermafbeelding 2017-02-19 om 19.31.11.png


Todo:
Find a cheap socket 775 motherboard with DDR3 support so that I can put the system in a normal mATX case
Buy the Xeon E5472 (€15 on AliExpress) and mod it to work on the 775 socket
Upgrade the RAM
Upgrade the Graphics card

 

UPDATE
I replaced the Radeon HD 6450 with a Gigabyte GT 710 and sleep/wake is fully functional. Also, I replaced the Q9450 with a Xeon E5450.
AppStore/iTunes/iCloud/iMessage/FaceTime fully functional.

 

Share this post


Link to post
Share on other sites
Cosmos    0

Hello Rico,

I'm Cosmos from France ! =)

I have on my desktop the same motherboard, a NEC Vl280U. I would like to put change my CPU for a Xeon like you (it seems to be the best CPU without outpass the limit of 95W).

My question is how to update the BIOS before ordering my new cpu on ebay or aliexpress ? There is nothing on the website of NEC, neither on Foxconn's one.

Will I have to do something else after ? 

My OS is Ubuntu 17.04 and I am quite a novice in all those things ^^

 

Thank you for your help =)

 

Best regards,

Cosmos

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $40.21 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • hi   ok I have been struggling with this for the past 2 weeks. I have installed and uninstalled Sierra more times than I can count and its been driving me potty .... have only cracked it today.  what you need to do is download create a vanilla usb stick with Sierra.  in order to do this I downloaded Yosemite.zone from the distroes  and created a usb stick.  the installed Yosemite once I was in Yosemite  ( the gfx work in this disto) I downloaded a copy of Sierra from the store..  you will have to search the net for the direct link.. I then created a bootable Sierra usb stick using unit beast, I selected legacy boot loader with no gfx injected. I then installed Sierra from this. once Sierra is installed boot from the usb and select your installed Sierra. iff all goes well you should have a working Sierra install with the gfx acceleration working.  I think the problem is with the type of Mac that Sierra thinks it is with everything working my system info is showing a iMac 27" 14.2 .  I have tried installing a boot loader on the main drive with no success so as a workaround you will have to use your usb stick. pics below of my system info  I hope this helped.  https://photos.app.goo.gl/PToVZOxq0UN9c5BR2 I also just noticed whilst I was trying to get thing working I copied a modified andradeonx4000.kext into the root drive of the Sierra stick. I don't know if this has had any effect on the install might be worth doing the same thing andy
    • Hello, I installed macOS High Sierra 10.13 on my Windows laptop. I installed them so I could dual boot them. It took me 2 day's to perfectionize the macOS because of the .kext files. All the Kext files went good except for graphic and Synaptics. If I install Synaptics, I can move the mouse but it zooms in and it gets stuck back into the corners. So I only installed Generic Touch Pad driver and that works fine. 

      Anyhow I thought everything was perfect until I opened Safari yesterday which came with glitches it stutters when scrolling. It's something like this https://www.youtube.com/results?search_query=graphic+glitches+hackintosh only worse. I searched a lot but I found nothing on AMD drivers for my laptop. I really like this macOS, and I want it to be perfect. Is that possible? Maybe with another macOS type/version? O'yeah, when I log in, the vertical lines appear as in the youtube video is that normal or is that because I don't have an graphic driver installed? I really hope on some positive answers, and I thank everyone for his time to read and react on this. Thank you
    • Hello.I am trying to install os x yosemite in my hp laptop but i cant get into the installer of os x yosemite. I already tried with this boot flags: /hp /hp 1 /haswell -v -x And the result is same, i stuck in a gray screen with the logo of apple. The specs of my hp laptop are: Intel(R) Celeron(R) CPU N3060 1,60 GHz up to 2,48 GHz (2 cores) 4GB RAM DDR3 Intel HD Graphics 500GB HDD (approximately) Does anyone know how to fix it? Thanks PD:sorry for my bad english, i talk spanish
    • Hello, I got macOS Sierra to work on my vostro 230 and I need to find drivers. I mostly just need graphics drivers (just integrated G41 graphics) and Broadcom Network drivers. > PLEASE DON'T GIVE ME AN EXPLANATION JUST GIVE ME DRIVERS. < CPU: Intel Core 2 Duo E7500 2.93 GHZ GPU: I could switch between a EVGA 610 or Intel G41 graphics. RAM: 4 GB DDR3 1333 MHZ. PSU: I don't know if this makes a difference but I got this Vostro when the PSU failed and I put a Optiplex 360 PSU in it.  
    • Hello,
      i successfully installed macOS Sierra version 10.12.3 on my laptop lenovo z500:
      intel core i5, 8 gb ram, 128 kingston ssd.
      but my problem no driver works except camera and usb.
      sound , wifi , eathernet and display drivers not working and i can't drive. please help, this my first time to install hackintosh and i can't do any thing
      thanks in advance.
  • Download Statistics

    • Files
      841
    • Comments
      2,129
    • Reviews
      2,532

×

Important Information

By using this site, you agree to our Terms of Use.